Help for exlink serial connection

This forum for information that related with C series hardware instead of firmware/software.
Post Reply

tempinbox
Posts: 317
Joined: Wed May 11, 2011 7:00 pm

Help for exlink serial connection

Post by tempinbox » Tue Nov 22, 2011 8:48 pm

Hi i buy one eminent em1116 usb to serial cable that has in it the Chipset: Prolific PL2303
--> http://www.eminent-online.com/en/produc ... sion-.html
for connect my pc with the c6000 tv and get serial consolle to delete the hotel mode hack and get back one virgin tv.
But there is a problem the connector on the tv side is a 9 Sub-D male and the dv-in connector of my tv is a db15 :shock: female (right?). So i buy a vga adapter that is a db9 female on one side and db-15 male on the tv side, i connect cable and adapater to tv and the usb to my pc, set the speed to 115200, 8n1 no flow controll... i'm using windows 7 home premium and putty the connection is open but on putty consolle i get only a black screen... i try to open the connection and starts the tv withouth all cable except for power and ex-link cable but the result was the same only black screen on putty consolle so what i'm doing wrong?
I buy 2 exempensive cable for nothing?
Please help me...
what i can do?
Is maybe because i have 3011 fw?
please reply i have to format mtd-rwarea to reset usb hack,
i set watch dog off on service menu and the rs232 to debug maybe i have to try with uart or logic?

User avatar
juusso
SamyGO Moderator
Posts: 10125
Joined: Sun Mar 07, 2010 6:20 pm

Re: Help for exlink serial connection

Post by juusso » Tue Nov 22, 2011 8:54 pm

rs232 debug is set in service menu already?
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

tempinbox
Posts: 317
Joined: Wed May 11, 2011 7:00 pm

Re: Help for exlink serial connection

Post by tempinbox » Tue Nov 22, 2011 9:29 pm

Yes Rs232 is set to debug and the watchdog is set to off.
After i start thetv first it show the messagge no signal... then if i wait for 2 minutes the red led of power is blinking
Last edited by tempinbox on Tue Nov 22, 2011 9:32 pm, edited 1 time in total.

User avatar
juusso
SamyGO Moderator
Posts: 10125
Joined: Sun Mar 07, 2010 6:20 pm

Re: Help for exlink serial connection

Post by juusso » Tue Nov 22, 2011 9:32 pm

Then your pins aren`t connected properly. No more reasons to don`t work.
drivers for cable also ok?
cable test - ok? (connect tx and rx with each other and see if you get typed symbols in terminal)...
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

tempinbox
Posts: 317
Joined: Wed May 11, 2011 7:00 pm

Re: Help for exlink serial connection

Post by tempinbox » Thu Nov 24, 2011 2:20 pm

juuso wrote:Then your pins aren`t connected properly. No more reasons to don`t work.
drivers for cable also ok?
cable test - ok? (connect tx and rx with each other and see if you get typed symbols in terminal)...
I try to connect with a jumper the second and third pin of db9 connector of my serial cable and i get back the typed symbols in terminal, then i try to connect with a jumper the second and third pins of my hd15 pins connector and the result was the same so i think that the cable and the adpator works so why i don't get info from tv?
For my test i use the program RS232 Terminal 1.2.0. and in it the data that i send with tx i get back from rx so the cable and the adaptor seems to works...right?
(The second pin is RX The third pin is TX)
Any other suggestions?

User avatar
juusso
SamyGO Moderator
Posts: 10125
Joined: Sun Mar 07, 2010 6:20 pm

Re: Help for exlink serial connection

Post by juusso » Thu Nov 24, 2011 2:46 pm

Swap rx and tx on adapter :-)
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

User avatar
erdem_ua
SamyGO Admin
Posts: 3102
Joined: Thu Oct 01, 2009 6:02 am
Location: Istanbul, Turkey
Contact:

Re: Help for exlink serial connection

Post by erdem_ua » Fri Dec 02, 2011 5:29 pm

Do you sue that if this cable output is TTL? I don't think if its TTL but instead using +8 -8 volt. This might problem...
TV serial port cannot controlled with high voltage RS232 but "TTL" voltages, like v3.3...

I don't know if you already burn your serial port at TV but you can try to buy this ultra pricey dongle for your job...

nspierbundel
Posts: 84
Joined: Thu Sep 29, 2011 3:08 pm

Re: Help for exlink serial connection

Post by nspierbundel » Fri Dec 02, 2011 5:57 pm

The prolific is default a non ttl !!!
Try the sugested ttl converter.
Hope you didnt smoked the tv
Daniel

tempinbox
Posts: 317
Joined: Wed May 11, 2011 7:00 pm

Re: Help for exlink serial connection

Post by tempinbox » Thu Dec 08, 2011 11:51 pm

Thanks for reply but i dont understand why my cable isn't ttl it has the same chip in it prolific pl2303hx so why isn't ttl?

nspierbundel
Posts: 84
Joined: Thu Sep 29, 2011 3:08 pm

Re: Help for exlink serial connection

Post by nspierbundel » Fri Dec 09, 2011 4:37 pm

Does your proliffic explicitly mention it is ttl ?
I also have prolific 23xx usb to serial. Non ttl.
If it says ttl than I m wrong and it should work.
Have you crossed rx and tx?

Post Reply

Return to “[C] Hardware”