HT-D7100 first impressions

Samsung's BluRay player related hacks.
Post Reply

sbav1
Official SamyGO Developer
Posts: 374
Joined: Fri Jan 15, 2010 10:20 am

HT-D7100 first impressions

Post by sbav1 »

Finally got some time to play with my "brand new" HT-D7100.

It's Firenze (SDP1004) based device with B-FIRHTBEUC firmware. Rooted by "patched downgrade" method. SamyGO extensions do not install properly as widget on this model, but never mind, right now I tested binaries compiled for GAP*/GAS* available in SourceForge, they (mostly) seem to work.

512MB onboard DRAM (two channels), but only 128MB is allocated to the kernel (the rest being wasted by Samsung for internal processing etc.). That's pretty bad , with exeDSP running, only 30-40MB free RAM is left for playing.

Main EEPROM (32KB, on I2C bus #1) is more or less redundant in this model - looks like most configuration/user settings are stored on MMC flash (in /mtd_rwarea/dtv_appstore.dat file ?). Quite surprisingly, 'eeprom-backup' (from chelsea-i2c-eeprom-tools_v02, compiled for B650 TV) still works without any changes ('eeprom-restore': too risky to even try, GPIO pin controlling EEPROM WP/WE is probably completely different).

Serial console pins on the mainboard are clearly labeled (image included) - there is even some kind of connector soldered on the opposite side of the PCB.

Top debug menu turned out to be quite an disappointment - very badly implemented, no Spi debug, no Subsystem debug, hardly anything works as it should. Bad Samsung :).
As a consolation prize, we get some bonus features in there worth mentioning. For example, with:

Code: Select all

[TOP Debug Menu] -> 11 : TD Debug -> 0x02 : ODi Debug -> 0x12 : ODsBarcelonaHdmiTxProcessor -> 0x30 : StartHdcpAuthentication(Stop-0, Start-1)
it's apparently possible to turn off HDCP encryption on HDMI output. Note: not tested with any actual Blu-ray disc yet (BD drive is not operational in my unit), but it seems to work as expected with any other playable content I've tried.

HDCP free BD-Player: that's quite fair-use-friendly by today's standards, especially from Samsung - thank you! ;)
You do not have the required permissions to view the files attached to this post.

arris69
Official SamyGO Developer
Posts: 1700
Joined: Fri Oct 02, 2009 8:52 am
Location: Austria/Vienna (no Kangaroos here)
Contact:

Re: HT-D7100 first impressions

Post by arris69 »

sbav1 wrote:Finally got some time to play with my "brand new" HT-D7100.

It's Firenze (SDP1004) based device with B-FIRHTBEUC firmware. Rooted by "patched downgrade" method. SamyGO extensions do not install properly as widget on this model, but never mind, right now I tested binaries compiled for GAP*/GAS* available in SourceForge, they (mostly) seem to work.
...
binaries are compatible from c series up to e (gap/pas is a good choice :-) ), only thing are the kernel modules.

but if you send me the DUID (you can find it in smarthub -> settings....) i can check whats going on...

chaosmaker
SamyGO Project Donor
Posts: 81
Joined: Tue May 08, 2012 7:03 am

Re: HT-D7100 first impressions

Post by chaosmaker »

Its probably a similar problem as in my HT-D5500, the SamyGO widgets dont work entirely. I have some issues with the modules as they dont insert properly.

sbav1
Official SamyGO Developer
Posts: 374
Joined: Fri Jan 15, 2010 10:20 am

Re: HT-D7100 first impressions

Post by sbav1 »

chaosmaker wrote:I have some issues with the modules as they dont insert properly.
I did some testing yesterday: apparently, modules being installed with SamyGO widget for (some ?) B-FIRHTBEUC devices are from C-series - no wonder they don't insert properly on Firenze ;). Hopefully we will be able to fix this problem in the near future.

arris69
Official SamyGO Developer
Posts: 1700
Joined: Fri Oct 02, 2009 8:52 am
Location: Austria/Vienna (no Kangaroos here)
Contact:

Re: HT-D7100 first impressions

Post by arris69 »

so pls. reinstall the widget, "should" be fixed.
thnx
arris

sbav1
Official SamyGO Developer
Posts: 374
Joined: Fri Jan 15, 2010 10:20 am

Re: HT-D7100 first impressions

Post by sbav1 »

arris69 wrote:so pls. reinstall the widget, "should" be fixed.
SamyGO extensions now working fine after widget reinstall, thanks!

chaosmaker
SamyGO Project Donor
Posts: 81
Joined: Tue May 08, 2012 7:03 am

Re: HT-D7100 first impressions

Post by chaosmaker »

Yup - same here, I do get the virtual USB drive now. Will have to play around and see whether everything is working I'll let you know as soon as I have some time.

sbav1
Official SamyGO Developer
Posts: 374
Joined: Fri Jan 15, 2010 10:20 am

Re: HT-D7100 first impressions

Post by sbav1 »

sbav1 wrote:

Code: Select all

[TOP Debug Menu] -> 11 : TD Debug -> 0x02 : ODi Debug -> 0x12 : ODsBarcelonaHdmiTxProcessor -> 0x30 : StartHdcpAuthentication(Stop-0, Start-1)
In BD-D6900 Top Debug Menu, it's in slightly different place

Code: Select all

[TOP Debug Menu] -> 11 : TD Debug -> 0x02 : TDi Debug -> 0x13 : ODsBarcelonaHdmiTxProcessor -> 0x30 : StartHdcpAuthentication(Stop-0, Start-1)
but it works, too. Also while Blu-ray disc content is being played. Good work, Samsung ;).

Post Reply

Return to “BluRay Players”