[App] Rooting E, F (and H?) Bluray

Samsung's BluRay player related hacks.

zoelechat
Official SamyGO Developer
Posts: 8424
Joined: Fri Apr 12, 2013 7:32 pm
Location: France

Re: [App] Rooting E and F Bluray

Post by zoelechat »

If ever you encounter problems on step to make installation widget appear in Smarthub, here's a report collection:
* Reboot the tv and don't plug the usb drive.
* Open Smart Hub > Apps > More Apps and then put the usb drive and exit from the screen for new device found.
* SamyGO -F widget will appears after that.
finally, i managed to install samygo. after 5 or more attemps the app appeared under "more apps".
The installation widget only shows up when plugging flash usb drive under more apps section.
Biggest hangup seemed to be getting the app to appear in the smarthub. Took several unplug/re-plug cycles while viewing the "more apps" section before the widget appeared.
It should appear automatically after inserting the USB (exit the usb pop-up first) but sometimes you need to exit out of the smarthub and go back for it to get loaded in the smarthub more apps menu.
The "trick" is to let the "New device" screen time out.
ps: replace "TV" by "Bluray Player"
I do NOT receive any PM. Please use forum.

spike2969
SamyGO Project Donor
Posts: 4
Joined: Sun Sep 27, 2015 11:52 am

Re: [App] Rooting E and F Bluray

Post by spike2969 »

zoelechat wrote:
If ever you encounter problems on step to make installation widget appear in Smarthub, here's a report collection:
* Reboot the tv and don't plug the usb drive.
* Open Smart Hub > Apps > More Apps and then put the usb drive and exit from the screen for new device found.
* SamyGO -F widget will appears after that.
finally, i managed to install samygo. after 5 or more attemps the app appeared under "more apps".
The installation widget only shows up when plugging flash usb drive under more apps section.
Biggest hangup seemed to be getting the app to appear in the smarthub. Took several unplug/re-plug cycles while viewing the "more apps" section before the widget appeared.
It should appear automatically after inserting the USB (exit the usb pop-up first) but sometimes you need to exit out of the smarthub and go back for it to get loaded in the smarthub more apps menu.
The "trick" is to let the "New device" screen time out.
ps: replace "TV" by "Bluray Player"
Thanks alot. Worked like a charm. Launched the App and rebooted.
Now trying to get rid of Cinavia.

spike2969
SamyGO Project Donor
Posts: 4
Joined: Sun Sep 27, 2015 11:52 am

Re: [App] Rooting E and F Bluray

Post by spike2969 »

Root worked fine even after reboot can still FTP and Telnet.
But Cinavia doesn't want to go away.
I'll post on the right thread for this issue.

Thanks!

tiflos
SamyGO Project Donor
Posts: 4
Joined: Fri Oct 02, 2015 10:58 am

Re: [App] Rooting E and F Bluray

Post by tiflos »

Why my post are removed?

zoelechat
Official SamyGO Developer
Posts: 8424
Joined: Fri Apr 12, 2013 7:32 pm
Location: France

Re: [App] Rooting E and F Bluray

Post by zoelechat »

tiflos wrote:Why my post are removed?
None of your post(s) has been removed...
Are you talking about that one?: viewtopic.php?f=70&t=8126&p=79091#p79091
Just remember where you post, or check your history :)
I do NOT receive any PM. Please use forum.

tiflos
SamyGO Project Donor
Posts: 4
Joined: Fri Oct 02, 2015 10:58 am

Re: [App] Rooting E and F Bluray

Post by tiflos »

sorry, sorry..... :(

tigol
SamyGO Project Donor
Posts: 7
Joined: Sat Jan 04, 2014 4:24 pm

Re: [App] Rooting E and F Bluray

Post by tigol »

Hi,
I have a BD-E8500.
I successfully installed Samygo App, and ran Web Browser after reboot. From this time, I have no more Samygo app displayed.
Then, I reach the BD through telnet connection.I never found ftp nor nfs connection.
As I thought every thing was OK, I unpluged the USB key. The day after I do not managed to launch the telnet link.
I plugged the USB key... No more success.

Any idea?
regards.
Tigol

NeoMoucha
SamyGO Project Donor
Posts: 86
Joined: Sat Dec 10, 2011 9:18 pm

Re: [App] Rooting E and F Bluray

Post by NeoMoucha »

read post #1 of this thread

!
WARNING!!!! DON'T EXPECT HACK TO BE WORKING CORRECTLY IF YOU EVER UNPLUG ROOTING USB :)!!!!!!
I love SamyGO :)

spinoza
SamyGO Project Donor
Posts: 14
Joined: Fri Oct 31, 2014 8:46 am

Re: [App] Rooting E and F Bluray

Post by spinoza »

I have tested the latest files for f beta bluray (i have f-6500), and i think it is more stable than the previous one. The only problem, is that after a long time (about 3 weeks), the root was disappeared (although i never unplug the usb) . And i had to do the process again. I also use slow starting. But with the previous files, i lost the rooting in about a few days.

TauPan
SamyGO Project Donor
Posts: 9
Joined: Thu Oct 22, 2015 8:27 pm

Re: [App] Rooting E and F Bluray

Post by TauPan »

Hi!

I've applied the procedure on my BD-E8909S with firmware 1018. First time I removed usb stick after booting, I know that was a mistake... Yesterday I tried again and left the stick in the whole time.

Like the other poster with an E-series BD, the SamyGO icon in SmartHub is empty for me.

When I click on it, the installation procedure starts and I see green OK after every line.

Starting the web browser does nothing (except displaying Google).

For me, telnet on port 5023 works all the time, but when I ls /dtv, there's no SGO.env, ftp port is not open.

Sometimes, after one or two reboots, ftp port is open and that way I could install samyGOrc yesterday and disable OTN (yay)!

I would like to have ssh, but the port is closed. When I start dropbear by hand, port 22 is open, but I have no password. Changing the password via telnet gives me "read-only filesystem".

smdb is running, but I see no shares, http port is open but browser says "not found".

After sourcing /dtv/AGO.env and .ashrc by hand, I can start mc in colour, but cursor keys don't work.

For me it looks like the installation didn't work completely.

I think that's all. I would like to decrypt recordings, but chrome warns that dvrdecoder contains malware, also I would prefer software for linux.

Hope somebody can point me at further things to do. Is there a logfile I could post here?

Kind regards

Post Reply

Return to “BluRay Players”