subtitles font

Here is information about customize your B series firmware..:!:This forum is NOT FOR USER questions or problems but DEVELOPER.

User avatar
geo650
Official SamyGO Developer
Posts: 289
Joined: Wed Oct 07, 2009 12:03 pm

Re: subtitles font

Post by geo650 » Wed May 25, 2011 2:06 pm

aquadran wrote:can you post sources for that version ?
I was trying to upload source files several times but every time I got uploading error. I am forced to upload to other folder again. So here it is:
http://sourceforge.net/projects/samygo/ ... p/download
(Outliner 0.2 source code)

aquadran
SamyGO Moderator
Posts: 264
Joined: Fri Oct 16, 2009 9:35 pm
Location: Poland

Re: subtitles font

Post by aquadran » Wed May 25, 2011 4:42 pm

geo650 wrote:
aquadran wrote:can you post sources for that version ?
I was trying to upload source files several times but every time I got uploading error. I am forced to upload to other folder again. So here it is:
http://sourceforge.net/projects/samygo/ ... p/download
(Outliner 0.2 source code)
thanks for sources.
I never have that problem with uploading.

steve-austin
Posts: 78
Joined: Tue Oct 20, 2009 8:04 pm

Re: subtitles font

Post by steve-austin » Wed May 25, 2011 6:21 pm

geo650 wrote:Here you are: Outliner 0.2 with two methods of text enrichment (black bars and shadows), and configurable through INI file:
http://sourceforge.net/projects/samygo/ ... p/download
Hey, is there a way to change the outliner.ini if I launch it at startup and then without press play to enable it?
55B650 and 37B650 with patched firmware

gchirtoaca
Posts: 35
Joined: Wed May 05, 2010 9:31 pm
Location: Bucharest, Romania
Contact:

Re: subtitles font

Post by gchirtoaca » Wed May 25, 2011 7:34 pm

Hi,

I've tried the Outline application 0.2. Some issues for me:
- the black color is not shown, other colours are visible, (tried green, blue); also, the alternative version 0.1 shows the nice semi-black bakground, but it's shifted for me
- the shadow have no visible effect
- no mather what value I set for the offset, the coloured background is shifted to the left, it always starts at the left edge of the screen, tried with 0, 4096, 8192, 16384
Here's a snapshot: http://imageshack.us/photo/my-images/837/cap015.png/
Hope it helps. Thanks.
Samsung LE37B653T5PXZG, T-CHLCIPDEUC 2008.2 firmware, Advanced Mode Patch

User avatar
geo650
Official SamyGO Developer
Posts: 289
Joined: Wed Oct 07, 2009 12:03 pm

Re: subtitles font

Post by geo650 » Wed May 25, 2011 11:44 pm

steve-austin wrote:Hey, is there a way to change the outliner.ini if I launch it at startup and then without press play to enable it?
To start Outliner without user action? I think it is not a good idea. It will eat your TV's resources (CPU power) because of continuous loop (subtitle searching function). It is better to enable Outliner only for watching a movie with subtitles.
gchirtoaca wrote:1) - the black color is not shown, other colours are visible, (tried green, blue); also, the alternative version 0.1 shows the nice semi-black bakground,
2) but it's shifted for me
3) - the shadow have no visible effect
4) - no mather what value I set for the offset, the coloured background is shifted to the left, it always starts at the left edge of the screen, tried with 0, 4096, 8192, 16384
Here's a snapshot: ...
1) did you set valid alpha-channel byte (AA) in INI file? I mean BKG_COLOR=AA000000, not BKG=00000000, because this won't be visible. Try other values, too.
2) & 4) try smaller values; also you can try negative ones, like -20, -30 etc. Try to find correct one. Remember to restart (reboot) TV after editing INI file.
3) It is strange. In my TV black shadow is placed below white subtitles. Try to increase SHADOW_X and SHADOW_Y values in INI file (=1...10, not more).

tgrassi
Posts: 20
Joined: Mon May 03, 2010 6:40 am
Location: Buenos Aires, Argentina

Re: subtitles font

Post by tgrassi » Tue Jun 21, 2011 12:10 am

Trying to figure it out the configuration for UN40B7000 (Latam unit) for shadow option.
The default config sets the black shadow too high and showing one part at right margin and the other part at left margin.
I'll let you know once I find the best config. Thank you for the development!!

yoco
Posts: 52
Joined: Mon Mar 01, 2010 7:14 pm

Re: subtitles font

Post by yoco » Thu Jun 30, 2011 7:31 pm

I tried the Ouliner 2 and I ca see grey shadow, but it's always placed on the left side of the screen. How do I fix this?

Post Reply

Return to “[B] Firmware”

Who is online

Users browsing this forum: No registered users and 1 guest