subtitles font

Here is information about customize your B series firmware..:!:This forum is NOT FOR USER questions or problems but DEVELOPER.

openikev2
Posts: 49
Joined: Sun Sep 12, 2010 6:55 pm

Re: subtitles font

Post by openikev2 » Wed Jul 20, 2011 12:10 pm

Hi,

thank you for the tool. It is what I was looking for a while ago. It works perfect in a LE40B650, with the settings posted by bruintje71 (PIXEL_SHIFT=-1280).

The only problem I see is that black bars appear a little moved to the bottom of the text, in such a way that some of the top part of the subtitle is still outside of the bar. Would it be possible to add a PIXEL_SHIFT also to Y coordinates? Something similar to what it is done for the shadow method, but to the bars. It would be nice also to be able to make bars wider, since sometimes, in multi-line subtitles, a the gap between both lines remains unfilled.

Thanks again and best regards

User avatar
erdem_ua
SamyGO Admin
Posts: 3090
Joined: Thu Oct 01, 2009 6:02 am
Location: Istanbul, Turkey
Contact:

Re: subtitles font

Post by erdem_ua » Sun Jul 31, 2011 2:24 pm

I have a request for next version of this app.
Merge it with "Big & Yellow Subtitles" code.
Since they are related with each other, they needed to be merged.
Also this will give people to adjust font size with ini file config easily and people doesn't require to run two different applet instead of one.
Doesn't it better?

openikev2
Posts: 49
Joined: Sun Sep 12, 2010 6:55 pm

Re: subtitles font

Post by openikev2 » Wed Aug 03, 2011 8:43 pm

openikev2 wrote:Hi,

thank you for the tool. It is what I was looking for a while ago. It works perfect in a LE40B650, with the settings posted by bruintje71 (PIXEL_SHIFT=-1280).

The only problem I see is that black bars appear a little moved to the bottom of the text, in such a way that some of the top part of the subtitle is still outside of the bar. Would it be possible to add a PIXEL_SHIFT also to Y coordinates? Something similar to what it is done for the shadow method, but to the bars. It would be nice also to be able to make bars wider, since sometimes, in multi-line subtitles, a the gap between both lines remains unfilled.

Thanks again and best regards
Hi,

After tons of tries, I figured out better values for PIXEL_SHIFT in my TV. Specifically, using 17920 is better because bars appear exactly behind the text, and not offsetted to the bottom.

Regards

Edit:
I correct myself. After some more tries, 37120 works better. Completely centered black bars. Hope it helps anyone to save some time, because I already spent a lot :)
Regards
Last edited by erdem_ua on Thu Aug 04, 2011 10:35 pm, edited 1 time in total.
Reason: Post merge

pjslf
Posts: 17
Joined: Sat Dec 18, 2010 7:12 pm
Location: Czech Republic

Re: subtitles font

Post by pjslf » Sun Aug 14, 2011 8:13 pm

Hi, i've tried the outliner app on my telly (LE40B550) via injectso, but it does not work. Log file says

Code: Select all

# cat /mtd_ram/Outliner_debug.log
injector() started
self open
loading main module:
/mtd_rwarea/SamyGO/lib/apps/outliner/outliner.so
cannot open main module:
/mtd_rwarea/SamyGO/lib/apps/outliner/outliner.so: undefined symbol: SDL_UnlockSurface
Does this mean my telly is not supported because it lacks SDL support?
LE40B550A5WXXH | T-CHL5DEUC-2008.0 / patched u-boot / network support

User avatar
erdem_ua
SamyGO Admin
Posts: 3090
Joined: Thu Oct 01, 2009 6:02 am
Location: Istanbul, Turkey
Contact:

Re: subtitles font

Post by erdem_ua » Sun Aug 14, 2011 11:51 pm

Definitely. At least described SDL function.

pjslf
Posts: 17
Joined: Sat Dec 18, 2010 7:12 pm
Location: Czech Republic

Re: subtitles font

Post by pjslf » Mon Aug 15, 2011 2:58 pm

Thank you for clarification. Is there any way to include SDL library and its dependencies into a custom built T-CHL5DEUC firmware and get it work?
LE40B550A5WXXH | T-CHL5DEUC-2008.0 / patched u-boot / network support

User avatar
erdem_ua
SamyGO Admin
Posts: 3090
Joined: Thu Oct 01, 2009 6:02 am
Location: Istanbul, Turkey
Contact:

Re: subtitles font

Post by erdem_ua » Mon Aug 15, 2011 3:04 pm

There is always a way but I don't know how to do it. :) If someone know, please talk here.

openikev2
Posts: 49
Joined: Sun Sep 12, 2010 6:55 pm

Re: subtitles font

Post by openikev2 » Wed Aug 31, 2011 5:35 pm

Hi all,

I finally managed to create a cross-compiling environment, so I can play with the code :D
I have patched the outliner code just to make two minor usability changes that are usefull at least for me.

1) You can now disable outliner by pressing "PLAY" key again. This allows to disable outliner without the annoying STOP + RETURN + OK sequence (and being carefull that you are not kicked out of the movie :D).

2) Slightly bigger horizontal margin (MARG_HBAR). Sometimes, when a two-line subtitle appears, a gap between both bars appears. By increasing the value of MARG_HBAR from 4 to 8, this is solved.

I put the file here in case someone finds these changes usefull too.

Regards
You do not have the required permissions to view the files attached to this post.

openikev2
Posts: 49
Joined: Sun Sep 12, 2010 6:55 pm

Re: subtitles font

Post by openikev2 » Sat Sep 03, 2011 2:15 am

nobange01 wrote:I use Outliner and I have it autostarted using injectso. If I then run DCA Module from Content Manager, Outliner doesn't work anymore. Can someone confirm this? My TV is CI+ device.
Confirmed. I think it is related to the key mapping. Anyway, if you load them the other way around (first DCA and the outliner) it should work.

Regards

Post Reply

Return to “[B] Firmware”

Who is online

Users browsing this forum: No registered users and 1 guest