UE40D5500 Boot loop problem. Please help fix.

General Forum for talking area for D series TVs.
Post Reply

drsamygo
Posts: 2
Joined: Sun Jul 14, 2019 8:19 am

UE40D5500 Boot loop problem. Please help fix.

Post by drsamygo »

Hi,

Suddenly my UE40D5500 stuck in the last channel I had seen and displayed nothing. I powered off and on and still nothing. So i did an Epprom Reset on te board and now I have stuck in a boot loop, in which as soon as I put my TV on the main power line the TV switch on automatically, and displays for 2 seconds the logo Samsung Smart TV, then black screen and after 10 seconds this is repeated.

I have also constructed the VGA link cable to serial and in my console I see the following messages:
Switch to Earphone UART
SEC

Switch to Micom UART


=================================
onboot (Feb 25 2011 - 16:08:03)
release ver : 1002 - RELEASE
etc :
=================================

Onboot X6 Sync mode
LCD FastLogo Run...
Loading Kernel....
load kernel start, size : 131072 + 3538944 byte
Jump Kernel....

auth success by h/w sha1 UART1 is used to UART or logic mode.


I have tried many times to do EPPROM reset but nothing happens. I have left the TV for many hours, nothing changed. i have removed the power for 1 week, nothing changed.

I am attaching pictures of the mainboard.


what should I do?

Thank you very very much in advance. Please give me a tip...I know a bit about electronics as a hobby so be free to give even advanced technical details.

IMG_20190407_191235.jpg
IMG_20190407_191220.jpg
IMG_20190407_191206.jpg
You do not have the required permissions to view the files attached to this post.

jozka
Posts: 1
Joined: Tue Apr 06, 2021 6:23 pm

Re: UE40D5500 Boot loop problem. Please help fix.

Post by jozka »

Hi,

I have exactly the same problem, happened to me today without any previous "fiddling" with the TV -- it worked in the morning and now it's in a constant boot loop every 16 seconds.
The serial debug output is exactly the same as posted above. (that's how I found this post)
Didn't do any EEPROM reset either -- it just happened out of nowhere.

Were you able to find any fix?

Thank you

drsamygo
Posts: 2
Joined: Sun Jul 14, 2019 8:19 am

Re: UE40D5500 Boot loop problem. Please help fix.

Post by drsamygo »

Yes, I fixed it and my TV works fine, but this is not an easy fix. The problem was that the firmware (software) of the television was stored on the NAND flash, which developed a bad block and thus it was damanged. I had to order a pre-programmed NAND flash from ebay for my exact model, from a user on ebay. The listing was named 'New nand k9gag08u0e + eeprom tested with ue32d55XX ue37d55XX ue40d55XX ue46d55XX' and cost under 20e. I got the two chips (nand+eeprom) and an electronic technician friend came removed the old and soldered the new nand chip, which is SMD (surface mounted device) with very tiny pins. We changed only the NAND. The EEPROM was not necessary, because after we powered on, the TV was functioning properly. It cost me only 20e and my television was fixed.

Best luck on your repair mate.

Ianios
Posts: 2
Joined: Mon Apr 05, 2021 8:31 am

Re: UE40D5500 Boot loop problem. Please help fix.

Post by Ianios »

to fix it, you can buy icespray and cool down the ic1302 chip without powercable. when the chip is good cold enough ice on it, power on the tv and all is working again.
i tried this last week and all seems ok
you can find a few youtube videos about that

Post Reply

Return to “[D] General”