UE40D6750 as a NAS? Problem writing via FTP! Slow FAT32

Here is information about customize your D series firmware..:!:This forum is NOT FOR USER questions or problems but DEVELOPER.
Post Reply

Posts: 18
Joined: Fri Jul 28, 2017 7:52 pm

UE40D6750 as a NAS? Problem writing via FTP! Slow FAT32

Post by Rezik » Sun Nov 19, 2017 8:49 pm

-- EDIT: Oops, wrong subforum, meant to post in Support --

Hello, I rooted this one very long ago, I think it was 2011 or 2012, and I only installed the main SamyGO app without any extensions or anything.

Obviously I'm here because of the absolutely bizzare thing of not being able to write to NTFS.

I don't want to keep disconnecting all the cables and taking livingroom apart every time I would like to write to the HDD. I could do it in chunks yes, space is not the issue, but it's a living room TV, it's not my TV in my room.

The main goal is to have everything local to the TV with minimal maintenance (i want to put it in box and make ventilation, easy and quick dust cleanup, no taking cables apart), no shares on another computer, the users who use the TV aren't going to be easily talked into using SamyGO, except maybe launching it, but I don't want to keep anything tied to my PC or anything outside the livingroom that the TV would have to rely on, so any samba shares are off from the get go.

I took 2 hours to fiddle through all the forums and since I'm not the only user of the TV I need to be more careful, need to check FW before I can dig into hospitality hack (but the thing about losing electricity on boot is worrying)

But, I haven't found anything about NTFS-3g for D series on the wiki. Is it possibly already in SamyGO and i just need to run some commands on NC or telnet.

I can see SamyConsole, some 0.2 or 0.3 I think, never tried using it, never tried telnet or anything.

Then I found a thread someone saying if I don't need to put it into PC I can just use XFS.
XFS did not work with SD Card reader (goobay) with a 4GB Transcend SD Card, should I try on an actual USB Storage Stick ?

Then I settled I'll just have to use multiple FAT32, 32GB each, but then a big problem, write speed went so slow.

SUPER SLOW like 120-240 kb/s - Even tho that's technically doable, the files won't be that large but it will be a hour wait for 2 of them, it's just not the kind of snail pace I'm willing to settle yet, I want to continue troubleshooting this.

I tried 2 USB sticks, and 1 SD Card adapter, and both into normal ports and the USB port labeled as (HDD) - same thing.

But I have yet to try the actual HDD, which uses Sata to USB adapter, one is from Goobay, the other one from Digitus.
But one of the HDDs is meant for PVR, I could ofcourse switch the adapters around, and also the TV only has one USB port with HDD label.

Now for my options as to what can I safely do on this TV, like a new version of SamyGO? Extensions ? Hospitality ?
I believe this is ARM, and I still know the FW names are T-GASDEUC...

It's recording something now, I forgot to get into the menus to check FW version, I'll update later, and I'll try the HDD as well.

Plus, I'll also try connecting the TV with the PC directly with a router in switch mode, as opposed to going into the main router with the internet.

EDIT: OOPS Sorry wrong subforum
Last edited by Rezik on Sun Nov 26, 2017 6:38 pm, edited 1 time in total.

Posts: 18
Joined: Fri Jul 28, 2017 7:52 pm

Re: UE40D6750 as a NAS? Problem writing via FTP! Slow FAT32

Post by Rezik » Mon Nov 20, 2017 3:07 pm

Should go to support forum - but I have an update:

Oh jeez, it's writing with 550 Kb/s with the HDD/Adapter plugged in HDD port ... why would USB stick be so slower. Seems like some kind of offset that sets everything lower to what it actually is capable of.

This is doable now, from 30 minutes down to 8 minutes for 300 MBs, so lucky?

I do not believe 500 kb is what PVR write speeds are, this is probably something designed this way or what.

This was with NTFS taking most space, using a 4GB FAT32 partition at the end.

Even better now, I made 9 FAT32 partitions and it's working 1.2 MB/s and that's pretty much express at this point, should be no problem going forward.

Post Reply

Return to “[D] Firmware”