Page 1 of 8

D series rooting (arm cpu architecture only) UPDATE!

Posted: Sat Nov 19, 2011 8:59 pm
by Denny
This is thread for D series arm hack update.
Firstly you have to install SamyGO hack from our develop server and then look this thread for updates.

What`s new
  • -Added posibility to play nondrm recorded files with are recorded on another device wherre drm is previusly disabled. (another samsnungs tv/bd) .
  • -Added posibility to record to any non XFS formated USB device, (also NFS mounted device to USB Viritual device)

if you use nfs recording, you dont need anymore remini script etc..., just mount your hdd to samygo viritual usb (in root)
attention, usb devices can be used for recording only if they are inserted after you execute SamyGO App (launcher), due samsungs limitation whitch are by this update removed (like SamyGO Virt. USB).

known bugs :
playing DRM recorded contents from another device still need to be don.

if you want to play your old recorded contents whitch are DRM Protected please make sure you enable drm by separate application (PVR_Switcher DRM On/Off) after execute main SamyGO app.
by executing again of same app, you will disable drm.

install instructions:
  1. connect FTP to TV
  2. extract
you will find 2 subfloders

SamyGO and PVR_Switcher

go to dir

copy SamyGO/ (this is the main patcher and loader) from unziped file to /mtd_down/widgets/user/SamyGO directory

go to dir

copy PVR_Switcher directory to /mtd_down/widgets/user/

by Samba access , same way, make sure you seted up root tree access posibility in samba config,
then type \\ip_of_tv\mtd_down\widgets\user and u are in correct directory, move files in needed directory.

wait a one minute before reboot TV that flash finish writing internal.

reboot tv and enjoy

if something goes wrong , resync App like first time and try again.

EDIT ON 22.12.2011

Added Big Yellow Font patch for Subtitle , size of font seted to 0x25
Added ChannelInfo refers to McFly?s Standalone App

Code: Select all

Re: D series rooting (arm cpu architecture only) UPDATE!

Posted: Sun Nov 20, 2011 12:45 am
by idbirch
Hi Denny, thanks for the update. I've been trying to get recording over my network working since the root was initially released but gave up after days of trying and no success. It sounds like it should be a little easier with this update but I'm still having problems.

I've got an NFS share set up on my PC using FreeNFS and it indeed works as if I use the Photos widget on Smarthub to view the directory structure of the SamyGO Virt.USB device, I see my server I.P. and within that the shared folder. When I try to record, I get "The capacity of the device is insufficient. Ensure more capacity and try again."

I think this is because the NFS share is getting mounted in a folder named after the server IP making the full path to it \usb\nfs\\SamyGO when as your guide above says the NFS share needs to be mounted right at the root of the virtual USB device.

I changed the DEST_DIR=$MOUNT_PATH\nfs line in 03_03_nfsmount.init to just DEST_DIR=$MOUNT_PATH and that has got rid of the \nfs\ level but I still have \usb\\SamyGO. How do I mount the NFs share right on the root of VirtUSB?

Re: D series rooting (arm cpu architecture only) UPDATE!

Posted: Sun Nov 20, 2011 2:15 am
by Denny
basicly the additional patch remove restrictions alow you plug&play solution, u just need correct to mount your hdd to vusb, for normal USB stick u just need to insert , all is done then by TV.

Code: Select all

Ensure more capacity and try again
this come coz your nfs mount point is not root and all other u wrote , i dont have idea i am not a linux expert ^..^ ...

try by some simular way lilke i use in all my devices:

Code: Select all

busybox mount -t nfs -o rsize=8192,wsize=8192,rw,soft,udp,nolock $MOUNT_PATH
where all devices store recorded streams in the same directory and they can be viewed from any tv ( just for test issue, i never use realy TV for recording as DM8000 can much better to do this :) ). is my 1TB HDD in Dreambox DM8000
$MOUNT_PATH is root mountpoint of vusb (/dtv/usb/sdxy)
/media/hdd/ is root on the HDD on DM8000, so movie is a subdir located on root.

before u test, take some 2 gig or more usb stick and try to record on it, format it as FAT under windows.

when you try , check that your mounted hdd contain some files, that you can also check by ls command, another also issue is , when you mount, the files are not imeditly present on the dir, coz your automount scripts 0x_0x_zzzzzmount.init scans your whole network (at me completly disabled ), so my tip, do manual mount your mounts.

Re: D series rooting (arm cpu architecture only) UPDATE!

Posted: Sun Nov 20, 2011 12:03 pm
by idbirch
Thanks for the tips Denny, I've had been trying to get this working by editing nfsmount.init but I don't understand the code well enough. If I just place my own .init file with just one line to do the mount, should this work:

/bin/busybox mount -t nfs -o rsize=8192,wsize=8192,rw,soft,udp,nolock /dtv/usb/sda

because at the moment, it doesn't! The exising init files always seem to use /bin/ before busybox and browsing my TV's file system over ftp, my virtual USB always ends up as /dtv/usb/sda which is why I thought the above would work. Any help on a one line script that would work?

Re: D series rooting (arm cpu architecture only) UPDATE!

Posted: Sun Nov 20, 2011 9:15 pm
by idbirch
Hi, I gave up again on this so disabled all the .init scripts and rebooted the TV but I've found using this new updated version of SamyGO, I can't record anything even onto proper USB hard disks. I get "Preparing to record Live TV" which stays on screen for a few seconds before disappearing and the recording never starts. I rebooted the TV several times and tried connecting the USB hard disk only after running SamyGO but it still doesn't work.

I re-synced to get the original SamyGO back and all worked OK again. Just to confirm the issue, I updated to the new version again and tried recording to a proper XFS USB HDD and it still didn't work. Re-syncing again fixed the issue.

Re: D series rooting (arm cpu architecture only) UPDATE!

Posted: Sun Nov 20, 2011 9:30 pm
by Denny
give up coz you first time fail ? , no good...

did you try to use FAT USB Stick ?

check your default recording device in config under recordings.

i just checked, deleted all stuff from FAT usb device, inserted to TV, changed default rec. device , start recording, work...

anyone can check same ?

Re: D series rooting (arm cpu architecture only) UPDATE!

Posted: Tue Nov 22, 2011 7:46 pm
by Denny
yes, PVR Switcher is for issue that you want watch recorded content that is scrambled , so just needs one time to switch on or off (by starting SamyGO app , DRM is seted to Off) ,

hope i can soon deliver app that will scan all USB contents and decrypt it by user request.

Re: D series rooting (arm cpu architecture only) UPDATE!

Posted: Mon Nov 28, 2011 1:05 am
by Frucoboti

This is my first post!.

I have some questions about Samygo on my 46D8000.

About usb pen drive. It is possible now to record a tv program on an standar fat pen drive, without the need to format in xfs mode.
Does it mean that if this pen fails the benchmark test that the TV does after format should work fine without formating in fat partition? without doing any test?

Is it possible then to do timeshifting in fat mode?

Best regards-

Re: D series rooting (arm cpu architecture only) UPDATE!

Posted: Mon Nov 28, 2011 1:39 am
by Denny
with this update after you install 1st release from server and doing replacment instruction,

you do not need to format any pen to XFS format( there will be no request popup after you insert it)
there is no "benchmark test" , so any pen will be accepted as recording device.

these points as they are realy paranoid are patched out :)

in my case 8 usb pens, different manufactors , only one was success this paranoid issue, so samsung limited very much their clients ,
after patch, every pen do well its job as it should.

the only point is, that the pen must be inserted after!! SamyGO + update is executed.! , coz then patch hapend, if the pen is inserted before executing of SamyGO the pen is marked as non recording device.