SamyGo virtual drive MOD

Here is information about customize your D series firmware..:!:This forum is NOT FOR USER questions or problems but DEVELOPER.

User avatar
pohybel
Posts: 45
Joined: Wed Jun 13, 2012 4:35 pm
Location: Poland

Re: SamyGo virtual drive MOD

Post by pohybel » Mon Nov 19, 2012 9:40 pm

Silly question: have you put modified g_file_starage.ko in /dtv/usb/sda1/SamyGO/lib/modules/2.6.24_SELP.4.3.x-Cortex-A8/kernel/drivers/usb/gadget/?
or maybe: /mtd_rwcommon/widgets/user/SamyGO/SamyGO/lib/modules/2.6.30.9/kernel/drivers/usb/gadget?

Your logs looks like you have loaded some g_file_storage but not mine g_file_storage :?
tempinbox wrote:

Code: Select all

/dtv/usb/sda1/SamyGO/etc/init.d # ./02_04_vusb.init start
insmod: cannot insert '/dtv/usb/sda1/SamyGO/lib/modules/2.6.24_SELP.4.3.x-Cortex-A8/kernel/drivers/usb/gadget/dummy_hcd.ko': File exists (-1): File exists
insmod: cannot insert '/dtv/usb/sda1/SamyGO/lib/modules/2.6.24_SELP.4.3.x-Cortex-A8/kernel/drivers/usb/gadget/g_file_storage.ko': Invalid module format (-1): Exec format error
even if g_file_storage and dummy_hcd haven't been loaded at this point next log lines indicated that some version of g_file_storage and dummy_hcd have been loaded
tempinbox wrote:

Code: Select all

dummy_hcd dummy_hcd: USB Host+Gadget Emulator, driver 02 May 2005
...
g_file_storage: Unknown parameter 'model'
...
as you see g_file_storage has been loaded and is trying to read 'model' parameter which has been added to driver by me. It's really strange because if insmod failed so why g_file_storage is trying to read 'model'? This parameter is passed to g_file_storage in the same line as insmod so if insmod failed all command should failed :?
tempinbox wrote: Your driver is smaller than mine why? mine is 34kb yours is 21kb ( i don't know if matter)
I don't know why by I dont think it's the problem.
tempinbox wrote: one qestion i have to modify the SGO.env?
No. It should be updated by 02_04_vusb.init enclosed in first post.
tempinbox wrote: It is strange but in dtv root i have 5 Vusb

Code: Select all

/ # cd dtv
/dtv # ls -a
.                     event4                notify.tdb
..                    gencache.tdb          notify_onelevel.tdb
.ashrc                gencache_notrans.tdb  passdb.tdb
.auth_finish          hidraw0               pcm_in
PART_FLAG_0           hidraw1               pp
SGO.env               hidraw2               secrets.tdb
YWE                   hidraw3               sessionid.tdb
apache_error_log      hidraw4               smbd-smb.conf.pid
brlock.tdb            httpd.pid             usb
cgi-bin               info                  vusb1
connections.tdb       input                 vusb2
dropbear.pid          lock                  vusb3
event0                locked                vusb4
event1                locking.tdb           vusb5
event2                messages.tdb          www
event3                mutex.tdb
but in mediaplayer i can see only the real usb device
It means that 02_04_vusb.init has been executed and create 5 drive image files but crush at insmod of g_file_storage so images haven't been mounted into virtual drives.

Please check if you put my g_file_storage.ko in proper place and also ensure that you don't have other version of this file somewhere in your tv. As far as I know Samsung is not providing g_file_storage in firmware by default.
Check also your /dtv/usb/sda1/SamyGO/samygo.log

I have downloaded sources for C600 but this is the same sources as for C6900 and toolchaine is also the same so there is no sense to build the file once more :(

At the end I found this wiki page http://wiki.samygo.tv/index.php5/SamyGO ... th_your_tv with note:

Code: Select all

T-VAL* -> binaries may work, kernel modules rather not (ARMv7) (defined as T-CSERIES.. in OE barnch, you have to implement the toolchain and kernel-build for your self) 
you have mentioned that your tv has T-VALDEUC firmware. g_file_storage is the kernel module so probably this is the problem. I didn't find separate toolchain for "T-*" at samsung site and I have no idea how to build it by myself. I have found only T-VALDEUC_3011_0.zip but id doesn't contain any sources or toolchain.

Sorry but I don't know what can I do more in this matter :(

tempinbox
Posts: 317
Joined: Wed May 11, 2011 7:00 pm

Re: SamyGo virtual drive MOD

Post by tempinbox » Tue Nov 20, 2012 4:52 pm

pohybel wrote:Silly question: have you put modified g_file_starage.ko in /dtv/usb/sda1/SamyGO/lib/modules/2.6.24_SELP.4.3.x-Cortex-A8/kernel/drivers/usb/gadget/?
or maybe: /mtd_rwcommon/widgets/user/SamyGO/SamyGO/lib/modules/2.6.30.9/kernel/drivers/usb/gadget?

Your logs looks like you have loaded some g_file_storage but not mine g_file_storage :?
Hi pohybel and :arrow: thanks
i have put modified g_file_storage.ko in

Code: Select all

/dtv/usb/sda1/SamyGO/lib/modules/2.6.24_SELP.4.3.x-Cortex-A8/kernel/drivers/usb/gadget/
i have only your modified g_file_storage.ko on my system (i've checked)
Maybe the problem is wrong init.d script? I also try yours original vusb init script and i disabled all others init script
So why this not work? it create 4 vusb but on dtv/usb/dev i can only see sda1 that is the real storage and samygovirt that is an hidden dir that on mediaplayer is not show.
@juuso @Arris69 we need your helps here.
Are there other way to have 4 vusb created and mounted so we can use them as mountpoint?

arris69
Official SamyGO Developer
Posts: 1700
Joined: Fri Oct 02, 2009 8:52 am
Location: Austria/Vienna (no Kangaroos here)
Contact:

Re: SamyGo virtual drive MOD

Post by arris69 » Tue Nov 20, 2012 5:22 pm

check the output of dmesg after you load the module, if it has some errors then you will se here the reason. the error message on console is nonsense....

all roads lead to rome, play around with module parameter and with scripts etc...

tempinbox
Posts: 317
Joined: Wed May 11, 2011 7:00 pm

Re: SamyGo virtual drive MOD

Post by tempinbox » Tue Nov 20, 2012 6:03 pm

arris69 wrote:check the output of dmesg after you load the module, if it has some errors then you will se here the reason. the error message on console is nonsense....

all roads lead to rome, play around with module parameter and with scripts etc...
dmesg says:

Code: Select all

scsi 0:0:0:0: Direct-Access     Kingston DataTraveler 2.0 1.00 PQ: 0 ANSI: 2
sd 0:0:0:0: [sda] 1952768 512-byte hardware sectors (1000 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 23 00 00 00
sd 0:0:0:0: [sda] Assuming drive cache: write through
sd 0:0:0:0: [sda] 1952768 512-byte hardware sectors (1000 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 23 00 00 00
sd 0:0:0:0: [sda] Assuming drive cache: write through
 sda: sda1
Poller thread started for sda, PID = 544
sd 0:0:0:0: [sda] Attached SCSI removable disk
usb-storage: device scan complete
 RTMPAllocTxRxRingMemory, Status=0
FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
-->RTUSBVenderReset
RTUSBVenderReset
Key1Str is Invalid key length(0) or Type(0)
Key2Str is Invalid key length(0) or Type(0)
Key3Str is Invalid key length(0) or Type(0)
Key4Str is Invalid key length(0) or Type(0)
1. Phy Mode = 5
2. Phy Mode = 5
3. Phy Mode = 9
RTMPSetPhyMode: channel is out of range, use first channel=1
MCS Set = ff ff 00 00 01
== rt28xx_init, Status=0
0x1300 = 00064300
dummy_hcd dummy_hcd: USB Host+Gadget Emulator, driver 02 May 2005
dummy_hcd dummy_hcd: Dummy host controller
dummy_hcd dummy_hcd: new USB bus registered, assigned bus number 5
usb usb5: configuration #1 chosen from 1 choice
hub 5-0:1.0: USB hub found
hub 5-0:1.0: 1 port detected
g_file_storage: Unknown parameter `model'
[CIP_KERNEL] count(1), value(0x0)
[CIP_KERNEL] count(2), value(0x0)
[CIP_KERNEL] authentication success code!!
[waiterd]Success!
Bulk In Failed. Status=-71, BIIdx=0x3, BIRIdx=0x3, actual_length= 0x0
usb 1-1: USB disconnect, address 2
Buffer I/O error on device sda1, logical block 78080
lost page write due to I/O error on sda1
        Manufacturer: Kingston   Product : DataTraveler 2.0
usb 1-1: new high speed USB device using ehci-sdp and address 3
usb 1-1: configuration #1 chosen from 1 choice
scsi1 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
scsi 1:0:0:0: Direct-Access     Kingston DataTraveler 2.0 1.00 PQ: 0 ANSI: 2
sd 1:0:0:0: [sda] 1952768 512-byte hardware sectors (1000 MB)
sd 1:0:0:0: [sda] Write Protect is off
sd 1:0:0:0: [sda] Mode Sense: 23 00 00 00
sd 1:0:0:0: [sda] Assuming drive cache: write through
sd 1:0:0:0: [sda] 1952768 512-byte hardware sectors (1000 MB)
sd 1:0:0:0: [sda] Write Protect is off
sd 1:0:0:0: [sda] Mode Sense: 23 00 00 00
sd 1:0:0:0: [sda] Assuming drive cache: write through
 sda: sda1
Poller thread started for sda, PID = 1079
sd 1:0:0:0: [sda] Attached SCSI removable disk
usb-storage: device scan complete
FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
Skip
g_file_storage: module has no symbols (stripped?))
So maybe is because the file is stripped?

arris69
Official SamyGO Developer
Posts: 1700
Joined: Fri Oct 02, 2009 8:52 am
Location: Austria/Vienna (no Kangaroos here)
Contact:

Re: SamyGo virtual drive MOD

Post by arris69 » Tue Nov 20, 2012 6:35 pm

tempinbox wrote:...
So maybe is because the file is stripped?
you added option -g to strip? and used the strip of your cross compiler?

User avatar
pohybel
Posts: 45
Joined: Wed Jun 13, 2012 4:35 pm
Location: Poland

Re: SamyGo virtual drive MOD

Post by pohybel » Tue Nov 20, 2012 6:46 pm

tempinbox wrote: So why this not work? it create 4 vusb but on dtv/usb/dev i can only see sda1 that is the real storage and samygovirt that is an hidden dir that on mediaplayer is not show.
As I wrote before: It means that 02_04_vusb.init has been executed and create 5 drive image files (just files - as all others) but crushed at insmod of g_file_storage so images haven't been mounted into virtual drives.

Ok. Last chance. I have recompiled it once more on fresh and clean environment. This time I didn't strip symbols so don't be surprised that file size > 300KB. Try file in attachment and use my 02_04_vusb.init script.
If this does not help then I'm giving up.
You do not have the required permissions to view the files attached to this post.

User avatar
pohybel
Posts: 45
Joined: Wed Jun 13, 2012 4:35 pm
Location: Poland

Re: SamyGo virtual drive MOD

Post by pohybel » Tue Nov 20, 2012 6:48 pm

arris69 wrote: you added option -g to strip?
No. Should I?
arris69 wrote: and used the strip of your cross compiler?
yes

tempinbox
Posts: 317
Joined: Wed May 11, 2011 7:00 pm

Re: SamyGo virtual drive MOD

Post by tempinbox » Tue Nov 20, 2012 7:07 pm

pohybel wrote:
tempinbox wrote:Hi my tv is ue32c6000 but fortunately has a valdeuc fw and valencia board so now is turned into a c6900
I'm not sure which source code should I use. I took the one for c6900. I recompile g_file_storage for it. Check it and give us your feedback. If it not work, I will try source code for c6000
tempinbox wrote: i've samygoextension for t-valdeuc and when i try to start your scripts i got these message from shell on telnet connection.
Aaaahhhhhh yes...That's why I could not find it. Telnet is not available on D-series :)
It works now, very well
Thanks a lot
Thanks

User avatar
pohybel
Posts: 45
Joined: Wed Jun 13, 2012 4:35 pm
Location: Poland

Re: SamyGo virtual drive MOD

Post by pohybel » Tue Nov 20, 2012 7:19 pm

Realy? Do all your virtual drives appear in TV? Cool!
I will add this file to package in first post so other C-series user can use it.

User avatar
juusso
SamyGO Moderator
Posts: 10125
Joined: Sun Mar 07, 2010 6:20 pm

Re: SamyGo virtual drive MOD

Post by juusso » Wed Nov 21, 2012 8:07 am

pohybel wrote:I've noticed that oryginal g_file_storage.ko has ~35Kb and the one compiled by me ~200Kb. Could you please write how can I make this file smaller?
Compiled from your source and attaching stripped version of module for D series.
somewhy still get some errors with c series compiler...
You do not have the required permissions to view the files attached to this post.
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

Post Reply

Return to “[D] Firmware”