UA40D5500RR bricked

Here is information about customize your D series firmware..:!:This forum is NOT FOR USER questions or problems but DEVELOPER.
Post Reply

bandwidthcrunch
Posts: 3
Joined: Tue Apr 09, 2013 10:45 am

UA40D5500RR bricked

Post by bandwidthcrunch » Thu Apr 11, 2013 7:44 am

Dear All,
I happened to foobar my TV accidentaly changing options while in the maintanence menu. Stopped working immediately.
Happened to call samsung people who sent two engineers who took 1 week to tell me that both the SMPS board and thg main board
have gone bad and its going to cost me $$. Since I have the option of getting it fixed from them anytime, thought maybe a bit of
self hacking might fix it. Used the VGA serial console and here is the log :

Switch to Earphone UART
SEC

Switch to Micom UART

=================================
onboot (Feb 25 2011 - 16:08:03)
release ver : 1002 - RELEASE
etc :
=================================

Onboot X6 Sync mode
LCD FastLogo Run...
Loading Kernel....
load kernel start, size : 131072 + 3538944 byte
Jump Kernel....

auth success by h/w sha1 !!!! there is format error !!!!
UART1 flag is wrong data
it will be set default - UART mode.


Tried various combinations of keys but the log just stops here and not sign of any activity on the TV. Neither do the
INFO MENU MUTE POWER combinations work. Also tried the MUTE 1 8 2 POWER combos.
After a bit of samygo readings about EEPROM hack , tried shorting the 2 EEPROM pins 5-6 and 4-5 but to no avail. Attached
is the picture of my EEPROM which looks like ATMLH116 ZECL 0J6168A but to no avail .
epromzoom.jpg
Any insights what to fiddle with ? Dont mind any kind of r&d
You do not have the required permissions to view the files attached to this post.

User avatar
juusso
SamyGO Moderator
Posts: 10116
Joined: Sun Mar 07, 2010 6:20 pm

Re: UA40D5500RR bricked

Post by juusso » Thu Apr 11, 2013 8:18 am

Strange brick. What exact did you touch in service menu? Is the code above full exlink log or just cutted of?
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

bandwidthcrunch
Posts: 3
Joined: Tue Apr 09, 2013 10:45 am

Re: UA40D5500RR bricked

Post by bandwidthcrunch » Thu Apr 11, 2013 8:26 am

I dont know which setting, got distracted on a call and pressed few buttons :(
That is the only log what i see from power on. Have a arduino leornado hooked
to the EEPROM , trying to take a dump or do a factory reset.

User avatar
juusso
SamyGO Moderator
Posts: 10116
Joined: Sun Mar 07, 2010 6:20 pm

Re: UA40D5500RR bricked

Post by juusso » Thu Apr 11, 2013 8:31 am

yes, try to do hard reset by shortening pins. but I feel your brick is related to some firmware issue or internal flash errors. If I'm right, then no fixes, just mainboard replacement can help.
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

bandwidthcrunch
Posts: 3
Joined: Tue Apr 09, 2013 10:45 am

Re: UA40D5500RR bricked

Post by bandwidthcrunch » Thu Apr 11, 2013 8:40 am

Am thinking also has to be firmwate related cause it happened when remote keys were pressed, was hoping to
have some boot flag that would get rid of this error

auth success by h/w sha1 !!!! there is format error !!!!

and also force the rs232 to DEBUG mode instead of UART mode.

User avatar
juusso
SamyGO Moderator
Posts: 10116
Joined: Sun Mar 07, 2010 6:20 pm

Re: UA40D5500RR bricked

Post by juusso » Thu Apr 11, 2013 2:47 pm

rs232 debug does nothing bad, moreover, it is ok - you see the debug log...

I don`t know if this can help - maybe not, but you lose nothing. You could force TV to boot another partition set. Look at this topic. I expect TV will boot if no h/w failure in those flash areas, ending with restart by authuld, but now you need to be sure TV can boot at all or not.
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

pauliini
Posts: 5
Joined: Thu Aug 13, 2015 8:30 am

Re: UA40D5500RR bricked

Post by pauliini » Wed Aug 26, 2015 6:32 am

I did the MAX232 circuit EX-link cable and connect it from PC serial connector to the TV VGA connector. I get exactly the same feedback as the chain initiator. TV model is Samsung UE40D707RK. I do not know what to try next?

My TV broke down when I pressed the Micom Upgrade function Service Menu.

I get feedback as follows:

Switch to Earphnne UART
SEC

Switch to Micom UART


=================================
onboot (Feb 25 2011 - 16:08:03)
release ver : 1002 - RELEASE
etc :
=================================

Onboot X6 Sync mode
LCD FastLogo Run...
Loadinf Kernel....
load kernel start, size : 131072 + 3538944 byte
Jump Kernel....

auth succesr by h/w sha1 !!!! there is format epror !!!!
UART1 flag is wrong data
it will be set default - UART mode.

I ordered Arduino Ethernet multi-function Interface and I'm going to try unbrick my TV by connecting Arduiono directly to circuit ATMLH136 as instructed on this website. Are there opportunities to succeed I do not know, you see it then. I would like to get constructive comments.

download/file.php?id=6228&mode=view

pauliini
Posts: 5
Joined: Thu Aug 13, 2015 8:30 am

Re: UA40D5500RR bricked

Post by pauliini » Wed Aug 26, 2015 6:42 am


pauliini
Posts: 5
Joined: Thu Aug 13, 2015 8:30 am

Re: UA40D5500RR bricked

Post by pauliini » Wed Aug 26, 2015 6:43 am

Better picture

ivania
SamyGO Project Donor
Posts: 2
Joined: Wed Nov 25, 2015 12:11 am

Re: UA40D5500RR bricked

Post by ivania » Thu Dec 10, 2015 11:36 am

did it work?

Post Reply

Return to “[D] Firmware”