How to downgrade D6200 ?

Here for general support for D series TVs, request and problem solve area.

Posts: 2
Joined: Sun Mar 25, 2018 3:58 pm

Re: How to downgrade D6200 ?

Post by Lupine » Mon Mar 26, 2018 11:47 pm

My main goal is to STFU the info banners on a D6500 @ 1027 using the hospitality hack.

I have the same problems as Elysium with:

Code: Select all

/mtd_rwcommon/widgets/user/SamyGO/SamyGO/etc/init.d/01_01_catch_crap.init failed to execute
/mtd_rwcommon/widgets/user/SamyGO/SamyGO/etc/init.d/02_04_vusb.vpvrimage.init failed to execute
/mtd_rwcommon/widgets/user/SamyGO/SamyGO/etc/init.d/03_03_nfsmount.init failed to execute
/mtd_rwcommon/widgets/user/SamyGO/SamyGO/etc/init.d/04_04_samba.init failed to execute
I can FTP and Netcat to the TV. The php and cgi pages don't work, probably because the Apache server isn't started.

One thing I noticed, echo $SYSROOT returns an empty line. That would mean ". /dtv/SGO.env" is not executed, right?
juusso wrote:
Sun Nov 12, 2017 10:36 pm
One more before you go sleep:
1. download this 01_01_catch_crap.init, unzip it and upload to TV via ftp. Overwrite existing one. Please do not edit this file, just unzip, upload (use binary mode of your ftp client), overwrite.
There's indeed a few differences between the original file and yours.

Code: Select all

# © Copyright 1996-2011, SamyGO

	$SYSROOT/bin/busybox nc -l -l -p 1023 -e /bin/sh &
	$SYSROOT/bin/busybox tcpsvd -vE 21 $SYSROOT/bin/busybox ftpd -w / &

Code: Select all

# © Copyright 1996-2011, SamyGO

	$SYSROOT/bin/busybox nc -l -l -p 3023 -e /bin/sh &
#	$SYSROOT/bin/busybox tcpsvd -vE 21 $SYSROOT/bin/busybox ftpd -w / & 
I will try to use your init file tomorrow, but if even $SYSROOT is not defined I don't think it'll make a difference. Next step is to redo the hospitality hack. Should I also try to reinstall SamyGO using develop in the SmartHub? Someone said his TV wouldn't even do FTP anymore after reinstalling...

Still getting "failed to execute" after replacing 01_01_catch_crap.init.

Something did change after replacing 01_01_catch_crap.init. In the old one I could Netcat on port 1023, in the new on port 3023. At least that part of the script is executed.

Tried some things. Blocked Samsung OTN IPs. Disabled AllShare. Deleted all scripts in init.d except 01_01_catch_crap.init, 02_04_vusb.init, 06_05_apache.init and 99_99_InfoBannerDuration.init. I can now access the TV from the browser, including cgi-bin. That did not work before.

Tried starting 99_99_InfoBannerDuration.init through cgi-bin/test.cgi:

Code: Select all

+ samyGOso -D -l /mtd_rwcommon/widgets/user/SamyGO/SamyGO/opt/privateer/usr/libso/
samyGOso: invalid option -- 'D'
usage: samyGOso -p PID {-c CONFIG | -l /full/path/to/ [-r (=resident)]} [-d (=debug on)] [-a (=add libc addressoffset )] [arg0,...,argN]
samyGOso v1.2.1 (c) bugficks 2013
+ sleep 1
I could try replacing, I am now using the one included in libSTFU.


Replaced from libSTFU with samyGOso v1.2.5. Commented out line 21 from catch_crap.init because I don't have /dtv/usb/sd*/smb_userdata. Restarted the TV, no more "failed to execute". Now STFU works! But not all banners are affected. The recording reminder is just a flash now. The one I want gone but is still there is the popup after the recording started.

Posts: 1
Joined: Mon Oct 08, 2018 5:44 am

Re: How to downgrade D6200 ?

Post by Kovajda » Tue Oct 16, 2018 7:22 pm

So I tried everything according to the instructions and also without success.
What to try to overwrite the 1014 firmware as 1029 via usb?

Post Reply

Return to “[D] Support”