Cannot play PRV content - need proper codec?

Here for general support for D series TVs, request and problem solve area.
Post Reply

Stewox
Posts: 20
Joined: Fri Feb 24, 2012 9:36 am

Cannot play PRV content - need proper codec?

Post by Stewox »

Hello

I can't play it nicely, it lags, it stutters and it's unwatchable, some players don't show video(black screen), only audio.

I haven't found any info on these forums despite searching many combinations.
  • Disconnected all External USB
    Enabled SamyGo extension
    Connected USB (FAT32)
    Entered USB at detection and Exit (reconnect required to get PVR to switch to default record device instea od SamyGO virt. USB)
    Started PVR successfuly.
The TV makes CONTENTS folder:
[datum].ckf
.enc
.inf
.mdb
.tmp <-- video
NewBoard4Rpsp.inf

TV: UE40D6750

User avatar
juusso
SamyGO Moderator
Posts: 10124
Joined: Sun Mar 07, 2010 6:20 pm

Re: Cannot play PRV content - need proper codec?

Post by juusso »

your PVR recorded content is encrypted, it is alowed to watch your recordings ONLY on same TV where records were done. Officially.
The solution you can find by reading these topics:
viewtopic.php?f=22&t=2820
viewtopic.php?f=21&t=2433
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

Stewox
Posts: 20
Joined: Fri Feb 24, 2012 9:36 am

Re: Cannot play PRV content - need proper codec?

Post by Stewox »

I haven't understood any of that in the D wiki install tutorial, which was probably not related to this.

How would that affect the HDTV, is there any part that can make my HDTV brick ?

In one of those topics it says that it doesn't work for D series so I stopped looking before. I thought this was old and was already integrated into extension.

Also the instructions are a bit too vague, how would I connect to HDTV to put those commands in ?

Why is this not a part of the extension anyways, there seems to be a lot of things just here and there with broken links, I would make another version and put everything in one package.

Also I wanted to play .tmp on PC not on any other HDTV, i do not need that, I tried with VLC, Windows Media, MPC, ... etc

Stewox
Posts: 20
Joined: Fri Feb 24, 2012 9:36 am

Re: Cannot play PRV content - need proper codec?

Post by Stewox »

I found the supposaable app here:
viewtopic.php?f=22&t=2820&start=200#p34737.


But it doesn't work, same problem. Keeps laggign, stuttering, sound and audio, also it's skipping a lot of frames, just like if you had low signal.

I will continue posting in that thread if I won't solve this, but I'm going to try other stuff with that program.



Image

Stewox
Posts: 20
Joined: Fri Feb 24, 2012 9:36 am

Re: Cannot play PRV content - need proper codec?

Post by Stewox »

Ah now I found out it some problem with the file it self how it was recorded


Scenario #1
  • 1. SamyGO Ext activated
  • 2. Connect USB Flash (ex: Patriot Memory 8GB - FAT32)
  • 3. PVR Records to USB
  • 4. USB -> PC -> transfer
  • 5a. Playback of .tmp with MFC ("low signal" issue, as in image above) ****
  • 5b. Playback of .srf with MFC ("low signal" issue, as in image above)
  • 6. DeSTRoi -> Method: MDB -> LOCAL _FILE.srf -> AF: False
  • 7. Success convert to .ts * (with the same "low signal" playback problem)

Scenario #2
  • 1. No SamyGO Extension launched (installed only)
  • 2. Default XFS Recording (500GB HDD via USB adapter)
  • 3. DeStRoi -> Method: MDB -> "AF": False -> "Decrypt on the Fly": True -> example non-HD video (80MB) (NOTE: "Decrypt on the Fly": False did NOT work, just made an empty tmp folder)
  • 4. Success convert to .ts
  • 5. WORKS!

"low signal" playback problem = stutter, laggy, skipping frames, etc -> unwatchable.

**** =
.TMP instead of .SRF was probably because I remember the HDTV was a bit of unresponsive to stop the recording when I wanted it to, and I out of frustration disconnected the USB and turned the TV off, that's why it wasn't able to complete and so it didn't finish it's process properly.
Next time It was fine so it completed it's process, there is more files there such as Ace.dat and Ace.log in database folder, and a PVRDBVersion.mgr file in root.


I may try to put that corrupted .ts to see if it will play okay on the actual HDTV not only on PC.

Maybe this whole "low-signal" issue was caused by the use of USB stick or whatever, maybe FAT32, but thankfully there's a solution, there may be more combinations to try with the decryptor tool and it's more to find than just 2 ways ... I didn't use HDD with SamyGO since I don't have more place empty partition on HDD and I have HDD installed in a way it's not quickly disconnectable, I also have other 3 partitions of stuff along with one XFS partition, i did not want to get something deleted or corrupted so i used the Patriot Memory USB.




I'm explaining all these details because for better understanding on my own but to also to clear things out for others, it's one thing that I hate on this world is very vague instructions without detail.

I wasn't aware of the AF option before, it was off when I tried and it worked: it's UE40D6750WSRZF (refurbished)

Post Reply

Return to “[D] Support”