T27D390 firmware update problem

Forum for your Monitor questions instead of TVs
Post Reply

Posts: 1
Joined: Thu Jul 12, 2018 9:22 am

T27D390 firmware update problem

Post by mkaram » Thu Jul 12, 2018 9:33 am

I am trying to update the firmware of Monitor T27D390EW from Samsung website. However the instruction are misguiding and the monitor/tv is not recognizing the file to update.

On their website you should be able to download the exe file: http://org.downloadcenter.samsung.com/d ... OriginYN=N

I have firmware 1008 on the monitor. Latest firmware on Samsung website is 1013. So it should pick it up.

Once the exe is saved and run on my computer, the instructions are confusing:
1. Save the firmware file from Samsung.com onto your computer.

File Name :T-NT14LDEUCM_1013.0

2. Connect the USB Memory Drive to the USB port of your PC.

Copy the file onto the USB Memory Drive.

3. Go to the USB Memory Drive and then double click the file.

4. Press the "Install" button.

5. Unzipping is in progress.

6. After completing, please press the"OK" and "Close" button.

7. A folder containing the firmware files has been added to the USB memory drive.

Folder Name : T-NT14LDEUCM

8. Safely disconnect the USB memory drive by right clicking the green check mark on the taskbar and then left click"Safely Remove".
There is no INSTALL button anywhere, and unzipping extracts a folder with upgrade.msd file. That file when I put on USB, the monitor doesn't recognize it whatsoever, i tried to leave it in the folder and i tried to move it to the root of the USB, either way the monitor is not recognizing the file.

Am I missing somthing?

Post Reply

Return to “Monitors”