Poor LA40B650 picture quality after FW upgrade

Here for general support for B series TVs, request and problem solve area.
Post Reply

Tade76
Posts: 3
Joined: Tue Jan 14, 2014 8:06 am

Poor LA40B650 picture quality after FW upgrade

Post by Tade76 » Tue Jan 14, 2014 12:55 pm

Hi guys,

The problem is: on my LA40B650 I did a FW upgrade (to the version before Feb 2010, "2004.1"). Everything went ok, BUT! - the picture quality of TV channels went worse, the picture looks like in CAM-Rip quality movie, darker in general. I put the backlight to max, change "white balance", en.saving=off, etc - nothing helps. But, again, when I enter the Content library or select the flash source (for any media) - here the the picture quality is not affected.
And I did not change anything from service menu, I even did not enter there!

what I did after:
- "Factory reset" from service menu - didn't help
- once again factory reset - the same
- turned off the TV (but didn't unplug the power cord)
The next day:
- rolled back to the initial FW - did with no problem, but the the picture quality remains the same bad
- another factory reset from service menu - the same

I believe the first upgrade changed some settings in the service menu , but there is no info on the setings value of the service menu
Can anyone, pls, help me restore the previous quality?..

Photoes of screen available upon request)))))

Best regards!

Tade76
Posts: 3
Joined: Tue Jan 14, 2014 8:06 am

Re: Poor LA40B650 picture quality after FW upgrade

Post by Tade76 » Tue Jan 14, 2014 9:10 pm

Just checked: when connecting DVD to AV source the picture the same poor, but if I connect it to Component source - the quality is fine.

Post Reply

Return to “[B] Support”