Page 1 of 2

Help: PS50B850 and Extension Pack

Posted: Fri Aug 13, 2010 12:45 pm
by paaro

I own a Samsung PS50B850 model since this March. I upgraded the FW from 3000.G to 3001.1 some months ago. Recently I got to know SamyGO stuff and was able to revert back to 3000.G (with telnet enabler) and then installed patched 3000.G FW. Then I wanted to install the Extension Pack ( ... sions_Pack). I followed the instructions, but no matter what I do, I cannot see the Game content folder. I only have the other five folders (Gallery, Cooking, Children, Wellness, Others). I tried to copy the Extension Pack manually (as explained in the instructions), but to no avail. Tried to change the folder to Others (by editing the clmeta.dat file), to no avail, too. I ran out of ideas. Any help would be appreciated!

Re: Help: PS50B850 and Extension Pack

Posted: Fri Aug 13, 2010 11:44 pm
by erdem_ua
Could you activate Telnet? I think you don't...
Might be you can load our tools IF you don't upgrade your TV firmware.
Since 3000.G firmware allows you to connect TV from ExLink connection,
You can enter to TV than you could install hacked firmwares or load hacks via gdb (I don't know if loading is successful on your PS model but It might be...)
So nothing to do. You needed to revert your firmware back, but it's not enough, you also needed to revert your firmwares linux kernel too for have ExLink connection.
And it's not looking quite possible with your model (PS series)...

Re: Help: PS50B850 and Extension Pack

Posted: Sat Aug 14, 2010 8:13 am
by paaro
Yes, I activated the telnet. This is what I did:
1) I followed this instructions: ... r_firmware
a) I enabled Telnet (it installed into the Children content folder)
b) I created Version.0 file with the 3000.G version info (since I upgraded some months ago from 3000.G to 3001.1)
c) I downloaded the 3000.G firmware from the link at the bottom of that page, for my model (T-CHU7DEUC - 3000.G)
2) I used SamyGO Firmware Patcher to patch the downloaded 3000.G firmware (to enable Telnet, VideoAR fix, etc)
3) I then plugged in the USB disk with this patched firmware, went to the Software Update menu in my TV and installed the patched 3000.G firmware from the USB disk.

Now my TV has the Telnet enabled by default (I don't have to explicitely run it in the Content menu).

I then tried to install the SamyGO Extension Pack. Since no Game folder appeared on my screen, I copied the files manually via Telnet (cp -a /dtv/usb/sda1/SamyGO /mtd_tlib/GGame/).
But still i cannot see it in the Content folders, since no Game folder is present there.

Re: Help: PS50B850 and Extension Pack

Posted: Sat Aug 14, 2010 8:33 am
by erdem_ua
Ooops I couldn't read your first post properly... Sorry. Yes you reverted your fw back...

But I think it's hard to show game folder at your firmware. Since your firmware is same for B7000 series, It have Game menu but it's hidden on PS series. I don't know how to activate it yet.

You might try "gdb attaching" way to start some programs from Telnet.I believe most of them will work on your TV. You might run some of programs at USB. Can you test it? You can find instructions at this forum page.
After you can change some flash menu files to have custom content player. That might allow you to run custom programs from remote, content library.
( T_Library.swf and mainmenu.swf )

Re: Help: PS50B850 and Extension Pack

Posted: Wed Aug 18, 2010 7:25 pm
by antapetr

if you can do this
paaro wrote:a) I enabled Telnet (it installed into the Children content folder)
then you can do the same thing with SamyGO Extension Pack. Just copy it to the /mtd_tlib/swf/CHILDREN/telnet-enabler folder, next to existing telnet folder. If you can see "Run this Telnet Enabler" entry in Children category you should see "SamyGO Extensions" entry next to it.

Happy hacking :-)

Re: Help: PS50B850 and Extension Pack

Posted: Sun Aug 29, 2010 12:28 am
by paaro
Sorry for a lengthy delay, I was on a well deserved summer vacations :)
erdem_ua, I tried the "gdb attaching" method, but I just couldn't get it to work. Then I tried the antapetr's suggestion. I copied the SamyGO extension folder to the /mtd_tlib/swf/CHILDREN/trojan/SamyGO (trojan is the folder where "telnet" folder also resides). When I go to the Content>Children on my TV, I get the option to select SamyGO Extension Pack (apart from the default Song and Story, and telnet). When I click it, nothing happens for some 10s, then the top (where "Children" text is written) and the bottom (where the Return and Exit buttons are displayed in the right corner) of the screen fades to black, but the main screen (with the five "applications" and the SamyGO logo) remains there. I waited for several minutes, but nothing happened. Then I exited the Content menu and went to the Media Play menu and pressed the red button, but no new fake servers were shown. I also tried to SSH to the telly, but with no success. I'm starting to wonder if there is a way for me to run this Extension Pack at all!

Re: Help: PS50B850 and Extension Pack

Posted: Mon Aug 30, 2010 4:33 am
by erdem_ua
Instead of using Expansion Pack, you can deploy that scripts to your Tv by hand (via using Advanced Way).
That will allow you to use nfs/samba mounting like options.
So your firmware is hackable and SamyGO is not equal to Expansion Pack ;)

You can also find way to install utilities like PVR app future via gdb attaching. I see some new program that patch exeDSP to load files.

Re: Help: PS50B850 and Extension Pack

Posted: Mon Aug 30, 2010 6:41 am
by juusso
You must run it from Content Library Manager: [Menu] -> [Source list] -> [USB] -> [Content Library] -> [My Contents] -> [Children]
Not directly from [Content library] -> [Children] via Content button on RC.

Re: Help: PS50B850 and Extension Pack

Posted: Mon Aug 30, 2010 6:55 pm
by paaro
juuso, nice! It works! Well, almost... :) When I run it, that female voice says something (didn't pay attention), then says the shutdown sequence is proceeding. After a few seconds, the Content menu returns. Then I can go to Source and I can see USB2: UPNP Server. So far, so good. I can play streamed stuff from my computer, but after a few minutes, the TV turns off and then on again, and UPNP server is gone. I have no idea why the TV shuts down! And, BTW, SSH doesn't work. Should it?