[Ended] E series widget -autostart w/o USB

Here are software that related with Samsung E series TVs.
Please don't create any new topic here unless you have software to post/release.
Locked

MnCC
Posts: 15
Joined: Fri Nov 18, 2011 8:28 am

Re: [Testing] Update2: E series widget -autostart w/o USB

Post by MnCC »

Sup,

Never updated my UE40ES7000, out of the box firmware 1008.
Installation works:
- ssh
- telnet
+ netcat
+ ftp

Virtual USB does not detect servers, but after change server=<ip> in 03_03_nfsmount.init it works ok.

Awesome!


(3gb+ files over wifi do not work properly, the speed is low for some reason)

User avatar
juusso
SamyGO Moderator
Posts: 10124
Joined: Sun Mar 07, 2010 6:20 pm

Re: [Testing] Update2: E series widget -autostart w/o USB

Post by juusso »

you can play with network options by commenting/uncommenting one of mount options (M_OPTS). Leave only one uncommented:

Code: Select all

# M_OPTS="soft,udp,async,nolock,rsize=32768,wsize=8192"
# M_OPTS="rw,soft,udp,nolock,rsize=32768,wsize=32768"
# M_OPTS="soft,tcp,nolock,rsize=32768,wsize=32768"
# M_OPTS="soft,tcp,nolock,rsize=8192,wsize=8192"
M_OPTS="soft,tcp,nolock"
AFAIK best nfs speed is when used udp protocol. try.
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

MnCC
Posts: 15
Joined: Fri Nov 18, 2011 8:28 am

Re: [Testing] Update2: E series widget -autostart w/o USB

Post by MnCC »

Hi,

I think the problem lies with the wifi, other devices (phone/laptop) pull 7Mb/sec (60+ mbit) easily over the same link.
The first 70Mb are pulled in with 2/3mb+, then the connection drops to 200kb. It does this for FTP aswell as NFS.

Installation was over USB, i've resetted smarthub and the tv-settings but no dice.
Going to try again, i will reset everything just to make sure.

I'll pastebin a bootlog

iDeep
Posts: 34
Joined: Wed Apr 24, 2013 3:15 pm

Re: [Testing] Update2: E series widget -autostart w/o USB

Post by iDeep »

Try using 802.11 g only mode in your router setting, this has been tested to immensely improve wifi transfer speeds for Android sticks.
Samsung UA40ES6600R (XZN)
Firmware : T-MST10PDAAC-1017.1
DATE : 2013-02-26
MICOM : T-MST10PDAAS-1004
SDAL : 4.28.0.0

MnCC
Posts: 15
Joined: Fri Nov 18, 2011 8:28 am

Re: [Testing] Update2: E series widget -autostart w/o USB

Post by MnCC »

Hi,

Thanks for the help (seems my router has no g only mode), but the problem lies with the TV. I have some cheap android hardware and it plays 8gb+ mkv files over wifi.
Tried to speed things up, but i cant stop/start the ra11n0 device, my netcat breaks and then i'm done, cant get back in.

sysctl -w net.core.rmem_max=33554432
sysctl -w net.core.netdev_max_backlog=2000
sysctl -w net.ipv4.udp_mem='262144 327680 393216'
sysctl -w net.ipv4.tcp_mem='262144 327680 393216'

Nevertheless i should get at constant 5 mbit over wifi, so i think something gets buffered or stored somewhere in the TV. Cant figure out where though.
filename : testfile.mkv filesize : 4691262160 bytes length : 8170 secs

AtSchU
Posts: 32
Joined: Fri Apr 05, 2013 5:46 pm

Re: [Testing] Update2: E series widget -autostart w/o USB

Post by AtSchU »

Hello everybody,

I can't get root access to a TVs with Firmware T-MST10PDEUC-1032.0.

Thats what I did:
1. Entered Service Menu and turned Watchdog off and put RS-232 to debug
2. Reseted Smarthub and cleared all Widgets
3. Updated Smarthub to newest version and then installed Skype
4. Turned TV off and pluged in USB with SamyGO
5. Turned on and installed SamyGO from the new icon in the Smarthub.
6. After installation I pressed exit on remote and turned TV off.
7. Unpluged USB and restarted TV.
According to the guides this should work but I can't access TV via FTP neither Virtual USB is shown.

Can anyone help?
FYI did the same procedure on a TV with T-MST10PDEUC-1029.0 and it worked.

gjoenge
Posts: 3
Joined: Thu Jun 14, 2012 9:38 pm

Re: [Testing] Update2: E series widget -autostart w/o USB

Post by gjoenge »

I just changed samygo to point to my NAS for the virtual USB device share. Unfortunately I have a lot of media files on it, and samygo seems to go into an endless loop here after I select Videos (I supose it probably works if you let it run for a very long time). This happens both with smb and nfs. Is there any way to turn off this scanning and just browse the folders and files normally?

User avatar
mmhorda
SamyGO Project Donor
Posts: 152
Joined: Tue Jan 25, 2011 11:23 am

Re: [Testing] Update2: E series widget -autostart w/o USB

Post by mmhorda »

Hello all,
Going to test widget on my TV UE50ES6300. what is the latest supported firmware?
is it working on T-MST10PDEUC-1036.0 ?

Thanks in advance.
TV: LE40C750 - T-VALDEUC 3011.0
TV: UE40D6100 - T-GAS6DEUC 1026.0
TV: UE50ES6300 - T-MST10PDEUC 1042.0
NAS: MyBookLive 3Tb - Core F/W 02.43.03-022

mamo
Posts: 13
Joined: Tue Jul 17, 2012 4:38 pm

Re: [Testing] Update2: E series widget -autostart w/o USB

Post by mamo »

Hi juuso,

i confirm SamyGO Extensions work on my Samsung UE46ES8090 T-ECPDEUC 2006.0 Firmware.
Widget Version 08/05/2013, install method is USB. (InstallSamyGO Widget)

Autostart = OK
FTP = OK
Telnet = OK
PHP Sysinfo = OK
Virtual USB = OK
NFS = OK
Samba = OK (4 fixed servers)
SSH = not OK

Camera App shows black screen instead of Camera Picture.
Skype App did not work. Hangs at "Loading..."

After Firmware update to T-ECPDEUC 2008.2 via USB, SamyGO still works in Autostart mode as described without new Widget Installation.

Many Thanks - Great Job!
Best Regards
mamo

Samsung UE46ES8090 / T-ECPDEUC-2011.1 / SamyGO Extensions

User avatar
mmhorda
SamyGO Project Donor
Posts: 152
Joined: Tue Jan 25, 2011 11:23 am

Re: [Testing] Update2: E series widget -autostart w/o USB

Post by mmhorda »

TV: UE50ES6300
Firmware: T-MST10PDEUC 1029
Widget Version 08/05/2013, USB Inastallation.

Autostart = OK
FTP = OK? (didn't check)
Telnet = OK
PHP Sysinfo = OK? (didn't check)
Virtual USB = OK
NFS = OK
Samba = OK? (didn't check)
SSH = KO

After Update to T-MST10PDEUC 1030 I had to unhash sleep 9 in 03_03_nfsmount.init right under /dtv/SGO.env otherwise NFS = KO
TV: LE40C750 - T-VALDEUC 3011.0
TV: UE40D6100 - T-GAS6DEUC 1026.0
TV: UE50ES6300 - T-MST10PDEUC 1042.0
NAS: MyBookLive 3Tb - Core F/W 02.43.03-022

Locked

Return to “[E] Software”