[App] PVR+ 3.x

Here are software that related with Samsung B series TVs. Like hex editors, new version of BusyBox or internal software, app programs that will run in your TV hardware.:!:This forum is NOT FOR USER QUESTIONS or Problems.

ftom

Re: PVR+ 3.x

Post by ftom » Tue Apr 03, 2012 9:08 pm

juuso wrote:You just need to start only loader.so from pvr directory.
I saw this advise many time but never seen guide how to start ".so" module in SamyGO.sh script.
I guess that there is some command which will start it but I'm not advanced user. Can anybody put example here please. This is very common Q in many forums.

Thanks in advance,
Pavel

donnib

Re: PVR+ 3.x

Post by donnib » Tue Apr 10, 2012 8:49 pm

Hi,
I have an UE40B7000 with T-CHU7DEUC-3000 and i can run PVR 3 but it does record and i can play but there is no Audio/Sound either on the TV itself or or a PC runninc VLS. What am i doing wrong ?

donnib

DEvil0000
Posts: 15
Joined: Tue Feb 14, 2012 2:35 pm

Re: PVR+ 3.x

Post by DEvil0000 » Wed Apr 11, 2012 1:54 pm

ftom wrote:
juuso wrote:You just need to start only loader.so from pvr directory.
I saw this advise many time but never seen guide how to start ".so" module in SamyGO.sh script.
I guess that there is some command which will start it but I'm not advanced user. Can anybody put example here please. This is very common Q in many forums.

Thanks in advance,
Pavel
just use injectso program...
search for it in wiki, forum sorceforge - you will find it with how to information for loding an so

User avatar
juusso
SamyGO Moderator
Posts: 10125
Joined: Sun Mar 07, 2010 6:20 pm

Re: PVR+ 3.x

Post by juusso » Wed Apr 11, 2012 2:00 pm

juuso wrote:You just need to start only loader.so from pvr directory.
by saying this i ment gbdtrick or injectso, sorry, i was not really accurate.
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

baco81
Posts: 70
Joined: Fri Apr 30, 2010 8:24 am

Re: PVR+ 3.x

Post by baco81 » Sat Apr 14, 2012 10:56 am

geo650 wrote:
baco81 wrote:Having some issues with the OTR function, though. It records the program I have scheduled but exeDSP crashes every time the recorded file reaches 4GB
I did not improve PVR+ in 2012 yet, but there are plans to release v3.1 soon. Until then, please try to record without splitting, on a network share or ext2 partition.
It should be enough to get "Automatic power-off" automatically disabled if splitting option is enabled.

After all, we can always have the TV powered off by the TV built-in timer... ;)

EDIT:
Well, it isn't enough :?

I made a test. Yesterday I scheduled the PVR+ application to record the F1 Chinese Gran Prix even though I was going to be in front of the TV enjoying the race at that time (this morning).

PVR+ started recording the race as expected and I manually set the "Automatic power-off" to disabled during the recording by pressing the "Power" button.

ExeDSP crashed when the recorded file reached 4 Gb anyway and the TV reboot, so there should be something else...
T-CHL7DEUC-2005.0-v0.24-GMT2-ArFIX2-ADFIX-fwver-ENGFIX

sicopata
Posts: 2
Joined: Tue Apr 17, 2012 9:22 am

Re: PVR+ 3.x

Post by sicopata » Tue Apr 17, 2012 10:05 am

Cornholio wrote:Can any1 help with PVR+ 3.x setup of path to record on my NAS instead on my pendrive.
my tv is 192.168.1.20
my nas is 192.168.1.40
use smb!!!
i try with MOVIE001.sh but no succsess

thanx in advance!!
:D :D :D
Similar here.
I can't load any script with PVR+
Actually I don't know how Target works assigning a folder of my NAS as recorded destination

I've used the script that I know it works mounting NAS folder in a Virtual USB, but PVR+ can't load it neither with yellow.sh nor MOVIE001.sh name file I get a error window
This is the script, changing the name of folder to adapt it to the needs

Code: Select all

#!/bin/sh
#!SamyGO VUSB multifolder SAMBA mount
echo "Creating USB virtual"
insmod ./lib/modules/drivers/usb/dummy_hcd.ko
sleep 2
insmod ./lib/modules/drivers/usb/g_file_storage.ko file=./lib/modules/drivers/usb/vusb.image
sleep 3

echo "Sharing folders"
insmod ./lib/modules/fs/cifs/cifs.ko
sleep 2

echo "Searching virtual USB"
VUSB=`grep -A 4 "File-Stor Gadget" /dtv/usb/log | grep MountDir | cut -d: -f2`
sleep 1

echo "Making mount points"
mkdir -p $VUSB/MOVIE001

echo "Mounting folders"
mount -o user=XXXX,password=XXXX -t cifs //192.168.2.102/recordings $VUSB/MOVIE001

echo "Ready !"

adrive

Re: PVR+ 3.x

Post by adrive » Tue Apr 17, 2012 2:23 pm

Hi all. First of all, thank you for the effort you spent creating this awesome pieces of code to make our TV's better.

I spent a lot of time reading the informations on various SamyGO topics. I have an issue that seems to be opened twice, but I cannot find some resolution of it.

I have L32B650 with patched firmware T-CHL7DEUC-1008.0, and I am successfully using telnet, ssh, nfs and other samygo services. But I have problem running PVR+3. It won't start, doesn't matters the used method. In both cases (starting as app from contents, or injectso) it logs undefined symbol error: _ZN8TCWindow9MuteVideoEb

Here is a full output of injectso method

Code: Select all

# nice -n 19 injectso $(pidof exeDSP) /mtd_tlib/GGame/PVRplus/loader.so Game_Main /mtd_tlib/GGame/PVRplus/

Module injector V1.2 for ARM based CPUs.
(copyleft) SmartSmurf 2010 (smartsmurf@shared-files.de)

Info: Import dlopen set at 0x0051bb38
Info: Import dlsym set at 0x0051bff4
Info: Import dlclose set at 0x0051bcf4
Info: current register set:
R0 =0xFFFFFFFC R1 =0x00000000 R2 =0x00000001 R3 =0x00000000
R4 =0x00000001 R5 =0x02839478 R6 =0x022EF224 R7 =0x000000F0
R8 =0x00000000 R9 =0x00000000 R10=0xBEA97A38 R11=0x00000000
R12=0x00000001 SP =0xBEA97A28 LR =0x405F5A44 PC =0x405F3008
CPSR=0x80000010

Info: new SP for inject code 0xBEA97628
Done.

# cat /mtd_ram/PVRplus_debug.log 
injector() started
self open
loading main module:
/mtd_tlib/GGame/PVRplus/pvrplus.so
cannot open main module:
/mtd_tlib/GGame/PVRplus/pvrplus.so: undefined symbol: _ZN8TCWindow9MuteVideoEb
#
I have also alternative original firmware T-CHL7DEUC-2005.0 and PVR+ 3.0 is working fine on it, however it is not a patched version, so I have a problem running other samygo services, or autostarting the telnet.

Is this known issue with T-CHL7DEUC-1008.0 firmware or I did something wrong loading it? Thank you for your help.

Here is my current service menu screenshot:
Image

DEvil0000
Posts: 15
Joined: Tue Feb 14, 2012 2:35 pm

Re: PVR+ 3.x

Post by DEvil0000 » Sun May 27, 2012 11:33 pm

adrive wrote:... In both cases (starting as app from contents, or injectso) it logs undefined symbol error: _ZN8TCWindow9MuteVideoEb
...
you have to load the loader.so!

c74k
Posts: 105
Joined: Tue May 04, 2010 7:45 pm

Re: PVR+ 3.x

Post by c74k » Sat Jun 09, 2012 8:37 am

how to record on NAS
i have NFS instaled but if i run record - recording stoped no bitrate data and create empy files on NAS

Post Reply

Return to “[B] Software”