Segmentation fault

Here for general support for E series TVs, request and problem solve area.
Post Reply

TDCroPower
SamyGO Project Donor
Posts: 26
Joined: Fri Oct 17, 2014 8:13 am

Segmentation fault

Post by TDCroPower »

i have a problem on my ES7090 which says "Segmentation fault".
Unfortunately, the problem occurs very sporadically.
Last I had the segmentation fault problem on an oscam binary.

Modellcode: UE40ES7090
Softwareversion: T-ECPDEUC-2022.0

here the sam.log output from my usb stick...

Code: Select all

tcp        0      0 0.0.0.0:4023            0.0.0.0:*               LISTEN      
tcp        0      0 127.0.0.1:49826         0.0.0.0:*               LISTEN      
tcp        0      0 0.0.0.0:9090            0.0.0.0:*               LISTEN      
tcp        0      0 127.0.0.1:51982         0.0.0.0:*               LISTEN      
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      
tcp        0      0 127.0.0.1:50000         0.0.0.0:*               LISTEN      
tcp        0      0 0.0.0.0:6000            0.0.0.0:*               LISTEN      
tcp        0      0 0.0.0.0:4023            0.0.0.0:*               LISTEN      
tcp        0      0 0.0.0.0:55000           0.0.0.0:*               LISTEN      
tcp        0      0 0.0.0.0:55001           0.0.0.0:*               LISTEN      
tcp        0      0 127.0.0.1:44154         0.0.0.0:*               LISTEN      
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      
tcp        0      0 192.168.180.17:7676     0.0.0.0:*               LISTEN      
+ echo checking /dtv/usb/sda1
checking /dtv/usb/sda1
+ sleep 1
+ [ -e /dtv/usb/sda1/SamyGO_data/128mb.xfs ]
+ echo OK
+ samygo_data_dir=/dtv/usb/sda1/SamyGO_data
+ cd /tmp
+ [ -z /dtv/usb/sda1/SamyGO_data ]
+ mkdir /tmp/bin
+ cp /dtv/usb/sda1/SamyGO_data/UEP_killer.sh /tmp/bin/
+ chmod +x /tmp/bin/UEP_killer.sh
+ /mtd_exe/InfoLink/lib/unzip -o -P 12345 /dtv/usb/sda1/SamyGO_data/data.zip -d /tmp/bin/
Archive:  /dtv/usb/sda1/SamyGO_data/data.zip
+ /tmp/bin/UEP_killer.sh
  inflating: /tmp/bin/busybox        
  error:  invalid compressed data to inflate
  inflating: /tmp/bin/libSkype.so    
+ chmod +x /tmp/bin/busybox
+ ln -s /dev/loop3 /tmp/loopnone
+ sync
+ /tmp/bin/busybox losetup /tmp/loopnone /dtv/usb/sda1/SamyGO_data/128mb.xfs
Segmentation fault
+ /tmp/bin/busybox mount -o sync,exec /tmp/loopnone /mnt
Segmentation fault
+ /tmp/bin/busybox --install -s /mnt/bin
Segmentation fault
+ sync
+ export PATH=/mnt/bin:/sbin:/usr/sbin:/bin:/usr/bin
+ export LD_LIBRARY_PATH=/mnt/lib:/mtd_cmmlib/RECOGNITION_LIB:/lib:/mtd_cmmlib/lib:/mtd_cmmlib/Comp_LIB:/mtd_exe/lib:/mtd_cmmlib/YWidget_LIB:/mtd_contents:/mtd_cmmlib/InfoLink/lib/plugin/Static:/mtd_appdata/moip:/mtd_cmmlib/GAME_LIB:/mtd_appdata/gemstar:/mtd_cmmlib/DRM_LIB:/Java/lib:/mtd_cmmlib/InfoLink/lib:/dtv:/mtd_appext/WidgetEngine:/mtd_rocommon/Webkit:/mtd_appext/Webkit:/mtd_exe/WebServerApp/bin:/mtd_appdata/Runtime/lib/CairoShadow:/mtd_appdata/Runtime/lib:/mtd_appdata/Runtime/XorgLibs:/mtd_appdata/yahoo:/mtd_appdata/yahoo/lib:/mtd_cmmlib/CM_LIB:/mtd_appext/OIPF/lib:/mtd_exe/OIPF/lib:/mtd_cmmlib/stagecraft20/libs/
+ sync
+ /mnt/bin/busybox tcpsvd -vE 0.0.0.0 21 /mnt/bin/busybox ftpd -w /
/dtv/usb/sda1/SamyGO_data/run1.sh: line 41: /mnt/bin/busybox: not found
+ sync
+ /mnt/bin/samygo_telnetd 2023
/dtv/usb/sda1/SamyGO_data/run1.sh: line 43: /mnt/bin/samygo_telnetd: not found
+ chmod 777 /mnt/rcSGO
chmod: /mnt/rcSGO: No such file or directory
+ sync
+ sh -x /mnt/rcSGO
sh: can't open '/mnt/rcSGO'
+ sync
+ read child_pid others
+ grep -v grep
+ grep run.sh
+ ps
+ echo Killing child process 820 of run.sh
Killing child process 820 of run.sh
+ kill -9 820
+ read child_pid others
Killing child process 1005 of UEP.b

zoelechat
Official SamyGO Developer
Posts: 8409
Joined: Fri Apr 12, 2013 7:32 pm
Location: France

Re: Segmentation fault

Post by zoelechat »

https://en.wikipedia.org/wiki/Segmentation_fault

Your bin is probably not correctly or not specifically compiled to work on your TV (wrong toolchain/arch), but there are tons of other possible unguessable causes.
I do NOT receive any PM. Please use forum.

TDCroPower
SamyGO Project Donor
Posts: 26
Joined: Fri Oct 17, 2014 8:13 am

Re: Segmentation fault

Post by TDCroPower »

It's just weird because they are the same files as before the problem.
I did not change anything on the USB stick or TV.

TDCroPower
SamyGO Project Donor
Posts: 26
Joined: Fri Oct 17, 2014 8:13 am

Re: Segmentation fault

Post by TDCroPower »

Unfortunately, I have to set the topic to on hold first.

Today I saved the settings via the menu.
Then I went down to the 0000 firmware and from there to the 2003 firmware... unfortunately the SmartHub doesn't work there anymore :x .
So I went up to 2009... also no working SmartHub :evil:.
So I'm back on 2022 and have everything set up as usual.

Now it works again, unfortunately the ghost is still hidden somewhere.
Let's see if I can find a resolution of "Segmentation fault" in parallel to test it more effectively in the future.

The problem must have a cause somewhere, if it works after a factory reset !?

Post Reply

Return to “[E] Support”