No samba shares on virtual USB

Here for general support for E series TVs, request and problem solve area.

barrymossel
SamyGO Project Donor
Posts: 12
Joined: Sat Jun 15, 2013 6:13 pm

No samba shares on virtual USB

Post by barrymossel » Sun Jun 16, 2013 7:25 am

I achieved telnet and ftp access by following the steps for the widget. I see a virtual usb device, but no video's/music/photos are shown, it's totally empty. I have a Samba share present in my network, but apparantly it's not found.

I have almost no linux knowledge by the way.

I changed /mnt/etc/init.d/04_04_samba.init

. /dtv/SGO.env
# sleep 9
##### CHANGE MEEEEE !!!!! ######
USER=""
PASSWD=""
PERM="rw" # can be ro or rw
##### CHANGE MEEEEE END ######

As my share requires no user or passwd. Also tried guest as user. And tried random strings for both user and passwd.

Tried changing the server to:

DEST_DIR=$MOUNT_PATH/smb
# SERVER=""
SERVER="192.168.2.253" # if you want a fixed server
SHARES=""
FR_NAME="Samba Server"
# M_OPTS="rw,user=${USER},password=${PASSWD}"
M_OPTS="$PERM,user=${USER},password=${PASSWD},codepage=cp1250,iocharset=utf8"

Nothing works.

I tried mounting the share manually through telnet:

VDLinux#> mount -o guest -t cifs //192.168.2.253/samba /dtv/usb/sdj/nas
mount: unknown filesystem type 'cifs'

So apparantly cifs is not loaded?
I have a UE40ES6300. Can someone help?

iDeep
Posts: 34
Joined: Wed Apr 24, 2013 3:15 pm

Re: No samba shares on virtual USB

Post by iDeep » Sun Jun 16, 2013 9:06 am

Try assigning both your TV and Samba server static IP's and use LAN connection for initial setup. Also, it takes a bit for TV to detect and populate the Samba shares.
Samsung UA40ES6600R (XZN)
Firmware : T-MST10PDAAC-1017.1
DATE : 2013-02-26
MICOM : T-MST10PDAAS-1004
SDAL : 4.28.0.0

barrymossel
SamyGO Project Donor
Posts: 12
Joined: Sat Jun 15, 2013 6:13 pm

Re: No samba shares on virtual USB

Post by barrymossel » Sun Jun 16, 2013 9:30 am

Both the TV and server have static IP's. TV is connected with ethernet cable, HDD is connected by USB to modem (modem creates Samba server - which is accesible in Windows).

How long should I be waiting for the share to be detected (TV was turned on for about 3-4 hours yesterday after installing the SamyGo widget).

iDeep
Posts: 34
Joined: Wed Apr 24, 2013 3:15 pm

Re: No samba shares on virtual USB

Post by iDeep » Sun Jun 16, 2013 11:09 am

For me it takes 20-30 seconds to get detected.
Samsung UA40ES6600R (XZN)
Firmware : T-MST10PDAAC-1017.1
DATE : 2013-02-26
MICOM : T-MST10PDAAS-1004
SDAL : 4.28.0.0

barrymossel
SamyGO Project Donor
Posts: 12
Joined: Sat Jun 15, 2013 6:13 pm

Re: No samba shares on virtual USB

Post by barrymossel » Sun Jun 16, 2013 12:15 pm

Doesn't it have something to do with the cifs not being loaded?

barrymossel
SamyGO Project Donor
Posts: 12
Joined: Sat Jun 15, 2013 6:13 pm

Re: No samba shares on virtual USB

Post by barrymossel » Tue Jun 18, 2013 4:59 pm

Anyone?

User avatar
fluffi444
SamyGO Project Donor
Posts: 562
Joined: Fri Apr 05, 2013 9:55 pm
Location: Germany

Re: No samba shares on virtual USB

Post by fluffi444 » Thu Jun 20, 2013 9:30 pm

Please try this:

http://<Your TV IP>:1080/phpsysinfo/shell.php

User: user
Password: pass

insmod /mnt/lib/modules/2.6.35.13/kernel/fs/cifs/cifs.ko

What is the result?

AND: Read this thread: viewtopic.php?f=52&t=5822c
Quite long but could be helpfull for you....
TV: UE40ES7000 @ UE40ES8090 - T-ECPDEUC-2022.0 // SamyGO
CI+: Unicam EVO 4 with HD+ (HD02) @ Pacific 4.60
NET: Samba: PC

barrymossel
SamyGO Project Donor
Posts: 12
Joined: Sat Jun 15, 2013 6:13 pm

Re: No samba shares on virtual USB

Post by barrymossel » Fri Jun 21, 2013 2:29 pm

Ok.

I managed to mount the share by manually loading cifs.ko and mounting the share with the next commands:

Code: Select all

insmod /mnt/lib/modules/2.6.35.13/kernel/fs/cifs/cifs.ko
mount -o username=guest,password= -t cifs //192.168.2.253/samba /dtv/usb/sdj/smb
Whereas I manually created the /dtv/usb/sdj/smb directory before.

Works great! But...

I, ofcourse, want it to load automatically. So I edited 04_04_samba.init to:
SpoilerShow
#!/bin/sh
#
# ? Copyright 1996-2010, ZsoltTech.Com
# by Ser Lev Arris <arris@ZsoltTech.Com>
#
# donated for the SamyGo Project
# http://samygo.sourceforge.net/
#
# Version: SamyGO svn $Id: 04_04_samba.init 1069 2011-01-03 16:47:24Z arris69 $
#

. /dtv/SGO.env
# sleep 9
##### CHANGE MEEEEE !!!!! ######
USER="guest"
PASSWD=""
PERM="rw" # can be ro or rw
##### CHANGE MEEEEE END ######

[ -e /mtd_rwarea/smb_userdata ] && source /mtd_rwarea/smb_userdata

[ -z $USER ] && exit 1
[ -z $PASSWD ] && exit 1

DEST_DIR=$MOUNT_PATH/smb
SERVER="192.168.2.253"
# SERVER="10.0.0.1" # if you want a fixed server
SHARES=""
FR_NAME="Samba Server"
# M_OPTS="rw,user=${USER},password=${PASSWD}"
M_OPTS="$PERM,user=${USER},password=${PASSWD},codepage=cp1250,iocharset=utf8"

SERVERS="Don't set me!!"

do_mount()
{
# $(echo -e "[sdh]\nVendor : CifsMount\nProduct : $FR_NAME\n\
#Serial : Q80VQLFH\nDevpath : 8\nLun : 0\nMountDir : $DEST_DIR\nFileSystem : vfat\n" >> /dtv/usb/log)

for i in $S_MOUNTS ; do
i="$(echo -n $i | sed -e 's/SGOspace/ /g')"
M_POINT="$DEST_DIR/$1/$(echo -n $i | sed -e "s/\\\$/_/g")"
mkdir -p "$M_POINT"
if [ `cat /proc/mounts | grep -c "$M_POINT"` -lt "1" ] ; then
/bin/busybox mount -o "${M_OPTS}" -t cifs "//$1/$i" "$M_POINT"
else
echo "$M_POINT is mounted!"
fi

done
}

get_shares()
{
echo "Search Shares"
for i in $SERVERS ; do
echo "on: $i"
S_MOUNTS=$(smbclient -s "$SYSROOT/etc/samba/smb.conf" -U ${USER}%${PASSWD} \
-g -L $i | grep "Disk|" | grep -v "\\$" | grep -v " Service" | sed -r 's/.*\|(.*)\|.*/\1/' | sed -r 's/ /SGOspace/g')
# -g -L $i | grep "Disk|" | grep -v "\\$" | grep -v " Service" | cut -d "|" -f2)
[ -n "$S_MOUNTS" ] && do_mount $i
done
}

get_servers()
{
if [ -z "$SERVER" ] ; then
# SERVERS=$(cat /proc/net/arp | grep -v "IP address" | cut -d " " -f1)
SERVERS=$(cat /proc/net/arp | grep -v "IP address" | sed 's/^\(\w*.\w*.\w*.\w*\) *.*/\1/')
else
SERVERS=$SERVER
fi
}

case $1 in
start)
insmod /mnt/lib/modules/2.6.35.13/kernel/fs/cifs/cifs.ko
mkdir -p "$DEST_DIR"
# get_servers
# get_shares
mount -o username=guest,password= -t cifs //192.168.2.253/samba /dtv/usb/sdj/smb
;;
stop)
# may can fail if device access the mount from content library
# for i in $(cat /proc/mounts | grep cifs | cut -d " " -f2) ; do
for i in $(cat /proc/mounts | grep cifs | grep "$DEST_DIR" | sed 's/^\(.*\) \(.*\) cifs .*/\2/') ; do
i="$(echo -n $i | sed -r 's/\\040/ /g')"
/bin/busybox umount "$i"
done
;;
status)
/bin/mount | grep "$DEST_DIR"
;;
*)
echo "Usage: $0 {start|stop}" 1>&2
exit 0
;;
esac
Changes I made:
- USER="guest"
- Fixed server
- Changed the loading of cifs.ko (insmod /mnt/lib/modules/2.6.35.13/kernel/fs/cifs/cifs.ko)
- Added mounting with above command
- Commented out get_servers and get_shares

Still doesn't work automatically. The cifs.ko won't load automatically through the above file. If I restart the TV I always have to manually load cifs.ko with the above command.

What is going wrong?
Last edited by barrymossel on Sat Jun 22, 2013 6:04 pm, edited 1 time in total.

miazza
SamyGO Project Donor
Posts: 714
Joined: Wed Apr 03, 2013 6:10 pm

Re: No samba shares on virtual USB

Post by miazza » Sat Jun 22, 2013 11:29 am

Tell us model and FW version.
I had the same issue on my ES8000 because the firmware was a debug version.
I solved with the last 2008 FW update.

Look at this viewtopic.php?f=52&t=5894
AVOID TO PUBLISH AND DISCLOSE SAMYGO PROJECTS ON OTHER FORUM.

barrymossel
SamyGO Project Donor
Posts: 12
Joined: Sat Jun 15, 2013 6:13 pm

Re: No samba shares on virtual USB

Post by barrymossel » Sat Jun 22, 2013 6:02 pm

I've read your topics, that's why I got this far. I own a ES63000 with latest firmware (1033). And I do have the share working. But only if I manually load cifs.ko and mount the share. Even with above changes tot 04_04_samba.init. I believe that file isn't working correct for some reasonm because it doesn't fire the commands; I have to do that manually. But actually I don't know anything about linux.

Post Reply

Return to “[E] Support”