Made mistake in user.sh patched BD-D7500B wont boot

User avatar
arris69
SamyGO Moderator
Posts: 1700
Joined: Fri Oct 02, 2009 8:52 am
Location: Austria/Vienna (no Kangaroos here)
Contact:

Re: Made mistake in user.sh patched BD-D7500B wont boot

Post by arris69 » Mon Jan 28, 2013 10:55 am

alessio71 wrote:..
So I will never be able to use a newer exeDSP at least that our friend arris69 won't update his patched FW, correct?
not correct, if you allready have a patched firm on your device then you can dump the partitions, unsquashfs it check the changes against the original one, modify it in same way repack again and flash your version back...

lewy20041
Posts: 27
Joined: Mon Jan 28, 2013 8:36 pm

Re: Made mistake in user.sh patched BD-D7500B wont boot

Post by lewy20041 » Mon Jan 28, 2013 9:34 pm

hello. i desperatly need help. i have bd-d7500 blueray 3d player i changed the dns tu 149.154.159.134 and it found the update B-FIRBP7WWC_001671. i flashed it and now my blueray player isnt working at all samsung smart logo and after that black screan. please hellp

alessio71
Posts: 39
Joined: Wed Sep 26, 2012 8:47 pm

Re: Made mistake in user.sh patched BD-D7500B wont boot

Post by alessio71 » Tue Jan 29, 2013 9:40 pm

arris69 wrote:
not correct, if you allready have a patched firm on your device then you can dump the partitions, unsquashfs it check the changes against the original one, modify it in same way repack again and flash your version back...
wow, sounds quite simple said like that but... I've already played my jolly with warranty and I don't think I'll risk this procedure without having a backdoor access (like the serial console).

What I'd like, is to have at least the SamyGO extentions working.
I've noticed that after the whole procedure with my new mainboard the process went somehow differently:

1) after the FW update to B-FIRBP7WWC_001671, the BD reports to have 1671.0 on it but before to have my motherboard replaced, following the same procedure, it was reporting to have the "real" 1004.x
2) I cannot manage to have all the SamyGO extensions' features working: for example the smb (client) is not working and the same with the "fake" usb storage. I tried to launch from telnet the 02_04_vusb.init script and this is what i get:

Code: Select all

./02_04_vusb.init start
mkfs.vfat 2.11 (12 Mar 2005)
insmod: can't insert '/mtd_down/widgets/user/SamyGOE/SamyGO/lib/modules/2.6.30.9/kernel/drivers/usb/gadget/dummy_hcd.ko': unknown symbol in module, or unknown parameter
insmod: can't insert '/mtd_down/widgets/user/SamyGOE/SamyGO/lib/modules/2.6.30.9/kernel/drivers/mstar/usb/gadget/dummy_hcd.ko': unknown symbol in module, or unknown parameter
insmod: can't insert '/mtd_down/widgets/user/SamyGOE/SamyGO/lib/modules/2.6.30.9/kernel/drivers/usb/gadget/g_file_storage.ko': unknown symbol in module, or unknown parameter
insmod: can't insert '/mtd_down/widgets/user/SamyGOE/SamyGO/lib/modules/2.6.30.9/kernel/drivers/mstar/usb/gadget/g_file_storage.ko': unknown symbol in module, or unknown parameter
cat: can't open '/sys/block/sd?/device/model': No such file or directory
real storage device at: /sys/block/sd?/device/model
I've checked and in the modules folder I don't have the 2.6.30.9 directory but a 2.6.24_SELP.4.3.x-Cortex-A8:

Code: Select all

ls /mtd_down/widgets/user/SamyGOE/SamyGO/lib/modules
2.6.24_SELP.4.3.x-Cortex-A8
Looks like there is something wrong betweeen the actual linux version and the libraries present in the actual SamyGO extensions:

Code: Select all

Linux version 2.6.30.9 (joongyu.sun@sp2) (gcc version 4.4.1 (VDLinux ga-release 2010-06-30) ) #45 PREEMPT Mon Feb 7 20:24:37 KST 2011
Can somebody help me with this?

Thank you.
Alessio
Last edited by alessio71 on Tue Jan 29, 2013 9:58 pm, edited 1 time in total.

alessio71
Posts: 39
Joined: Wed Sep 26, 2012 8:47 pm

Re: Made mistake in user.sh patched BD-D7500B wont boot

Post by alessio71 » Tue Jan 29, 2013 9:43 pm

lewy20041 wrote:hello. i desperatly need help. i have bd-d7500 blueray 3d player i changed the dns tu 149.154.159.134 and it found the update B-FIRBP7WWC_001671. i flashed it and now my blueray player isnt working at all samsung smart logo and after that black screan. please hellp
Have you tried a simple "Factory Reset" procedure?

Code: Select all

Reset Your Blu-ray

    Power on your Blu-ray player and tune your TV to the input where the Blu-ray player is connected. For example, if the Blu-ray player is connected to HDMI 1 press the TV input/source/line button to tune your TV to HDMI 1.

    Remove any disc from the player and then press and hold the Stop button on the front of the player, not the remote, for about 8 seconds or until the front display reads ?SETUP?. 'Resetting all settings to default values...' is displayed on your TV screen as the Blu-ray player powers off and resets.

    The Blu-ray player is automatically powered on after the reset and the select Language screen is displayed.

User avatar
arris69
SamyGO Moderator
Posts: 1700
Joined: Fri Oct 02, 2009 8:52 am
Location: Austria/Vienna (no Kangaroos here)
Contact:

Re: Made mistake in user.sh patched BD-D7500B wont boot

Post by arris69 » Tue Jan 29, 2013 10:13 pm

alessio71 wrote:....
Looks like there is something wrong betweeen the actual linux version and the libraries present in the actual SamyGO extensions:

Code: Select all

Linux version 2.6.30.9 (joongyu.sun@sp2) (gcc version 4.4.1 (VDLinux ga-release 2010-06-30) ) #45 PREEMPT Mon Feb 7 20:24:37 KST 2011
Can somebody help me with this?

Thank you.
Alessio
reinstall it...
Last edited by arris69 on Tue Jan 29, 2013 10:14 pm, edited 1 time in total.
Reason: SamyGOE_FIRENZE_BD_usermode

alessio71
Posts: 39
Joined: Wed Sep 26, 2012 8:47 pm

Re: Made mistake in user.sh patched BD-D7500B wont boot

Post by alessio71 » Tue Jan 29, 2013 10:25 pm

arris69 wrote:
reinstall it...
The firmware or the Extensions? I tried to reinstall the extensions but nothing changed... and the firmware reports that there are no updates available (as I said, before, when I went in the firmware update menu, I had the "real" 1004, now i get the 1671 that's why I don't get any update)

Thank you,
Alessio

User avatar
arris69
SamyGO Moderator
Posts: 1700
Joined: Fri Oct 02, 2009 8:52 am
Location: Austria/Vienna (no Kangaroos here)
Contact:

Re: Made mistake in user.sh patched BD-D7500B wont boot

Post by arris69 » Tue Jan 29, 2013 10:40 pm

alessio71 wrote:
arris69 wrote:
reinstall it...
The firmware or the Extensions? I tried to reinstall the extensions but nothing changed... and the firmware reports that there are no updates available (as I said, before, when I went in the firmware update menu, I had the "real" 1004, now i get the 1671 that's why I don't get any update)

Thank you,
Alessio
the extensions, now you should have the version with the correct kernel modules...

alessio71
Posts: 39
Joined: Wed Sep 26, 2012 8:47 pm

Re: Made mistake in user.sh patched BD-D7500B wont boot

Post by alessio71 » Tue Jan 29, 2013 11:12 pm

You're amazing!
Thank you!

Alessio

alessio71
Posts: 39
Joined: Wed Sep 26, 2012 8:47 pm

Re: Made mistake in user.sh patched BD-D7500B wont boot

Post by alessio71 » Tue Jan 29, 2013 11:16 pm

Please, let me ask you one last question:
woldn't be possible to launch a copy of the new firmware (unpacked and exeDSP patched) from the usb? Using the run.sh hotplug feature?
I know it sound difficult but at least I don't risk (and I don't want to) to brick my BD...

Thank you again,
Alessio

P.S.
Isn't possbile yet to use an USB keyboard connected to the BD? I see that all the imput modules for usb are missing...

Code: Select all

insmod: can't insert '/mtd_down/widgets/user/SamyGOE/SamyGO/lib/modules/2.6.30.9/kernel/drivers/usb/input/usbhid.ko': unknown symbol in module, or unknown parameter
insmod: can't insert '/mtd_down/widgets/user/SamyGOE/SamyGO/lib/modules/2.6.30.9/kernel/drivers/hid/hid.ko': unknown symbol in module, or unknown parameter

lewy20041
Posts: 27
Joined: Mon Jan 28, 2013 8:36 pm

Re: Made mistake in user.sh patched BD-D7500B wont boot

Post by lewy20041 » Wed Jan 30, 2013 8:11 am

alessio71 wrote:
lewy20041 wrote:hello. i desperatly need help. i have bd-d7500 blueray 3d player i changed the dns tu 149.154.159.134 and it found the update B-FIRBP7WWC_001671. i flashed it and now my blueray player isnt working at all samsung smart logo and after that black screan. please hellp
Have you tried a simple "Factory Reset" procedure?

Code: Select all

Reset Your Blu-ray

    Power on your Blu-ray player and tune your TV to the input where the Blu-ray player is connected. For example, if the Blu-ray player is connected to HDMI 1 press the TV input/source/line button to tune your TV to HDMI 1.

    Remove any disc from the player and then press and hold the Stop button on the front of the player, not the remote, for about 8 seconds or until the front display reads ?SETUP?. 'Resetting all settings to default values...' is displayed on your TV screen as the Blu-ray player powers off and resets.

    The Blu-ray player is automatically powered on after the reset and the select Language screen is displayed.
it didnt helped. isnt there some ran.sh firmware upgrade scrip as this firmware suposed be samygo pached

Post Reply

Return to “Support”