Setting up a cross compiling toolchain

Ideas and dreaming will go this forum

Posts: 160
Joined: Wed Jan 13, 2010 12:02 pm

Re: Setting up a cross compiling toolchain

Post by nbd » Fri Feb 12, 2010 9:59 pm

I installed Arm port of Debian Lenny with qemu from here. Then I mounted the hda.img with -o loop to my nfs export path and mounted it from the TV. Now I have gcc/gdb running from TV. (Better to exit qemu before mounting, or you will experience strange things if you modify the filesystem through the -o loop mount)

I also tried running nmap, but it says "Bus error"


My bad. I tried running nmap under chroot, but it runs fine from the TV after I added the library paths:

Code: Select all

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/dtv/usb/sda2/armel_chroot/lib
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/dtv/usb/sda2/armel_chroot/usr/lib

User avatar
Official SamyGO Developer
Posts: 1700
Joined: Fri Oct 02, 2009 8:52 am
Location: Austria/Vienna (no Kangaroos here)

Re: Setting up a cross compiling toolchain

Post by arris69 » Sat Mar 27, 2010 4:27 pm

xer21 wrote:ended up using ./configure --host=arm-SamyGO-linux-gnueabi

that seems to work... but I need glib2.0, i downloaded the source trying to compile using

./configure --host=arm-SamyGO-linux-gnueabi

but it fails saying "cannot run test program while cross compiling"... funnnnnnnnnnnnnn.... anyone know how to bypass that? I'm thinking maybe of just resetting up scratchbox and trying that method again, I was able to compile glib2 no problem using scratchbox, my test program worked, but I was getting Bus Error on my program, went to go mess with it again and scratch box was broken some how... haha
may you need
--build and --target to set, btw. why you don't switch to our openembedded?


Post Reply

Return to “[B] Brainstorm”