[App] SamyGO ChannelInfo for D(arm)/E/F series!

Here are software that related with Samsung F series TVs.
Please don't create any new topic here unless you have software to post/release.

mackowiakp
Posts: 67
Joined: Sat Apr 07, 2012 4:33 pm
Location: Gdynia/Poland

Re: [APP] SamyGO ChannelInfo for D(arm)/E/F series!

Post by mackowiakp » Tue Mar 31, 2015 7:48 am

I read whole topic and I still dont know how to change default 10s of displaying info bar to for example 4,5 sec. Any help?
WARNING ! The administrator has the right to refuse to install WINDOWS, invoking the conscience clause !

User avatar
juusso
SamyGO Moderator
Posts: 10003
Joined: Sun Mar 07, 2010 6:20 pm

Re: [APP] SamyGO ChannelInfo for D(arm)/E/F series!

Post by juusso » Mon Apr 06, 2015 12:20 pm

This is possible with help of SamyGO STFU mod D(arm)/E/F viewtopic.php?f=21&t=6558#p47446
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

mackowiakp
Posts: 67
Joined: Sat Apr 07, 2012 4:33 pm
Location: Gdynia/Poland

Re: [APP] SamyGO ChannelInfo for D(arm)/E/F series!

Post by mackowiakp » Tue Apr 07, 2015 7:58 am

THX! Works!
WARNING ! The administrator has the right to refuse to install WINDOWS, invoking the conscience clause !

User avatar
fluffi444
SamyGO Project Donor
Posts: 560
Joined: Fri Apr 05, 2013 9:55 pm
Location: Germany

Re: [APP] SamyGO ChannelInfo for D(arm)/E/F series!

Post by fluffi444 » Thu Jun 11, 2015 10:10 pm

I don't know if some of you uses the media center app PLEX.

After hours of testing and searching what force my TV to black screen and reboot after using PLEX app, I found out that libChannelInfo.so is the reason...
Without libChannelInfo: no issues - With libChannelInfo: freeze, blackscreen and reboot after closing PLEX app (after some minutes of video playback).

This is quite good reproducible:

- Boot TV without injected libChannelInfo.so
- Inject libChannelInfo.so via SSH - success (I can inject it as often I want from SSH)

Code: Select all

samyGOso v1.2.4 (c) bugficks 2013, sectroyer 2014
Injecting '/mnt/opt/privateer/usr/libso/libChannelInfo.so' resident: '1'
adding libc addr to found symaddress c1c80 + 40f6a000 4102bc80
Succeeded.
- start PLEX app and close it right away
- Inject libChannelInfo.so via SSH - fail - sometimes freeze and reboot - sometime nothing but everytime (after PLEX using) this output:

Code: Select all

samyGOso v1.2.4 (c) bugficks 2013, sectroyer 2014
Injecting '/mnt/opt/privateer/usr/libso/libChannelInfo.so' resident: '1'
Segmentation fault
I know that this combination (PLEX app and SamyGOs ChannelInfo) is not very common but maybe someone has the time an motivation to look into this. I really like ChannelInfo but I like PLEX more ;)

Plex_2002_final - Just move Plex folder to user apps via FTP
https://www.dropbox.com/s/g4bwlklokcvl3 ... _final.zip

BTW: Is the injection with this command still up-tp-date?

Code: Select all

samyGOso -p `pidof exeDSP` -l $libPATH/libChannelInfo.so
TV: UE40ES7000 @ UE40ES8090 - T-ECPDEUC-2022.0 // SamyGO
CI+: Unicam EVO 4 with HD+ (HD02) @ Pacific 4.60
NET: Samba: PC

User avatar
fluffi444
SamyGO Project Donor
Posts: 560
Joined: Fri Apr 05, 2013 9:55 pm
Location: Germany

Re: [APP] SamyGO ChannelInfo for D(arm)/E/F series!

Post by fluffi444 » Fri Jun 12, 2015 11:21 pm

fluffi444 wrote:I don't know if some of you uses the media center app PLEX.
After hours of testing and searching what force my TV to black screen and reboot after using PLEX app, I found out that libChannelInfo.so is the reason...
Without libChannelInfo: no issues - With libChannelInfo: freeze, blackscreen and reboot after closing PLEX app (after some minutes of video playback).
Solved by zoelechat! Many thanks!
TV: UE40ES7000 @ UE40ES8090 - T-ECPDEUC-2022.0 // SamyGO
CI+: Unicam EVO 4 with HD+ (HD02) @ Pacific 4.60
NET: Samba: PC

Grafhkgb
SamyGO Project Donor
Posts: 89
Joined: Tue Jan 07, 2014 6:21 pm

Re: [APP] SamyGO ChannelInfo for D(arm)/E/F series!

Post by Grafhkgb » Mon Mar 07, 2016 8:14 pm

Hello,
I have change the oscam to the tanjasoft version. And after that the channelinfo don't work!

The files are all on the right place, they have the attribute and the autostart files is also there...
Or is the problem the Samygoso 1.2.4?

miazza
SamyGO Project Donor
Posts: 695
Joined: Wed Apr 03, 2013 6:10 pm

Re: [APP] SamyGO ChannelInfo for D(arm)/E/F series!

Post by miazza » Mon Mar 07, 2016 9:23 pm

Use 1.2.5
AVOID TO PUBLISH AND DISCLOSE SAMYGO PROJECTS ON OTHER FORUM.

Grafhkgb
SamyGO Project Donor
Posts: 89
Joined: Tue Jan 07, 2014 6:21 pm

Re: [APP] SamyGO ChannelInfo for D(arm)/E/F series!

Post by Grafhkgb » Tue Mar 08, 2016 9:07 pm

I have the version 1.2.5 on the path: "/mnt/opt/privateer/usr/bin/", the "99_99_ChannInfoON.init" is in the path "/mnt/etc/init.d/" and the lib is here: "/mnt/opt/privateer/usr/libso/libChannelInfo.so"

All have the attributes:
chmod 755 /mnt/etc/init.d/99_99_ChannInfoON.init
chmod 755 /mnt/opt/privateer/usr/libso/libChannelInfo.so

But why it dont work?
UExxF8090

The EPG App and Oscam works!

zoelechat
Official SamyGO Developer
Posts: 8295
Joined: Fri Apr 12, 2013 7:32 pm
Location: France

Re: [APP] SamyGO ChannelInfo for D(arm)/E/F series!

Post by zoelechat » Tue Mar 08, 2016 9:25 pm

Because lib folder is wrong in startup script, you have to change it to libso

Code: Select all

libPATH=$SYSROOT/opt/privateer/usr/so
Also change exeDSP to exeAPP

Anyway, I think right script and lib are already included (and enabled by default!) in SamyGO-F, there was no need to replace by wrong ones and break original sequence :)
I do NOT receive any PM. Please use forum.

Grafhkgb
SamyGO Project Donor
Posts: 89
Joined: Tue Jan 07, 2014 6:21 pm

Re: [APP] SamyGO ChannelInfo for D(arm)/E/F series!

Post by Grafhkgb » Tue Mar 08, 2016 9:39 pm

Or can you uplaod the right Datafile for the autorun?

Post Reply

Return to “[F] Software”