[APP] SamyGO SPMdecrypt E/F/?

Here are software that related with Samsung F series TVs.
Please don't create any new topic here unless you have software to post/release.

yanhujk
SamyGO Project Donor
Posts: 21
Joined: Thu Jan 23, 2014 8:34 am

Re: [APP] SamyGO SPMdecrypt E/F/?

Post by yanhujk » Tue Feb 18, 2014 4:01 pm

zoelechat wrote:Use telnet, not FTP :)
failed again??

Code: Select all

VDLinux#> cd /mtd_rwcommon/SPMdecrypt
VDLinux#> chmod +x samyGOso
VDLinux#> ./samyGOso -p $(pidof exeTV || pidof exeDSP) -l $(pwd)/libSPMdecrypt.s
o
Segmentation fault

yanhujk
SamyGO Project Donor
Posts: 21
Joined: Thu Jan 23, 2014 8:34 am

Re: [APP] SamyGO SPMdecrypt E/F/?

Post by yanhujk » Wed Feb 19, 2014 5:15 am

is my previous steps right? I copy the app folder to the usb/SPMdecrypt/ in PC , then plug usb to TV ( that app is not install on my tv ), then I contents from zip to TV/mtd_rwcommon/SPMdecrypt

I want to try full path for .so and add -d to command line also cat /.version , But be very sorry I am noob can you give an example for me?

yodo
Posts: 7
Joined: Fri Feb 21, 2014 3:17 pm

Re: [APP] SamyGO SPMdecrypt E/F/?

Post by yodo » Fri Feb 21, 2014 4:30 pm

yanhujk wrote:
zoelechat wrote:Use telnet, not FTP :)
failed again??

Code: Select all

VDLinux#> cd /mtd_rwcommon/SPMdecrypt
VDLinux#> chmod +x samyGOso
VDLinux#> ./samyGOso -p $(pidof exeTV || pidof exeDSP) -l $(pwd)/libSPMdecrypt.s
o
Segmentation fault

After hours of having the same problem as you, i've found a solution (I had been copying and pasting your posting!... It has a typo which is the cause of the Segmentation fault.

Also I used the web interface to send the commands at http://YOUR-IP-ADDRESS-HERE:1080/phpsysinfo/shell.php

You've got

Code: Select all

 ./samyGOso -p $(pidof exeTV || pidof exeDSP) -l $(pwd)/libSPMdecrypt.s
You are missing the "o" on the end "libSPMdecrypt.s" should read "libSPMdecrypt.so"

I ran the following command without the typo and it worked

Code: Select all

./samyGOso -p $(pidof exeTV || pidof exeDSP) -l /mtd_rwcommon/SPMdecrypt/libSPMdecrypt.so
samyGOso v1.1 (c) bugficks 2013
Injecting '/mtd_rwcommon/SPMdecrypt/libSPMdecrypt.so' resident: '0' 
Injecting '/mtd_rwcommon/SPMdecrypt/libSPMdecrypt.so' succeeded.
And after a few mins checking the usb drive at /dtv/usb/sda1/SPMdecrypt -- the file times on all the folders slowly updated over a few mins..

That being said, while the folders have changed, when I try coping some to /mtd_rwcommon/widgets/user
the folders copy, but the apps do not show up in my smarthub -- Any ideas as to whats going on?

yanhujk
SamyGO Project Donor
Posts: 21
Joined: Thu Jan 23, 2014 8:34 am

Re: [APP] SamyGO SPMdecrypt E/F/?

Post by yanhujk » Fri Feb 21, 2014 6:41 pm

it worked? thank you very much
try zip the app?and use SmartHub Widget Manager?

yodo
Posts: 7
Joined: Fri Feb 21, 2014 3:17 pm

Re: [APP] SamyGO SPMdecrypt E/F/?

Post by yodo » Sat Feb 22, 2014 12:47 am

yanhujk wrote:it worked? thank you very much
try zip the app?and use SmartHub Widget Manager?
I'm still running into problems getting apps from other regions installed.

I've got my TV changed to the US, the apps I had decrypted are UK apps.

When I've tried to use the SmartHub Widget Manager, it now shows the apps with the correct description (before this process they were showing as encrypted)

When I try to do a "Start App Sync", I get an error on every app (except SamyGo), like the BBC iPlayer.

On the TV a window pops up and says "Failed to install. For more information, visit http://www.samsungdforum.com/Support/TV/AppsSecurity/"

Any ideas on why i'm getting this error or how to fix it?

Thanks

User avatar
bugficks
Official SamyGO Developer
Posts: 1062
Joined: Tue Jun 25, 2013 3:56 pm

Re: [APP] SamyGO SPMdecrypt E/F/?

Post by bugficks » Sat Feb 22, 2014 12:52 am

did you try modifying config.xml yet?

Code: Select all

	<type>user</type>

yodo
Posts: 7
Joined: Fri Feb 21, 2014 3:17 pm

Re: [APP] SamyGO SPMdecrypt E/F/?

Post by yodo » Sat Feb 22, 2014 6:18 am

bugficks wrote:did you try modifying config.xml yet?

Code: Select all

	<type>user</type>

I'm still having problems.

On the BBC iPlayer app I edited the config.xml file as follows:

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<widget>
  <previewjs>BBC iPlayer</previewjs>
  <preIcon />
  <icon />
  <ThumbIcon>781_106_gloss_eng.png</ThumbIcon>
  <BigThumbIcon>781_115_gloss_eng.png</BigThumbIcon>
  <ListIcon>781_85_gloss_eng.png</ListIcon>
  <BigListIcon>781_95_gloss_eng.png</BigListIcon>
  <Icon1080>icons/128x106.png</Icon1080>
  <category>video</category>
  <autoUpdate>y</autoUpdate>
  <screensaver>n</screensaver>
  <cpname>BBC</cpname>
  <cplogo />
  <user>n</user>
  <cpauthjs />
  <ver>2.024</ver>
  <mgrver />
  <fullwidget>y</fullwidget>
  <srcctl>y</srcctl>
  <ticker>n</ticker>
  <childlock>n</childlock>
  <audiomute>n</audiomute>
  <videomute>n</videomute>
  <dcont>y</dcont>
  <widgetname>BBC iPlayer</widgetname>
  <description>BBC iPlayer</description>
  <width>1280</width>
  <height>720</height>
  <author>
    <name>British Broadcasting Corporation</name>
    <email />
    <link>http://www.bbc.co.uk</link>
    <organization>BBC</organization>
  </author>
  <channelType>child</channelType>
  <channelRoot>1</channelRoot>
  <channelDisplay>y</channelDisplay>
  <apptype>11</apptype>
 <type>user</type>
  <AIT_appid>1</AIT_appid>
  <AIT_orgid>384</AIT_orgid>
  <AIT_version>1.2.3</AIT_version>
  <runTitle>uk.co.bbc.iPlayer</runTitle>
  <ThumbIconHD />
  <BigThumbIconHD />
  <ListIconHD />
  <BigListIconHD />
<packaging>squashfs</packaging></widget>
As you can see I added the <type>user</type> after the <apptype>11</apptype> tag

I then tried ftping the folder over to /mtd_rwcommon/widgets/user
The folder moves over (the only other folder there is the SamyGO folder) but the app does not show up on smart hub.

I also tried ziping up the folder and using the SmartHub Widget Manager but again on the TV got a pop up that says "Failed to install. For more information, visit http://www.samsungdforum.com/Support/TV/AppsSecurity/"

Any other ideas on what I might be doing wrong??
Thanks in advance!

User avatar
bugficks
Official SamyGO Developer
Posts: 1062
Joined: Tue Jun 25, 2013 3:56 pm

Re: [APP] SamyGO SPMdecrypt E/F/?

Post by bugficks » Sat Feb 22, 2014 6:58 am

<user>n</user>
<apptype>11</apptype>

try removing those two lines

User avatar
bugficks
Official SamyGO Developer
Posts: 1062
Joined: Tue Jun 25, 2013 3:56 pm

Re: [APP] SamyGO SPMdecrypt E/F/?

Post by bugficks » Sat Feb 22, 2014 8:28 am

what usually works to bypass that security check.
- take a widget you know installs fine.
- rename it to the one you want to install and install it.
- now overwrite files from the widget you wanted to install w/ ftp.
- restart TV

yodo
Posts: 7
Joined: Fri Feb 21, 2014 3:17 pm

Re: [APP] SamyGO SPMdecrypt E/F/?

Post by yodo » Sat Feb 22, 2014 12:49 pm

bugficks wrote:what usually works to bypass that security check.
- take a widget you know installs fine.
- rename it to the one you want to install and install it.
- now overwrite files from the widget you wanted to install w/ ftp.
- restart TV
Still no luck for me.

What i've tried.

again using the BBC iPlayer app, I've made the changes to the config.xml as above (got rid of the <user> and <apptype> tags, added the <type> tag) and zipped it back up as BBC.zip

Then I used the SmartHub Widget Manager and had it try sync with just Samygo and BBC as the apps to install -- yet again on the TV Igot a pop up that says "Failed to install. For more information, visit http://www.samsungdforum.com/Support/TV/AppsSecurity/"


So instead, since the only app I can seem to install with the SmartHub Widget Manager is samygo, I made 2 versions of the samygo zip, one called SamyGO.zip and one called BBC.zip

Did the app sync using SmartHub Widget Manager and it installed 2 SamygoExt... icons.

FTP'ed in and I have 2 folders in /mtd_rwcommon/widgets/user
SamyGo and BBC

I then cleared out the contents of the BBC folder and replaced them with the files that are from my BBC iPlayer app that has been modified as above.

Now I have 2 icons that the text underneath is "SamyGOext..." but one of them has the BBC iPlayer icon instead of the SamyGo icon.

But.... when I try to run the BBC iPlayer it comes up saying "Loading SamyGoExtensionsF..." and seems to just get stuck there....

Any other ideas? Thanks again in advance for all your help!

Post Reply

Return to “[F] Software”