[ROOT] Rooting E/F on latest firmwares

Here are software that related with Samsung F series TVs.
Please don't create any new topic here unless you have software to post/release.

Riquet065
Posts: 35
Joined: Wed May 16, 2018 3:26 pm

Re: [ROOT] Rooting E/F on latest firmwares

Post by Riquet065 » Sun Jul 21, 2019 11:04 pm

Hello

The root worked good from more one year but today my TV rebooted every 2-3 minutes.
To stop that i was need to delete files or folder:
/mtd_rwcommon/emps/empBrowserCommonPlugin/plugins/libSamyGorun.so
/mtd_rwcommon/SamyGO
/mnt/rcSGO
and i unplug my usb device and the tv didn't reboot.

I install back the root from the begining but the problem start again the reboot every 2-3 minutes.
I have enought memory only 211Mb/1.42Gb used.
I tried to install with some others usb devices but it's the same thing, so now I deleled back the files/folder
/mtd_rwcommon/emps/empBrowserCommonPlugin/plugins/libSamyGorun.so
/mtd_rwcommon/SamyGO
/mnt/rcSGO
in the tv, but if i turn off the tv and plug a clean usb device (Fat32 or Ext4), start the tv and rebooting again all 2-3 minutes!

Maybe the root was not the problem, or i need to delete other files to stop booting the tv when i plug an usb device? I can say i view the SamyGo widget in Smart Hub but after a time i saw it no more, and when i plug an usb device and try to view the source that doesn't work and reboot the TV.

the last sam.log on usb device: tcp 0 0 0.0.0.0:4023 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:55872 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:50000 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:44561 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:50001 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:4023 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:55000 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:55001 0.0.0.0:* LISTEN
tcp 0 0 192.168.1.32:7676 0.0.0.0:* LISTEN
+ echo checking /dtv/usb/sda1
checking /dtv/usb/sda1
+ sleep 1
+ [ -e /dtv/usb/sda1/STOP_SAMYGO ]
+ [ -e /dtv/usb/sda1/SamyGO_data/samyext4.img ]
+ samygo_data_dir=/dtv/usb/sda1/SamyGO_data
+ cd /tmp
+ [ -f /mnt/rcSGO ]
+ [ -z /dtv/usb/sda1/SamyGO_data ]
+ mkdir /tmp/bin
+ /mtd_exe/InfoLink/lib/unzip -o -P 12345 /dtv/usb/sda1/SamyGO_data/data.zip -d /tmp/bin/
Archive: /dtv/usb/sda1/SamyGO_data/data.zip
inflating: /tmp/bin/AutoStart
inflating: /tmp/bin/busybox
inflating: /tmp/bin/libSkype.so
inflating: /tmp/bin/remshd
inflating: /tmp/bin/UEP_killer.sh
inflating: /tmp/bin/remshd33
+ chmod 777 /tmp/bin/AutoStart /tmp/bin/UEP_killer.sh /tmp/bin/busybox /tmp/bin/libSkype.so /tmp/bin/remshd /tmp/bin/remshd33
+ /tmp/bin/busybox --install -s /tmp/bin
+ sync
+ export PATH=/tmp/bin:/usr/sbin:/usr/bin:/bin:/sbin:/etc/Scripts:/util:/mtd_appdata/Runtime/bin
+ export LD_LIBRARY_PATH=/tmp/bin:/mtd_cmmlib/RECOGNITION_LIB:/lib:/mtd_cmmlib/lib:/mtd_cmmlib/Comp_LIB:/mtd_exe/lib:/mtd_cmmlib/YWidget_LIB:/mtd_cmmlib/InfoLink/lib/plugin/Static:/mtd_appdata/moip:/mtd_cmmlib/GAME_LIB:/mtd_appdata/gemstar:/mtd_cmmlib/DRM_LIB:/Java/lib:/mtd_cmmlib/InfoLink/lib:/mtd_appext/WidgetEngine:/mtd_appext/Webkit:/mtd_exe/WebServerApp/bin:/mtd_cmmlib/CBRE:/mtd_cmmlib/CBRE/bin/lib:/mtd_cmmlib/flashplayer/libs:/mtd_appdata/Runtime/lib/CairoShadow:/mtd_appdata/Runtime/lib:/mtd_appdata/Runtime/XorgLibs:/mtd_cmmlib/CM_LIB:/mtd_appext/OIPF/lib:/mtd_exe/OIPF/lib:/mtd_contents:/dtv
+ sync
+ sync
+ /tmp/bin/remshd33
+ /tmp/bin/busybox tcpsvd -vE 0.0.0.0 21 /tmp/bin/busybox ftpd -w /
tcpsvd: listening on 0.0.0.0:21, starting
+ ln -s /dev/loop3 /tmp/loopnone
+ sync
+ /tmp/bin/busybox losetup /tmp/loopnone /dtv/usb/sda1/SamyGO_data/samyext4.img
+ /tmp/bin/busybox mount -o sync,exec /tmp/loopnone /mnt
+ /tmp/bin/busybox --install -s /mnt/bin
+ sync
+ cd /
+ /sbin/rmmod ARS_module
+ echo
+ echo ===========================
+ echo ls -la after rmmod ARS_module
+ echo ===========================
+ ls -la /mnt/bin /mnt/doc /mnt/etc /mnt/firmware /mnt/lib /mnt/mc /mnt/opt /mnt/phpsysinfo /mnt/rcSGO /mnt/sam.log /mnt/samygo.log /mnt/sbin /mnt/src /mnt/usr
+ echo ===========================
+ echo Starting rcSGO from run1.sh
+ echo ===========================
+ /mnt/bin/busybox sh -x /mnt/rcSGO /mnt
+ echo
+ echo ===========================
+ echo Starting UEP_killer.sh
+ echo ===========================
+ ps
+ grep run.sh
+ /tmp/bin/UEP_killer.sh
+ + read child_pid others
grep -v grep
+ echo Killing child process 833 of run.sh
Killing child process 833 of run.sh
+ kill -9 833
+ read child_pid others
tcpsvd: start 1448 192.168.1.32:21-192.168.1.102:51050
tcpsvd: status 1/30
Thank you
TV Samsung UE32F6470; Firmware T-MST12DEUC_2126.0