Page 10 of 13

Re: [App] SamyGO NoDRM E/F (MST only)

Posted: Tue Jan 13, 2015 9:53 pm
by sectroyer
BTW why do you constantly ask about NoDRM if (from what I know) you don't plan to have SamyGO enabled ALL THE TIME? :)

Re: [App] SamyGO NoDRM E/F (MST only)

Posted: Tue Jan 13, 2015 11:35 pm
by tendi
sectroyer wrote:I don't treat it seriously :P :lol: :D :twisted:
I didn't realise that :)
sectroyer wrote:BTW why do you constantly ask about NoDRM if (from what I know) you don't plan to have SamyGO enabled ALL THE TIME? :)
Because I'm still having problems with PVRDecoder and, since I'm interested to record only some scheduled programmes which recur max. 4 times a month, I could root and use it in those occasions.

Re: [App] SamyGO NoDRM E/F (MST only)

Posted: Sat Jan 24, 2015 10:48 am
by iT00NZ
If I do factory reset, will I've got 'clear' TV? I lost my root and the files from ' NoDRM ' are still there. I want to delete them and root 'clear' TV again.

Re: [App] SamyGO NoDRM E/F (MST only)

Posted: Wed Feb 18, 2015 9:48 pm
by iT00NZ
I can't copy into my TV.

Re: [App] SamyGO NoDRM E/F (MST only)

Posted: Sat Feb 21, 2015 12:49 pm
by iT00NZ
If I program the recording when the TV is turned off, the root after starting recording isn't working (it need 30 seconds to start) and NO DRM too. Any idea for that?

Re: [App] SamyGO NoDRM E/F (MST only)

Posted: Tue Mar 24, 2015 3:49 pm
by alexsmith
This post is to let you know that disabling DRM worked perfectly with my F5500 (UN32F5500AGXZD), firmware version 2129.

Current setup info, according to SamyGO PVR decoder:

Model: UN32F5500
Firmware: T-MST12UABC-2129.2 2015-01-21

Just followed all instructions from the first post and it worked.

Thanks a lot!

Re: [App] SamyGO NoDRM E/F (MST only)

Posted: Sun Aug 30, 2015 5:09 pm
by zoelechat
Moved out of donor's area, enjoy! :)

Re: [App] SamyGO NoDRM E/F (MST only)

Posted: Sun Jun 26, 2016 1:59 pm
by rootmysamynow
Hello Reader,

although I really enjoy using NoDRM on my UE39F5370 FW1014, there's one thing (or maybe two) that I don't understand about it:

All "new" recordings ("new" means after enabling NoDRM) get recorded unencrypted (surprise, surprise, ...), and can be played by the TV's recording browser (or on the PC after copying). For all "old" recordings, I can only see previews. Starting to play such an old recording ends in "Wiedergabe fehlgeschlagen" (probably: Play failed).

/dtv/NoDRM.log shows "Key found in DB. Disabling DRM", although NoDRM reports itself to be configured in "Pernament mode!".
This does not change whether the DRM key CRC32 is added to (ie. present in) file /mtd_rwcommon/NoDRM.db, or not.

Of course, after disabling NoDRM, it's the other way round (without the text in NoDRM.log...).

From the above, would anyone be able to help me? I'd be glad to provide more info if requested, and if I'm able to provide it.

Thanks in advance.

The other thing that I stumbled across is:
Once the DB usage had been rectified for me, is there any chance to calculate the CRC32 checksums without selecting every single recording in media browser, and reading the hash from NoDRM.log?
Unfortunately, cksum on my TV creates a CRC40 instead of a CRC32, plus the DRM key listed in NoDRM.log does not seem to match the values stored in the 20160606*.key files created through PVRDecoder...

Thanks again.

Re: [App] SamyGO NoDRM E/F (MST only)

Posted: Sun Jun 26, 2016 2:02 pm
by sectroyer
you should read first post, If you want to to be able to play OLD recordings you HAVE TO use transition mode :)

Re: [App] SamyGO NoDRM E/F (MST only)

Posted: Sun Jun 26, 2016 2:11 pm
by rootmysamynow
Thanks for your very quick response.

Sorry, so I must have misinterpreted your addition to that first post:
Therefore after you have watched/removed most of your DRM protected recordings you should switch to permanent mode and remove the database. In this mode NoDRM will enable DRM only for every video for which CRC32 off DRM key is IN the database. NoDRM will not change the database in this mode so every CRC32 of drm key has to be added manually. NoDRM logs both DRM keys and CRC32 values so it very easy to manually add/remove entries to/from database.
Unfortuntely, that stops me at another stage: Although 99_91_pvr_NoDRM.init requests transition mode, NoDRM.log always reports "Pernament mode!". I did not yet manage to start it in Transition mode, but that would be a different story.

Code: Select all

root@(none) init.d $ samyGOso -p $( pidof exeTV || pidof exeDSP ) -r -l /mnt/opt/privateer/usr/libso/ -d transition
Injecting '/mnt/opt/privateer/usr/libso/' resident: '1' mprotect: 0x41e96f80
dlopen: 0x42158c5c
dlclose: 0x42158cf0
dlsymaddr: 0x42158d50
pc=41fc4654 lr=41fc4638 sp=beb75e80 fp=80
r0=3f054a4 r1=80
r2=1 r3=0
stack: 0xbeb56000-0xbeb77000 length = 135168
executing injection code at 0xbeb75d4c
library injection completed!
root@(non) init.d $ cat /dtv/NoDRM.log
[NoDRM] SamyGO NoDRM v0.3.9 - (c) bugficks 2013
[NoDRM] Pernament mode!
[NoDRM] DRM will be enabled only for entries FROM /mtd_rwcommon/NoDRM.db !
[NoDRM] _Z26_SdPVR_Record_HandleStreamhh [0x421e4994].
[NoDRM] _Z27MApi_PVR_Playback_EnableDRMh [0x42ba5e78].
[NoDRM] _Z31MApi_PVR_Playback_SetDRMPlayKeyPhm [0x42ba5e9c].
[NoDRM] _Z28MApi_PVR_Record_SetDRMRecKeyPhm [0x42ba5f9c].
[NoDRM] SdPVR_Record_HandleStream found at: 0x421e4994
[NoDRM] Patching CMP R2, #1 found at 0x421e4a5c
[NoDRM] init done...
(Sorry again, coloring doesn't seem to work in code env. This is just to show that CMD was started with parameter transition, but log states Pernament, anyway.

PS, by the way, should someone come across this thread and wonder:
I just noticed that cksum does NOT create a CRC40. It's really a CRC32, but the output isn't in hex; it's in decimal. Hence the longer string.
And: The DRM Key listed in NoDRM.log and in *.key file actually DO match. Just some "reworking" needs to be done, as e.g. "0xac2175d0, 0xcc79bb2e, 0xb4b9963c, 0x5b52021b" becomes d0 75 21 ac 2e bb 79 cc - 3c 96 b9 4b 1b 02 52 5b.