UA40F6400 hardware/UART/EXlink

This forum is for information related with F series hardware.

levi
Posts: 24
Joined: Tue Oct 01, 2013 11:27 pm

UA40F6400 hardware/UART/EXlink

Post by levi » Sat Oct 26, 2013 6:01 pm

Hi all,
Today I've opened my TV and found some interesting stuff to share with.
My intention to open TV was to solder debug cable but i've found that actually no soldering required (at least in my TV). Moreover there is no need to open TV at all!
The DEBUG/UART/SERIAL/EXLink interface is available at USB port marked as camera (see photo).
You can see full sized photo of main board here
Here is full power cycle log from serial console. If i understood right it is quite verbose compared to ones posted by other people. I've set Console mode to debug from SM, could it be related to verbos output or i am wrong?
SpoilerShow
Image

User avatar
juusso
SamyGO Moderator
Posts: 9775
Joined: Sun Mar 07, 2010 6:20 pm

Re: UA40F6400 hardware/UART/EXlink

Post by juusso » Mon Oct 28, 2013 12:16 pm

Thanks, we need to move this to the wiki. Just need some more confirmations on which models this does work.
LE40B653T5W,UE40D6750
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

levi
Posts: 24
Joined: Tue Oct 01, 2013 11:27 pm

Re: UA40F6400 hardware/UART/EXlink

Post by levi » Mon Oct 28, 2013 1:10 pm

we need to move this to the wiki
That will be great!
BTW i have more high resolution photos of mainboard without heatsink, i can share them too if anyone interested.

User avatar
juusso
SamyGO Moderator
Posts: 9775
Joined: Sun Mar 07, 2010 6:20 pm

Re: UA40F6400 hardware/UART/EXlink

Post by juusso » Mon Oct 28, 2013 3:03 pm

levi wrote:BTW i have more high resolution photos of mainboard without heatsink, i can share them too if anyone interested.
sure we want :)
LE40B653T5W,UE40D6750
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

levi
Posts: 24
Joined: Tue Oct 01, 2013 11:27 pm

Re: UA40F6400 hardware/UART/EXlink

Post by levi » Tue Oct 29, 2013 9:51 am

Here are some pictures, I will add back side of the board at the weekend...
Flash area - https://db.tt/NiPdvanO
Header area - https://db.tt/uOXiQjlA
Satellite chips - https://db.tt/r568ClK4

levi
Posts: 24
Joined: Tue Oct 01, 2013 11:27 pm

Re: UA40F6400 hardware/UART/EXlink

Post by levi » Sat Nov 02, 2013 2:16 pm

Finally, the back side of motherboard.

Tamagnun
SamyGO Project Donor
Posts: 65
Joined: Tue Sep 10, 2013 7:31 pm
Location: Italy

Re: UA40F6400 hardware/UART/EXlink

Post by Tamagnun » Wed Nov 13, 2013 2:34 pm

As shown in the attached photo, my TV PS64F8500 has the SERVICE PORT in 3,5" stereo jack format, so I think I've to prepare the ExLink cable using my Nokia DLR-5 cable ;) and a stereo male jack, isn't it? In addition, my TV hasn't the CAMERA USB port (camera is embedded)...

If OK, when the serial connection will be opened, what I'll be able to do by using it? Any guide available on the forum?

Thank you for your help and suggestions!
Ciao
You do not have the required permissions to view the files attached to this post.

User avatar
bugficks
Official SamyGO Developer
Posts: 1049
Joined: Tue Jun 25, 2013 3:56 pm

Re: UA40F6400 hardware/UART/EXlink

Post by bugficks » Sun Nov 24, 2013 12:39 am

levi, did you change anything else in service menu beside "uart:debug" and "watchdog:off" ? like setting "USB Serial: Off" to "On" ?

@Tamagnun
just search wiki for 3.5 exlink.

rg2013
Posts: 17
Joined: Sun Nov 24, 2013 9:06 pm

Re: UA40F6400 hardware/UART/EXlink

Post by rg2013 » Sun Nov 24, 2013 9:32 pm

Sorry for any inconvinience. first post ever.
My congratulations to all your good work.
@bugficks
Got my first serial log running.
What I did:
power off
info menu mute power // on standard remote
control - sub option - rs232jack:debug, watchdog:off usbserial:ON
confirmed all changes with enter button
exited with return button
POWER off

started sudo su // on ubuntu 12.04lts
// recognize the difference. I especially mentioned the usbport!!! (that had been my first mistake, so nothing happend)
minicom -D /dev/ttyUSB0

POWER on // TV remote

thats it with a very verbose console in my
(get lucky)

My Hardware:
ftdi usbtoserial uart breakoutboard.
ftdi RX ----- TV camera USB TX
ftdi TX ------ TV camera USB RX
ftdi GND ---- TV camera USB GND

linux notebook ubuntu 12.04lts
sudo apt-get install minicom

SAMSUNG TV 32F5570 / t-mst12deuC-1113.0 / t-mst12deus-1009
wlan and ethernet included without camera, no bluetooth
Hope I could help.


P.S. Forgot to mention. Uart level switched by Hardwarejumper on sparkfun breakout board was 3.3V.
Samsung TV UE32F5570 Firmware: T-MST12DEUC-1113.0 / T-MST12DEUS-1009

User avatar
bugficks
Official SamyGO Developer
Posts: 1049
Joined: Tue Jun 25, 2013 3:56 pm

Re: UA40F6400 hardware/UART/EXlink

Post by bugficks » Mon Nov 25, 2013 12:49 am

setting usb to serial in SM seems to do the trick. connected raspberry pi serial straight to cam port (w/o TTL converter). now i have a wireless connection to tv console, sweet :)

Code: Select all

$cu -l /dev/ttyAMA0 -s 115200
Connected.
[WebKit Core Debug] [void WebCore::GLContext::swapBuffers():898] < 11 frames / 10.006887 fps : url=file://localhost/mtd_down/widgets/manager/10130000000/index.html.s >
i guess once usb is set to serial in SM one has to take care not to plugin regular USB device into cam port.

Post Reply

Return to “[F] Hardware”