22F5400 no telnet no VUSB and no remote working.

Here for general support for F series TVs, request and problem solve area.

miazza
SamyGO Project Donor
Posts: 649
Joined: Wed Apr 03, 2013 6:10 pm

22F5400 no telnet no VUSB and no remote working.

Post by miazza » Thu Sep 29, 2016 7:23 pm

Hello to everybody.
I have a 22F5400 running FW version 119 with OTN disabled since years.
I had root working well for a couple of years with the skype root (now substituded by the new root method without skype.
It was working well (also oscam for MST was working well) since one week ago.

I did not do anything apparently (I was out for business trip) but now I have FTP working but no telnet and all extensions seems not executed (also no 02_04_vusb.init).

After about one minutes that the TV is ON and well working, I cannot anymore do anything ;TV remains on but without any response from remote:
- no channel change
- no volume
- not possible to switch off

Every time I need to unplug from the wall.

What can i do to investigate the issue and solve the problem ?
AVOID TO PUBLISH AND DISCLOSE SAMYGO PROJECTS ON OTHER FORUM.

wluczykijwf
Official SamyGO Developer
Posts: 1025
Joined: Sat Sep 21, 2013 5:07 pm
Location: Poland

Re: 22F5400 no telnet no VUSB and no remote working.

Post by wluczykijwf » Thu Sep 29, 2016 7:47 pm

@miazza:
  1. You delete log files in /mnt directory:
    • sam.log
    • samygo.log
  2. You read the post.
sorry for my english
UE40F8000 (T-FXPDEUC-1125.1), BD-D5500

miazza
SamyGO Project Donor
Posts: 649
Joined: Wed Apr 03, 2013 6:10 pm

Re: 22F5400 no telnet no VUSB and no remote working.

Post by miazza » Thu Sep 29, 2016 8:00 pm

wluczykijwf wrote:@miazza:
  1. You delete log files in /mnt directory:
    • sam.log
    • samygo.log
  2. You read the post.
I did it.
My 01_01_catch_crap.init is like this:

Code: Select all

#!/bin/sh
#
# ? Copyright 1996-2014, SamyGO
#
#
. /dtv/SGO.env

case $1 in 
	start)
		echo "+++++++++++Release notes++++++++++" > $LOGFILE
			cat $SYSROOT/etc/version >> $LOGFILE 2>&1
		echo " " >> $LOGFILE 2>&1
		echo "++++++++++++++++++++++++++++++++++" >> $LOGFILE
		echo "cat /.version" >> $LOGFILE
		echo "++++++++++++++++++++++++++++++++++" >> $LOGFILE
			cat /.version >> $LOGFILE 2>&1	
		echo " " >> $LOGFILE 2>&1
		echo "++++++++++SGO.env+++++++++++++++++" >> $LOGFILE			
			cat /dtv/SGO.env >> $LOGFILE
		echo "++++++++++++++++++++++++++++++++++" >> $LOGFILE			
AVOID TO PUBLISH AND DISCLOSE SAMYGO PROJECTS ON OTHER FORUM.

wluczykijwf
Official SamyGO Developer
Posts: 1025
Joined: Sat Sep 21, 2013 5:07 pm
Location: Poland

Re: 22F5400 no telnet no VUSB and no remote working.

Post by wluczykijwf » Thu Sep 29, 2016 8:03 pm

Do you watchdog is disabled in SM?
sorry for my english
UE40F8000 (T-FXPDEUC-1125.1), BD-D5500

miazza
SamyGO Project Donor
Posts: 649
Joined: Wed Apr 03, 2013 6:10 pm

Re: 22F5400 no telnet no VUSB and no remote working.

Post by miazza » Thu Sep 29, 2016 8:10 pm

Yes Watchdog is disabled.
The TV is not rebooting.... I can use it as far as I do not need to change channel or volume :)
AVOID TO PUBLISH AND DISCLOSE SAMYGO PROJECTS ON OTHER FORUM.

miazza
SamyGO Project Donor
Posts: 649
Joined: Wed Apr 03, 2013 6:10 pm

Re: 22F5400 no telnet no VUSB and no remote working.

Post by miazza » Thu Sep 29, 2016 8:16 pm

OK. I deleted them again and TV rebooted.
Now root working well as one week ago :)

Do you have any idea about how to prevent it for the future ?
AVOID TO PUBLISH AND DISCLOSE SAMYGO PROJECTS ON OTHER FORUM.

wluczykijwf
Official SamyGO Developer
Posts: 1025
Joined: Sat Sep 21, 2013 5:07 pm
Location: Poland

Re: 22F5400 no telnet no VUSB and no remote working.

Post by wluczykijwf » Thu Sep 29, 2016 8:39 pm

I before the fix I did after each change (scripts, libs ect.) on TV a backup samyext4.img file on my PC. In the event of a failure I replace only the samyext4.img on USB with a root.
sorry for my english
UE40F8000 (T-FXPDEUC-1125.1), BD-D5500

miazza
SamyGO Project Donor
Posts: 649
Joined: Wed Apr 03, 2013 6:10 pm

Re: 22F5400 no telnet no VUSB and no remote working.

Post by miazza » Fri Sep 30, 2016 8:35 am

wluczykijwf wrote:I before the fix I did after each change (scripts, libs ect.) on TV a backup samyext4.img file on my PC. In the event of a failure I replace only the samyext4.img on USB with a root.
This is of course a good idea but I do not have root via USB; my widget is autostarting in the "old" way.
AVOID TO PUBLISH AND DISCLOSE SAMYGO PROJECTS ON OTHER FORUM.

User avatar
juusso
SamyGO Moderator
Posts: 9623
Joined: Sun Mar 07, 2010 6:20 pm

Re: 22F5400 no telnet no VUSB and no remote working.

Post by juusso » Fri Sep 30, 2016 9:29 am

Need init script which checks and deletes log files. if size exceeds ...
LE40B653T5W,UE40D6750
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

miazza
SamyGO Project Donor
Posts: 649
Joined: Wed Apr 03, 2013 6:10 pm

Re: 22F5400 no telnet no VUSB and no remote working.

Post by miazza » Fri Sep 30, 2016 10:16 am

juusso wrote:Need init script which checks and deletes log files. if size exceeds ...
Nice.
Do you have one ready to share ?
may be it is already available in some discussion but I do not know how to look for it.
AVOID TO PUBLISH AND DISCLOSE SAMYGO PROJECTS ON OTHER FORUM.

Post Reply

Return to “[F] Support”