Page 1 of 1

Fixing Smart hub

Posted: Mon Aug 27, 2018 11:05 pm
by kasnepatinka
Hi everyone Im trying to access TDM but no success. I was established console connection but it seems that TV does not accept my my commands, or maybe im doing something wrong. Tried SM rs232 debug and uart with no luck.
The main reason Im doing this because somehow I lost my root and and all apps gone from smart hub. It seems that problem is with /mtd_rwcommon I think its read only or not exist or no permissions.
I will be grateful for the advice what should I do.

TV: UE32F6400
After apps gone I upgraded to latest firmware tried root but no success. After that I downgraded to 0000 and upgraded to 1119.0
P.S. factory reset and smart hub reset not working tried like 100 times.

Re: Top debug menu

Posted: Wed Sep 05, 2018 9:16 pm
by kasnepatinka
OK I have fixed my problems. And what I wrote in the first post was nonsense.
1. TDM working perfectly but it was useless for me.
2. There was no problems with permissions
3. Rooting E / F on latest firmware Do not know why it was not working few first times but after some time playing with files i managed to get root access .
4. I Connected to ftp and found an update.disable file in / mtd_rwcommon / catalog. I Deleted it and restarted the TV, Smart Hub was flawlessly updated.

And now it seems that everything is working like before.
I do not know how that file was created but maybe this info will be useful to someone.

P.S. Tomorrow I will check another tv with not working smart hub
P.S.S. little notice when usb disk with samygo is removed apps not working (strange)

Re: Top debug menu

Posted: Thu Sep 06, 2018 12:07 pm
by juusso
Great and thank you for sharing info. Try to boot TV without SamyGO USB and then check whether apps are working or not. Cold start.

Re: Top debug menu

Posted: Thu Sep 06, 2018 1:50 pm
by zoelechat
That "update.disable" thingy is known here for a long time, for causing issues rather than disabling updates we'd like to (e.g:, but no idea why/when TV would create it by itself (never heard :) )

Re: Top debug menu

Posted: Fri Sep 07, 2018 4:02 pm
by kasnepatinka
OK guys checked another tv with smart hub problem. On this tv there was no file update.disable so I did the same thing On both my tv's
Deleted leftovers:
and all files extracted from in directory /tmp/bin <-after deleting files from this directory root stops working immediately so delete them last.
Restarted TV and and smart hub started working perfectly even without usb disk.

Then I rooted tv just to check how everything works. I noticed when samygo is installed and usb disk is in tv smart hub working like charm. But when usb disk is not inserted apps in smart hub freezes wthen you start them. So if you do not want samygo anymore first delete it from TV. Otherwise smart hub will not work.

Also it would be nice if someone could create SamyGO delete widget or some kind of script which could find all samygo leftowers and delete them. Including bussybox, netcat, ftp, telnet and etc.

Re: Top debug menu

Posted: Fri Sep 07, 2018 4:05 pm
by kasnepatinka
And maybe admin could change topic name to something like Fixing Smart hub :)