[CHROOT] Debian Jessie armel image

Here are software that related with Samsung H series TVs.
Please don't create any new topic here unless you have software to post/release.

ZGod
Posts: 56
Joined: Sat Mar 21, 2015 7:46 pm

Re: [CHROOT] Debian Jessie armel image

Post by ZGod » Wed Mar 27, 2019 11:39 pm

Seems I spoke too soon... after installing ssh, it gave me an illegal instruction error. In a Debian Buster armel chroot ssh seems to work.

The problem with apt I could work around by adding -o Acquire::Check-Date=false to the command.

I am facing another problem now however. Some executables are not working, they give "Exec format error". When I try to run it with the linker, I get a segfault. Running file over them shows that those executables are "ELF 32-bit LSB executable" while the working ones are "ELF 32-bit LSB shared object" (that I always thought was only referring to library files with .so in them).

User avatar
mad_ady
SamyGO Project Donor
Posts: 264
Joined: Sun May 03, 2015 10:42 am

Re: [CHROOT] Debian Jessie armel image

Post by mad_ady » Thu Mar 28, 2019 9:00 am

Thanks for sharing.
You can manually set the time after you chroot with the date command (but it might cause stability issues). But you can tell apt to ignore the release timestamps: https://unix.stackexchange.com/question ... cal-mirror

Edit: oops, missed your last post.
Not sure why some binaries still fail. You can try to recompile them so that they won't contain illegal instructions. Might depend on the gcc version used and what the processor on the TV actually supports.
H6400, firmware 2602.2 downgraded to 2130

ZGod
Posts: 56
Joined: Sat Mar 21, 2015 7:46 pm

Re: [CHROOT] Debian Jessie armel image

Post by ZGod » Thu Mar 28, 2019 12:23 pm

I do not think that the gcc version should really matter. That should be taken care of by the chroot using its own set of libraries. I think there is just a special type of executable that doesn't work properly with the kernel. It seems that it has something to do with statically compiled executables, I think those are a problem, they consistently segfault. I also had this problem when I tried to run cdebootstrap directly on the TV. In the end I just connected the hard disk I'm using for this to another system and ran 'debootstrap' from there to get the initial chroot filesystem.

Maybe recompiling the few packages that have such executables so they produce regular non-static ones could help.

User avatar
mad_ady
SamyGO Project Donor
Posts: 264
Joined: Sun May 03, 2015 10:42 am

Re: [CHROOT] Debian Jessie armel image

Post by mad_ady » Thu Mar 28, 2019 12:46 pm

Yeah, I too ran debootstrap on a different arm system, TV is too crippled.
H6400, firmware 2602.2 downgraded to 2130

Post Reply

Return to “[H] Software”