Page 15 of 15

Re: [App] libAmbiLight E/F/H (MST-only)

Posted: Fri Oct 09, 2020 10:02 am
by aimaim
adonis wrote:
Thu Oct 08, 2020 7:12 pm
Yeah, would like to see what's going on. I mostly use the testimage from my first post for testing.., cast it to the TV (centered) and adjust the offset.
Sent you the test data via pm.

Re: [App] libAmbiLight E/F/H (MST-only)

Posted: Fri Oct 09, 2020 10:26 am
by adonis
aimaim wrote:
Fri Oct 09, 2020 10:02 am
adonis wrote:
Thu Oct 08, 2020 7:12 pm
Yeah, would like to see what's going on. I mostly use the testimage from my first post for testing.., cast it to the TV (centered) and adjust the offset.
Sent you the test data via pm.
Got iyour dm.. thanks!

This behaviour is strange since I can't reproduce it on my end, with 15 by 10 res.

I see you're using SLEEP=1. Sorry, I forgot to mention that I changed the behavior of that too, my bad. Could you please increase that to 5, since 1 would be the equivalent of 0.1 of previous config 😅
Maybe the huger amount of data that's sent to the ESP, confuses it due to the high frequency.

Re: [App] libAmbiLight E/F/H (MST-only)

Posted: Fri Oct 09, 2020 11:12 am
by aimaim
adonis wrote:
Fri Oct 09, 2020 10:26 am
This behaviour is strange since I can't reproduce it on my end, with 15 by 10 res.

I see you're using SLEEP=1. Sorry, I forgot to mention that I changed the behavior of that too, my bad. Could you please increase that to 5, since 1 would be the equivalent of 0.1 of previous config 😅
Maybe the huger amount of data that's sent to the ESP, confuses it due to the high frequency.
I changed SLEEP from 1 to 5, but that didn't solve the problem with the full-res-version. Went back to the doubling-version and SLEEP=5; which caused the tv to crash. So I'm back to SLEEP=1; now :)

Also I included ArduinoOTA in the app.ino to simplify future testing of the arduino sketch. Seems like a nice way to avoid always moving the esp8266 between tv and pc.

Re: [App] libAmbiLight E/F/H (MST-only)

Posted: Fri Oct 09, 2020 12:25 pm
by adonis
Hmmmm... that's really strange. How do you update the so-file. I encountered, that sometimes if I upload it while it runs, the TV crashes.

My workflow for testing is:

Rename *init file ti *init.dis to prevent autoloading
Restart TV

then:
- Upload *.so file
- cd /mnt/etc/init.d
- run ./99_100...init.dis to start service...
- repeat until everything's working as expected

Re: [App] libAmbiLight E/F/H (MST-only)

Posted: Fri Oct 09, 2020 12:33 pm
by aimaim
Image
adonis wrote:
Fri Oct 09, 2020 12:25 pm
Hmmmm... that's really strange. How do you update the so-file. I encountered, that sometimes if I upload it while it runs, the TV crashes.

My workflow for testing is:

Rename *init file ti *init.dis to prevent autoloading
Restart TV

then:
- Upload *.so file
- cd /mnt/etc/init.d
- run ./99_100...init.dis to start service...
- repeat until everything's working as expected
Tried it your way. But it made no difference. But since SLEEP=1 works, I'll just stick with it :)

Re: [App] libAmbiLight E/F/H (MST-only)

Posted: Sun Oct 11, 2020 11:24 am
by aimaim
I noticed some strange behavior of the new version:

Sometimes parts of the ambilight flicker despite the picture being frozen/ paused. I sent you two videos to demonstrate the behavior.

Take care
aimaim

Re: [App] libAmbiLight E/F/H (MST-only)

Posted: Sun Oct 11, 2020 12:34 pm
by notengo13
@aimaim could you share please your app.ino with ARDUINOOTA I'm too lazy to search for it and how to do it.
For me also I have some issues with new version. My setup is
H Leds 60
V Leds 32
I want to flash nodemcu with new sketch and see what improves. With version3 I can't t get it work correctly.

Re: [App] libAmbiLight E/F/H (MST-only)

Posted: Sun Oct 11, 2020 12:58 pm
by aimaim
notengo13 wrote:
Sun Oct 11, 2020 12:34 pm
@aimaim could you share please your app.ino with ARDUINOOTA I'm too lazy to search for it and how to do it.
For me also I have some issues with new version. My setup is
H Leds 60
V Leds 32
I want to flash nodemcu with new sketch and see what improves. With version3 I can't t get it work correctly.
There you go. I threw it together kind of carelessly. So it might not be tidy, but it works.

Re: [App] libAmbiLight E/F/H (MST-only)

Posted: Mon Oct 12, 2020 11:23 am
by notengo13
aimaim wrote:
Sun Oct 11, 2020 12:58 pm
notengo13 wrote:
Sun Oct 11, 2020 12:34 pm
@aimaim could you share please your app.ino with ARDUINOOTA I'm too lazy to search for it and how to do it.
For me also I have some issues with new version. My setup is
H Leds 60
V Leds 32
I want to flash nodemcu with new sketch and see what improves. With version3 I can't t get it work correctly.
There you go. I threw it together kind of carelessly. So it might not be tidy, but it works.
Thank you. I Will try it this days

Re: [App] libAmbiLight E/F/H (MST-only)

Posted: Sun Oct 18, 2020 10:32 pm
by schybiorz
So i got it somehow to work. Ue75h6470.

48 led top and left right 24.
I plan not to use the bottom led`s. Can i cut them or is there a way to optimize the lib to leave it away.

Have a nodemcu and ws2812b led`s

One strange behavior is the color green is blue and blue is green.
Also after first manuel injection led change like the picture.

But after another attempt my esp8266 turn off led and I need to restart TV. TV is responding but no led light. Would be cool if someone can help me.