[Ended][ROOT] H "Skype" root (FW<=Dec.2014, all T-GFS)

Here are software that related with Samsung H series TVs.
Please don't create any new topic here unless you have software to post/release.
Locked

lbalan79
SamyGO Project Donor
Posts: 133
Joined: Mon Jan 12, 2015 5:24 am

Re: [!!!] Rooting H series (updated 27/01/2015)

Post by lbalan79 »

http://h30499.www3.hp.com/t5/HP-Securit ... Ng07i7Alj0

Still trying to modify this to find out if there is any better way to do this.

PS: I wish the guy didn't disclose this so my tv would still work. This is interesting: http://www.openwall.com/lists/oss-secur ... 4/06/26/23

Do we know for sure a recording device is needed?



Thank you

phonk
SamyGO Project Donor
Posts: 36
Joined: Mon Feb 02, 2015 10:43 am

Re: [!!!] Rooting H series (updated 27/01/2015)

Post by phonk »

Hello,

I'm on 2134 with my 6470 model. Is there a chance to get this rooted ?

Should I try it with the your method in Post #1 ? Or will I brick my TV ?

Greets

User avatar
ryn0909
SamyGO Project Donor
Posts: 82
Joined: Thu Jan 01, 2015 9:22 am
Location: california, USA

Re: [!!!] Rooting H series (updated 27/01/2015)

Post by ryn0909 »

so i went and purchased an ex-link cable from FTDI, TTL-232R-3V3-AJ. i downloaded and installed their drives. running putty set for serial connection at 115,200 8 N 1 None. and tv rs232 port is set on Debug. when i power the tv on, i get all sorts of input coming in but its all garbbled gibberish. as a reminder i have the UN46h6201afxza. am i doing something wrong or is this what im suppossed to get?? attached is a screenshot of the session.

also i am awaiting the arrival of the service manual for this tv. idk if it will help anyone but ill provide it upon request, once it arrives ill let everyone know.
You do not have the required permissions to view the files attached to this post.
UN46H6201AF-XZA
T-NT14MAKUC-1112.1

JokinAU
SamyGO Project Donor
Posts: 6
Joined: Tue Jan 06, 2015 12:28 pm

Re: [!!!] Rooting H series (updated 27/01/2015)

Post by JokinAU »

Just a shot in the dark (no computer handy ATM, just brainstorming): Are those parameters correct? Specifically the port speed...

User avatar
ryn0909
SamyGO Project Donor
Posts: 82
Joined: Thu Jan 01, 2015 9:22 am
Location: california, USA

Re: [!!!] Rooting H series (updated 27/01/2015)

Post by ryn0909 »

ya know, im not really sure what the port speed should be set at.... but i do know that its reading from the ex-link port. if i shut the tv off, the data on the screen stops. when i turn tv back on, the data starts flowing fast.
UN46H6201AF-XZA
T-NT14MAKUC-1112.1

JokinAU
SamyGO Project Donor
Posts: 6
Joined: Tue Jan 06, 2015 12:28 pm

Re: [!!!] Rooting H series (updated 27/01/2015)

Post by JokinAU »

Some posts like http://forums.cnet.com/7723-13973_102-3 ... a-ex-link/ state that they used 9600bps. You won't blow anything, so try to use different combinations, mainly slower speeds...

Anyway, some TV have different RS232 debug modes:
Debug mode [Debug smart][Debug runtime]

Try to mess with it also.

I can't access my ue48h8000 in any way, so I am also planning to give ex-link a try

rafaelscheel
SamyGO Project Donor
Posts: 18
Joined: Wed Feb 11, 2015 12:45 pm

Re: [!!!] Rooting H series (updated 27/01/2015)

Post by rafaelscheel »

Wow Impressed!! Worked perfectly fine!!!
Turned watchdog off, so it does not reboot automatically.

Would gladely donate directly to the author of this. Pls pn me your account infos.

Oh forgot to mention:
-> UE32H4580, T-MST14DEUC-2120.0

Time needed < 15min GJ !! Plugged the power 4 times off after crash till it stopped crashing and worked.

-Rafael

User avatar
ryn0909
SamyGO Project Donor
Posts: 82
Joined: Thu Jan 01, 2015 9:22 am
Location: california, USA

Re: [!!!] Rooting H series (updated 27/01/2015)

Post by ryn0909 »

JokinAU wrote:Some posts like http://forums.cnet.com/7723-13973_102-3 ... a-ex-link/ state that they used 9600bps. You won't blow anything, so try to use different combinations, mainly slower speeds...

Anyway, some TV have different RS232 debug modes:
Debug mode [Debug smart][Debug runtime]

Try to mess with it also.

I can't access my ue48h8000 in any way, so I am also planning to give ex-link a try

the options i have for the rs232 function are: DEBUG, UART, LOGIC, FANET
i have it set on debug rite now. ill try the 9600 baud and post my results.
UN46H6201AF-XZA
T-NT14MAKUC-1112.1

User avatar
ryn0909
SamyGO Project Donor
Posts: 82
Joined: Thu Jan 01, 2015 9:22 am
Location: california, USA

Re: [!!!] Rooting H series (updated 27/01/2015)

Post by ryn0909 »

tried it on 9600 baud and still same garbled output just slower..... does it matter which source input its on? i dont see why it would but i could be wrong.
UN46H6201AF-XZA
T-NT14MAKUC-1112.1

Scow1018
SamyGO Project Donor
Posts: 2
Joined: Mon Feb 09, 2015 10:36 pm

Re: [!!!] Rooting H series (updated 27/01/2015)

Post by Scow1018 »

It Work`s
With PVR Recorder i get all the Record`s from my Harddrive on TV, but i?m not able to decode. ( I`ll ask in another Tread)
I dried to open the TV wit SSH, i think there is a connection, but with"root" and "SamyGo" there is no access.
tatus: Connecting to 192.168.90.21...
Response: fzSftp started
Command: open "root@192.168.90.21" 22
Command: Pass: ******
Error: Authentication failed.
Error: Critical error
Error: Could not connect to server

TV: UE40H6600
Firmware: T-GFSDEUC-1200.2,BT-S/G

But anyway
Thanks for your Guide

Locked

Return to “[H] Software”