H6640 exlink port

This forum is for information related with H series hardware instead of firmware/software.

rexio8
SamyGO Project Donor
Posts: 11
Joined: Fri Jun 21, 2013 10:52 am

Re: H6640 exlink port

Post by rexio8 » Sat Apr 14, 2018 8:09 pm

sectroyer wrote:
Fri Apr 06, 2018 3:55 pm
Nice find but you made one mistake. RS232 mode needs to be set to Debug :) Setting UART to ON is enough to enable FULL exlink on headphone jack :) You will see HUGE difference in a size of output :D When set to UART exlink (on ANY port) gives you ONLY basic message. Anyway once again good find.
I'm aware of the difference between Debug and Uart. Maybe I wasn't to precise when writing my post.
But anyway I've found out that some commands give you also current TV status. For example the 08,22,f0,01,00,00,E5 gives you the current volume level. If anybody's interested I can share more commands and findings.

sectroyer
Official SamyGO Developer
Posts: 5731
Joined: Wed May 04, 2011 5:10 pm

Re: H6640 exlink port

Post by sectroyer » Tue May 15, 2018 6:13 pm

You can post people will check if they find something interesting :)
I do NOT support "latest fw" at ALL. If you have one you should block updates on router and wait for it to STOP being "latest":)
If you want me to help you please paste FULL log(s) to "spoiler"/"code" bbcodes or provide link(s) to pasted file(s) on http://ctrlv.it/ Otherwise "NO HELP"!!!
If you want root DISABLE internet access to your device!!!!
DO NOT EVER INSTALL FIRMWARE UPGRADE !!!!

User avatar
juusso
SamyGO Moderator
Posts: 9977
Joined: Sun Mar 07, 2010 6:20 pm

Re: H6640 exlink port

Post by juusso » Tue May 15, 2018 9:32 pm

Yes, off course, sounds very prommising, please...
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. Imagerooting K seriesImage, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

thor
SamyGO Project Donor
Posts: 8
Joined: Fri Mar 03, 2017 12:03 am

Re: H6640 exlink port

Post by thor » Wed May 23, 2018 4:15 am

rexio8 wrote:
Fri Mar 09, 2018 3:23 pm
...exlink works on my h6640 tv through the audio out (headphones) jack. All you need to do is enable uart and change the rs232 mode to uart in the service menu. Now I can control my tv through rs232.
Thanks for your awesome work guys!
Hello rexio8, thanks for sharing this information. I'm a little bit confused regarding "enable uart", as this is mentioned only 1 other time in this forum, and it's also not in the wiki:
Service Menu -> Options -> Sub Options : Set: Enable UART - ON

Is this the option which you changed?
What happens with the audio signal from the headphones port? Do you still hear audio when you connect normal earphones?
Martin UE48H6270: Firmware T-MST14DEUC-2850.3-1009 Vers. 2860 -> 0000 -> 2781 (last rootable), H "Network" (Wifi) root, LAN-switch, NoDRM

obrienjames
Posts: 1
Joined: Fri May 25, 2018 11:57 am

Re: H6640 exlink port

Post by obrienjames » Fri May 25, 2018 12:04 pm

Hi

Joing this thread a little late.

I have made an 3.5mm ExLink cable, and using a RS232 serial-usb adapter (FTDI chip).

I am able to see the debug output when RS232 mode set to debug and I connect using the 115200 baud rate.

I am having difficultly sending any commands, I’m using Minicom to connect.

Can someone just explain so I need to use Rs232: UART or Debug. And if I use UART is it 115200 or 9600 baud rate.

Finally when sending commands do I need to send the console unlock code. When using Minicom and the console unlock code on the wiki I don’t get any response.

Any help would be greatly appreciated

Thanks

James

rexio8
SamyGO Project Donor
Posts: 11
Joined: Fri Jun 21, 2013 10:52 am

Re: H6640 exlink port

Post by rexio8 » Mon May 28, 2018 9:41 pm

juusso wrote:
Tue May 15, 2018 9:32 pm
Yes, off course, sounds very prommising, please...
So here is what I found out, about the status commands:
Volume status: 08 22 f0 01 00 00 E5
Mute status: 08 22 f0 02 00 00 E4
Channel number: 08 22 f0 03 00 00 E3
Selected source: 08 22 f0 04 00 00 E2
Picture size: 08 22 f0 05 00 00 E1
3D mode: 08 22 f0 06 00 00 E0
Picture mode: 08 22 f0 07 00 00 DF
Sound mode: 08 22 f0 08 00 00 DE

Sample output for the volume status commands is like so (when the command was issued 3 times):

Code: Select all

0000000 0c03 03f1 f50c f008 0001 f100 0015 fd00
0000010 0c03 03f1 f50c f008 0001 f100 0014 fe00
0000020 0c03 03f1 f50c f008 0001 f100 0013 ff00
The first value (0000000,0000010,0000020) is added by hexdump (line number) so ignore it. You should be interested in the second to last data in the sequence (0015, 0014, 0013). These are your current volume levels. In this examples I have changed my tv volume from 15 to 14 and finally to 13.
The same applies to other commands. Some give you boolean values (like the mute status command in which you get 0000 or 00001) and other give integer values (like the channel number).

rexio8
SamyGO Project Donor
Posts: 11
Joined: Fri Jun 21, 2013 10:52 am

Re: H6640 exlink port

Post by rexio8 » Mon May 28, 2018 9:55 pm

thor wrote:
Wed May 23, 2018 4:15 am

Hello rexio8, thanks for sharing this information. I'm a little bit confused regarding "enable uart", as this is mentioned only 1 other time in this forum, and it's also not in the wiki:
Service Menu -> Options -> Sub Options : Set: Enable UART - ON

Is this the option which you changed?
What happens with the audio signal from the headphones port? Do you still hear audio when you connect normal earphones?
In my case I've enabled:
Service Menu -> Control -> SubOption -> UART Enable to ON and Service Menu -> Control -> SubOption -> RS-232 Jack to UART
Remember to set the port settings to 9600 8N1. Then you can use it like:

Code: Select all

echo -en "\x08\x22\xf0\x03\x00\x00\xE3" > /dev/ttyUSB0
and in a second terminal

Code: Select all

hexdump < /dev/ttyUSB0
I don't use headphones, but I've checked and it appears that you cannot use them as nothing can be heard.

Post Reply

Return to “[H] Hardware”