H6640 exlink port

This forum is for information related with H series hardware instead of firmware/software.

rexio8
SamyGO Project Donor
Posts: 11
Joined: Fri Jun 21, 2013 10:52 am

H6640 exlink port

Post by rexio8 » Wed Jan 27, 2016 1:36 am

I would like to read debug data from my Samsung's H6640 exlink port. Is there a way to access it without opening the TV? Does anybody know where is it located?

sectroyer
Official SamyGO Developer
Posts: 5732
Joined: Wed May 04, 2011 5:10 pm

Re: H6640 exlink port

Post by sectroyer » Wed Jan 27, 2016 5:53 am

rexio8 wrote:I would like to read debug data from my Samsung's H6640 exlink port. Is there a way to access it without opening the TV? Does anybody know where is it located?
Root TV :)
I do NOT support "latest fw" at ALL. If you have one you should block updates on router and wait for it to STOP being "latest":)
If you want me to help you please paste FULL log(s) to "spoiler"/"code" bbcodes or provide link(s) to pasted file(s) on http://ctrlv.it/ Otherwise "NO HELP"!!!
If you want root DISABLE internet access to your device!!!!
DO NOT EVER INSTALL FIRMWARE UPGRADE !!!!

rexio8
SamyGO Project Donor
Posts: 11
Joined: Fri Jun 21, 2013 10:52 am

Re: H6640 exlink port

Post by rexio8 » Wed Jan 27, 2016 12:10 pm

I have rooted already (and many thanks for your hard work in this field ;). But I need a rs232 interface for a home automation project.

sectroyer
Official SamyGO Developer
Posts: 5732
Joined: Wed May 04, 2011 5:10 pm

Re: H6640 exlink port

Post by sectroyer » Wed Jan 27, 2016 1:48 pm

rexio8 wrote:I have rooted already (and many thanks for your hard work in this field ;). But I need a rs232 interface for a home automation project.
Then you need do soldier or patch (in UNKNOWN way) kernel... Unless you want to ONLY read ? :)
BTW why NOT use usb to rs232 adapter?
I do NOT support "latest fw" at ALL. If you have one you should block updates on router and wait for it to STOP being "latest":)
If you want me to help you please paste FULL log(s) to "spoiler"/"code" bbcodes or provide link(s) to pasted file(s) on http://ctrlv.it/ Otherwise "NO HELP"!!!
If you want root DISABLE internet access to your device!!!!
DO NOT EVER INSTALL FIRMWARE UPGRADE !!!!

rexio8
SamyGO Project Donor
Posts: 11
Joined: Fri Jun 21, 2013 10:52 am

Re: H6640 exlink port

Post by rexio8 » Wed Jan 27, 2016 5:18 pm

I was hoping that exlink is easy accessible. But the idea with USB to rs232 is working great - thanks.
One more concern: after the dmesg command I can see several error messages like:

#########################################
[ERROR][CAP:NoSKIP][CAP(19)][TH(pidof:2244)PTH(sh)][U(1010)G(1010)]
###########################################
#########################################
[ERROR][CAP:NoSKIP][CAP(19)][TH(pidof:2244)PTH(sh)][U(1010)G(1010)]
###########################################

is this normal or I have something wrong with my config (I haven't observed any issues with the TV yet)?

zoelechat
Official SamyGO Developer
Posts: 8251
Joined: Fri Apr 12, 2013 7:32 pm
Location: France

Re: H6640 exlink port

Post by zoelechat » Wed Jan 27, 2016 5:41 pm

It's "normal". From Samsung's point of view maybe :)
I do NOT receive any PM. Please use forum.

rexio8
SamyGO Project Donor
Posts: 11
Joined: Fri Jun 21, 2013 10:52 am

Re: H6640 exlink port

Post by rexio8 » Fri Mar 09, 2018 3:23 pm

sectroyer wrote:
Wed Jan 27, 2016 1:48 pm
rexio8 wrote:I have rooted already (and many thanks for your hard work in this field ;). But I need a rs232 interface for a home automation project.
Then you need do soldier or patch (in UNKNOWN way) kernel... Unless you want to ONLY read ? :)
BTW why NOT use usb to rs232 adapter?
Sorry to bump an old thread, but I have found out, that exlink works on my h6640 tv through the audio out (headphones) jack. All you need to do is enable uart and change the rs232 mode to uart in the service menu. Now I can control my tv through rs232.
Thanks for your awesome work guys!

fraglord
SamyGO Project Donor
Posts: 68
Joined: Mon Jan 05, 2015 2:30 pm

Re: H6640 exlink port

Post by fraglord » Fri Mar 16, 2018 1:46 pm

rexio8 wrote:
Fri Mar 09, 2018 3:23 pm
Sorry to bump an old thread, but I have found out, that exlink works on my h6640 tv through the audio out (headphones) jack. All you need to do is enable uart and change the rs232 mode to uart in the service menu. Now I can control my tv through rs232.
Thanks for your awesome work guys!
Interesting. You mind to share details like: what adapter you are using (really RS232 or TTL?), Pinout of the 3.5mm connector, setting for the serial console etc.
*** UE40H6470 *** F/W: T-MST14DEUC-2130.0 *** OTA & OTN disabled ***

rexio8
SamyGO Project Donor
Posts: 11
Joined: Fri Jun 21, 2013 10:52 am

Re: H6640 exlink port

Post by rexio8 » Sat Mar 17, 2018 7:56 am

fraglord wrote:
Fri Mar 16, 2018 1:46 pm
Interesting. You mind to share details like: what adapter you are using (really RS232 or TTL?), Pinout of the 3.5mm connector, setting for the serial console etc.
I'm using a Nokia DKU-5 cable, prepared according to the wiki (https://wiki.samygo.tv/index.php?title= ... BD_players), so 3.3v TTL here. The 3.5mm audio jack is also connected according to the wiki - well at least I think so, because initially I wasn't getting anything on the serial console, so I switched the rx and tx pins, but I could have interpreted the wiki wrong initially. As for the serial console settings it's also like on the wiki:
Speed 9600
Data bits 8
Stop bits 1
Parity None
Flow control None

I have also found evidence on the net, that exlink works for the H6400 through the audio jack.

sectroyer
Official SamyGO Developer
Posts: 5732
Joined: Wed May 04, 2011 5:10 pm

Re: H6640 exlink port

Post by sectroyer » Fri Apr 06, 2018 3:55 pm

rexio8 wrote:
Fri Mar 09, 2018 3:23 pm
Sorry to bump an old thread, but I have found out, that exlink works on my h6640 tv through the audio out (headphones) jack. All you need to do is enable uart and change the rs232 mode to uart in the service menu. Now I can control my tv through rs232.
Thanks for your awesome work guys!
Nice find but you made one mistake. RS232 mode needs to be set to Debug :) Setting UART to ON is enough to enable FULL exlink on headphone jack :) You will see HUGE difference in a size of output :D When set to UART exlink (on ANY port) gives you ONLY basic message. Anyway once again good find.
I do NOT support "latest fw" at ALL. If you have one you should block updates on router and wait for it to STOP being "latest":)
If you want me to help you please paste FULL log(s) to "spoiler"/"code" bbcodes or provide link(s) to pasted file(s) on http://ctrlv.it/ Otherwise "NO HELP"!!!
If you want root DISABLE internet access to your device!!!!
DO NOT EVER INSTALL FIRMWARE UPGRADE !!!!

Post Reply

Return to “[H] Hardware”