Page 1 of 1

Unbrick LE37A552P3R after failed firmware update

Posted: Wed Apr 04, 2018 12:27 am
by nivela
Hello, I picked up a Samsung LE37A552P3R (XXC) today, which supposedly broke when the person was trying to do a Firmware update over USB.

If I plug in the TV to power the power LED blinks ~3 times, then it is dark. If I press power on the remote the LED turns on after a few seconds. When I press power again the LED blinks again and then turns off again. The screen/backlight never turns on!

I have tried the following things:

Download official firmware: MT8226/T-PRLPEUMD-1022.0.bin, put it on a fat32 formatted USB stick and tried to start the TV with Pressing Source on the TV and Power on the remote at the same time.

Made a Ex-Link cable and connected it to my USB serial device, I see some communication when starting the TV, but nothing really informative or helpful.

What test or steps do you recommend I take?

I have a cheap mini EEPROM flasher, could I de-solder the chip and flash it directly?

Thanks for the help!

Re: Unbrick LE37A552P3R after failed firmware update

Posted: Sat Apr 28, 2018 3:28 pm
by nivela
Nobody that could give me any information regarding this? I really don't want to invest time if it would be waisted, the TV is not worth it. Thank you.