rs232 control of LExxA956 [FiXED]

Information, quest?ons and any other thing that related with A series.
Post Reply

mholgate
Posts: 4
Joined: Wed Jun 06, 2012 8:15 pm

rs232 control of LExxA956 [FiXED]

Post by mholgate » Thu Jun 07, 2012 3:26 pm

TV model: LE46A956 (in full: LE46A956D1MXXU)
official firmware: T-RBYDEUC-1013.1


My goal is to get this TV to respond to RS232 commands, such as VolumeUp, PowerOff, etc. using the codes documented on the wiki ( http://wiki.samygo.tv/index.php?title=E ... s%28SH4%29 ) but my problem is that the TV doesn't want to respond to any command I give it. I've also tried the codes documented on avsforum (thread title: "samsung rs232 port specifications").

I can read the output of what's going on, on boot-up or when I increase volume for instance, but it just won't respond to any of my input commands.

I know the cable's good and my setup is ok, because I can control the TV in u-boot only. That's the weird thing.

I think the main problem is that my Service Menu (in Advanced mode) seems to be different from most published on the net. For instance, "RS-232" or "Debug" doesn't exist anywhere in the menu options.

All I've done to get into u-boot successfully was to switch Advanced > Adjust > UART Select from "W-mount" to "STi"

Also, I cannot enter TDM view u-boot on this TV using anything mentioned in the SamyGO A-series wiki.

Please help
Last edited by mholgate on Fri Jun 08, 2012 4:09 pm, edited 1 time in total.

tom_van
Official SamyGO Developer
Posts: 146
Joined: Tue Jan 19, 2010 10:44 am

Re: rs232 control of LExxA956 - Wiki commands don't work

Post by tom_van » Fri Jun 08, 2012 6:30 am

It DOES respond. You should start debug mode first. You might missed adding yongsik to kernel boot parameters - see http://wiki.samygo.tv/index.php5/Gettin ... _%28SH4%29. Without it serial input is crippled at 115kBaud.

You also may be interested in remote control over ethernet, see https://forum.samygo.tv/viewtopic.php?f=8&t=2021

mholgate
Posts: 4
Joined: Wed Jun 06, 2012 8:15 pm

it's working!

Post by mholgate » Fri Jun 08, 2012 11:14 am

wow - thanks so much! It is working after all :D
The problem was that I was using command mentioned in the wiki to directly load kernel:

Code: Select all

bbm load kernel; bbm close; setenv bootargs console=ttyAS0,115200 mem=$memsize root=/dev/tfsr6 rw rootfstype=squashfs bigphysarea=2000 quiet yongsik; bootm 0x84100000
but what got it working for me was that I needed to Save the change instead by following the next command mentioned in the wiki instead:

Code: Select all

setenv bootargs console=ttyAS0,115200 mem=$memsize root=/dev/tfsr6 rootfstype=squashfs bigphysarea=2000 quiet yongsik
setenv bootcmd "bbm load kernel;bbm close;bootm 0x84100000"
saveenv
and now I can successfully control it using the 1-char commands mentioned in the wiki ( http://wiki.samygo.tv/index.php?title=E ... te_control ).

Now I'm having trouble figuring out how to find the command for "Power OFF" (or "Power Toggle").
The RC command code (hex) for these are:
Power Toggle = 0x98
HDMI2 = 0xBE

How do I decipher this to find the chars I should sent via Ex-link? I tried all the keys on my keyboard, but these ones must be a little more complex.
Or if not, perhaps there's another way to do this programmatically via the command-line or busybox?

tom_van
Official SamyGO Developer
Posts: 146
Joined: Tue Jan 19, 2010 10:44 am

Re: it's working!

Post by tom_van » Fri Jun 08, 2012 2:08 pm

mholgate wrote:The problem was that I was using command mentioned in the wiki to directly load kernel:

Code: Select all

bbm load kernel; bbm close; setenv bootargs console=ttyAS0,115200 mem=$memsize root=/dev/tfsr6 rw rootfstype=squashfs bigphysarea=2000 quiet yongsik; bootm 0x84100000
Command is ok, but were you quick enough to enter the command before autoboot fired up?

Seems you have a htpc and want to automate some tasks, don't you? Bad luck, Ex-link commands looks like what developers programmed for testing a tv firmware on some prototype board without remote control. Not full set of commands for real use. I looked for the commands in firmware disassembly, so chance that you'll find something new is quite low. If my gues is right, you'd better load a remote control module to tv and send commands from htpc over net.
Or use HDMI-CEC over HDMI cable.

mholgate
Posts: 4
Joined: Wed Jun 06, 2012 8:15 pm

Re: rs232 control of LExxA956 - Wiki commands don't work

Post by mholgate » Fri Jun 08, 2012 3:19 pm

ok - thanks for the heads-up.
If my gues is right, you'd better load a remote control module to tv and send commands from htpc over net.
Or use HDMI-CEC over HDMI cable.
Yes, that's my aim. I don't have any experience with the above, but I do use girder on the htpc. My TV is connected to my computer via HDMI, so perhaps HDMI-CEC is the next thing I should investigate...

mholgate
Posts: 4
Joined: Wed Jun 06, 2012 8:15 pm

Re: it's working!

Post by mholgate » Fri Jun 08, 2012 4:21 pm

tom_van wrote: If my gues is right, you'd better load a remote control module to tv and send commands from htpc over net.
Or use HDMI-CEC over HDMI cable.
One more thing, could you please elaborate on what you mean by "load a remote control module to tv" ?
1) I've seen telnet/ssh mentioned in the wiki, which is best for this purpose?
2) Also, will this method allow me to turn the TV on when it's off?
3) Will I need to install SamyGO firmware + SamyGO extensions in order to achieve this?

tom_van
Official SamyGO Developer
Posts: 146
Joined: Tue Jan 19, 2010 10:44 am

Re: rs232 control of LExxA956 [FiXED]

Post by tom_van » Fri Jun 08, 2012 4:57 pm

1) telnet is ok on a safe network - e.g. on a home net behind firewall
2) no. Only IR can switch tv on.
3) You need patched firmware with libGame.so launcher restrored.
Network remote control can be loaded manually as a "game" or automatically on tv startup.

Post Reply

Return to “A Series”