LE46A956 - problems with H264 decoder??

Information, quest?ons and any other thing that related with A series.
Post Reply

tom_van
Official SamyGO Developer
Posts: 145
Joined: Tue Jan 19, 2010 10:44 am

LE46A956 - problems with H264 decoder??

Post by tom_van » Thu Feb 07, 2013 10:26 am

Hi all,

My LE46A956 have problems with decoding one HD program (czech CT1 HD) from DVB-T broadcasting. It started couple of months ago - probably after some changes on broadcaster's equipment. The problem appears only when a native full HD material is broadcasted. Video starts twitching - instead of smooth play you see stall and skip several times per second. Video gradually getting later and later after audio. Twitching does not stop until another program is zapped. When switched back to the HD channel, twitching often starts again.

There are other HD channels which plays without a problem. SD channels are ok too.

Have you experienced similar problems?

tom_van
Official SamyGO Developer
Posts: 145
Joined: Tue Jan 19, 2010 10:44 am

Re: LE46A956 - problems with H264 decoder??

Post by tom_van » Mon Feb 11, 2013 7:52 pm

Following kernel messages from stapi module show in dmesg output during the problem:

Code: Select all

[  815.537000] Skip: STC:0x6f8acaa1    PTS:0x6f8ab16d NumberToDO=4
[  815.613000] Skip: STC:0x6f8ae695    PTS:0x6f8abf7d NumberToDO=6
[  815.690000] Skip: STC:0x6f8b02a2    PTS:0x6f8ae9ad NumberToDO=4
[  815.767000] Skip: STC:0x6f8b1ed9    PTS:0x6f8af7bd NumberToDO=6
[  815.844000] Skip: STC:0x6f8b3ad5    PTS:0x6f8b05cd NumberToDO=8
[  815.921000] Skip: STC:0x6f8b5708    PTS:0x6f8b13dd NumberToDO=10
[  815.998000] Skip: STC:0x6f8b7334    PTS:0x6f8b2ffd NumberToDO=10
[  816.075000] Skip: STC:0x6f8b8f66    PTS:0x6f8b3e0d NumberToDO=10
[  816.192000] Skip: STC:0x6f8bb9a2    PTS:0x6f8b683d NumberToDO=10
[  816.269000] Skip: STC:0x6f8bd5a0    PTS:0x6f8b845d NumberToDO=10
[  816.346000] Skip: STC:0x6f8bf1c0    PTS:0x6f8ba07d NumberToDO=10
[  816.422000] Skip: STC:0x6f8c0e05    PTS:0x6f8bae8d NumberToDO=10
...

Code: Select all

[  998.741000] Skip: STC:0x7091bfcc    PTS:0x708d3393 NumberToDO=10
[  998.818000] Skip: STC:0x7091dbdf    PTS:0x708d4fb3 NumberToDO=10
[  998.895000] Skip: STC:0x7091f832    PTS:0x708d5dc3 NumberToDO=10
Notice that STC - PTC difference grows from 6452 (< 0.1 sec) to 301679 (more than 3 sec)
It seems like the synchronization algorithm does not work for this HD channel.

marcjero
Posts: 50
Joined: Sun Mar 06, 2011 8:40 pm

Re: LE46A956 - problems with H264 decoder??

Post by marcjero » Thu Feb 21, 2013 4:31 pm

No I didn't get that. But I found before that remuxing some h264 mkvs sometimes lead to audio/video sync issues...

d3m0n1q733rz
Posts: 2
Joined: Tue Mar 26, 2013 6:19 am

Re: LE46A956 - problems with H264 decoder??

Post by d3m0n1q733rz » Tue Mar 26, 2013 6:31 am

It's probably an audio/video interleave change via the station that's non-standard. It could be using a different bitrate than usual or including information that the TV doesn't recognize in the audio such as a second audio stream. I would say a change needs to be made in how the codec handles these streams.

khushfehmi045
Posts: 1
Joined: Sat Dec 06, 2014 4:47 am

Re: LE46A956 - problems with H264 decoder??

Post by khushfehmi045 » Sat Dec 06, 2014 5:25 am

The problem appears only when a native full HD material is broadcasted. Video starts twitching - instead of smooth play you see stall and skip several times per second. Video gradually getting later and later after audio. Twitching does not stop until another program is zapped. When switched back to the HD channel, twitching often starts again.??
Join online Braindumps dumps and C4120-783 braindumps to pass pmp dumps exam in first PW0-204 braindumps Our best ]

edrik
Posts: 2
Joined: Sun Jan 24, 2016 9:49 pm

Re: LE46A956 - problems with H264 decoder??

Post by edrik » Mon Jan 25, 2016 10:02 pm

was a fix found for this?

tom_van
Official SamyGO Developer
Posts: 145
Joined: Tue Jan 19, 2010 10:44 am

Re: LE46A956 - problems with H264 decoder??

Post by tom_van » Sat Feb 06, 2016 9:57 am

Not an easy one. The problem is that Samsung firmware is based on an old version of coprocessor backend.

The only solution is to use alternative firmware.
Unfortunately it is far from finished state.

Post Reply

Return to “A Series”

Who is online

Users browsing this forum: No registered users and 1 guest