UE40C6700 Blinking LED after mainboard replacement

Support for C series TVs that all user could ask. Please do not ask a questions at other forums.
Post Reply

thin
Posts: 2
Joined: Fri May 26, 2017 10:18 pm

UE40C6700 Blinking LED after mainboard replacement

Post by thin » Fri May 26, 2017 10:45 pm

Hello all,

Shortly after the warranty time the screen of my 40-inch UE40C6700 had the funky rainbow stripes, so i reflowed the mainboard with the heatgun method, which lasted 2 months, and then i destroyed the MB by trying a second reflow in the oven. The soldering points melted, yes, but the board now is bent, most capacitors went up like popcorn and most things got reflowed all over the place. That one is destroyed.

After quite a bit of search i have found another (used) mainboard of a 46-incher, a blue one, which has the same product number BN41-01444B,
but after replacing it there's a black screen and the flashing standby light (and ticking relay) of uselessness.

Tried fixes:
- exchanged the power board with the one that came with the mainboard
- hooked up a USB with firmware
- tried an eeprom reset (the method from the wiki, for the C6200)

... but it keeps on ticking.

My suspicion is that the mainboard assumes the wrong panel, but i am fairly new to the topic.

Any idea how i can fix this with a black screen?

Thanks and regards, T

//

Edit: Could it be that the Eeprom reset did not work?

thin
Posts: 2
Joined: Fri May 26, 2017 10:18 pm

Re: UE40C6700 Blinking LED after mainboard replacement

Post by thin » Sat Jun 24, 2017 8:49 pm

The hardware's working now as it seems, ticking is gone, TV fires up (i see backlight on black screen), but no image and sound yet.

Any idea how to set the tv to the right values?

is a blind firmware update possible with the 'right' firmware?
eeprom reset?
access via the ex-link port (no idea if debug is enabled)?

Post Reply

Return to “[C] Support”