Page 1 of 2

PVR on US K series

Posted: Mon Dec 21, 2020 3:56 am
by stoneattic
I'm been doing a lot of reading on what people have done to turn PVR on on K Series TVs and have tried a bunch myself with the following results, all using the Service Menu:

1. I changed the Extended PVR to ON. This worked until the TV was turned off and back on, which reset the Extended PVR back to OFF.

2. I changed the Local Set form USA to NONE, SD_MEXICO, and CARRIBE. In all of these cases the PVR worked but Bluetooth was disabled, which meant my Smart Remote would only turn the TV on and off with no other functions and my soundbar wouldn't pair. I tried setting BT Support to ON but it didn't seem to work and restarting the TV set it back to OFF. I set BT_AUDIO_ON_OFF to ON, but it didn't make a difference.

3. I changed the Region from USA to KOR (they where the only options). The Bluetooth worked, but I lost all antenna channels and scanning didn't show any. I thought maybe TUNER was the difference but in the USA and KOR setting the TUNER was the same S_T2C. Setting back to USA allowed me to rescan and get my antenna channels back.

Has anyone in the USA, or probably Canada would have the same issue, been able to get the PVR to work?
Any other suggestions that maybe I didn't try?

Thanks!

Re: PVR on US K series

Posted: Mon Dec 21, 2020 1:39 pm
by notengo13
Maybe you need to change also BOM model and SW model to get it work.
check here
Screenshot_20201022_221719_cn.wps.moffice_i18n.jpg

Re: PVR on US K series

Posted: Mon Dec 21, 2020 3:08 pm
by stoneattic
notengo13 wrote:
Mon Dec 21, 2020 1:39 pm
Maybe you need to change also BOM model and SW model to get it work.
check here
Screenshot_20201022_221719_cn.wps.moffice_i18n.jpg
Thanks for the reply. I am worried about bricking my TV if I pick an incorrect BOM or SW model. My SW Model is UKU6000 and the BOM Model is 6300. Is there a list of compatible models or has anyone changed from the UKU6000 and 6300 with success, or failure?

Thanks!

Re: PVR on US K series

Posted: Mon Dec 21, 2020 3:39 pm
by stoneattic
I found where someone appears to have bricked their UN50KU6300FXZA (same model as mine) doing just that:

viewtopic.php?t=12022&start=60

Re: PVR on US K series

Posted: Mon Dec 21, 2020 4:19 pm
by notengo13
stoneattic wrote:
Mon Dec 21, 2020 3:39 pm
I found where someone appears to have bricked their UN50KU6300FXZA (same model as mine) doing just that:

viewtopic.php?t=12022&start=60
He changed from 6000 to the model which use one connect box.
I went into the service menu using IR Service App and accidentally changed the model from uku6000 to uks7000. Now my TV boots but it doesn't respond to the remote nor to the IR Service App. The screen is stuck on the page "Connect one box to TV" I can't even enter any other menus . please help
TV model:ua43ku7000
What you get in BOM model and SW model

Re: PVR on US K series

Posted: Mon Dec 21, 2020 4:25 pm
by stoneattic
I haven't changed the SW or BOM models yet. They are still at SW Model UKU6000 and BOM 6300.

Re: PVR on US K series

Posted: Mon Dec 21, 2020 4:44 pm
by notengo13
stoneattic wrote:
Mon Dec 21, 2020 4:25 pm
I haven't changed the SW or BOM models yet. They are still at SW Model UKU6000 and BOM 6300.
Try to ask or get these value from another country where is possible to use PVR and compare them if they are same or different. Check on youtube service menu videos maybe You have luck and someone post some video with service menu and you can see these values. Somehow tv knows that you are in country where you can't use PVR.

Re: PVR on US K series

Posted: Mon Dec 21, 2020 5:08 pm
by notengo13
Check service manual maybe it will help you
viewtopic.php?p=107484#p107484

Re: PVR on US K series

Posted: Tue Dec 22, 2020 4:54 pm
by stoneattic
I spent a lot of time (too much, hehe) with Google and Google translate and found some German sites where they were working with a KU6070 and using UKU6090 to get PVR with Bluetooth and found these instructions:

http://www.hifi-forum.de/viewthread-151-32055.html

I found on the Samsung developer's site that the UKU6000 (mine) was in the same model group as the UKU6090 that the German's were using:

https://developer.samsung.com/smarttv/d ... roups.html

So I did the following:

1) Set SW Model to UKU6090

2) Under MRT Options set the Extended PVR to ON (this was already ON but might have been from me messing with it yesterday, or might have been by default with the UKU6000 SW Model setting)

3) Under MRT Options set BT Support to ON (this was OFF)

4) Under Engineer Options set BT AUDIO ON OFF to ON (this was already ON but might have been from me messing with it yesterday, or might have been by default with the UKU6000 SW Model setting)

I exited the Service Menu and had PVR and Bluetooth (both the Smart Remote and BT soundbar worked). :D
When I shut off and restarted the TV I lost PVR. :cry:

BUT!!! Setting the Local Set in the service menu to CARRIBE turned the PVR back on and it stays functional even after shutting the TV off and restarting! And PIP is now a functional option! :D :D :D

I'm pretty excited and figured I'd post what I did hoping it helps someone else. Of course do at your own risk, etc....

I will post a follow up if I discover any issues or additional features in the future.

Re: PVR on US K series

Posted: Tue Dec 22, 2020 8:36 pm
by stoneattic
I found an issue with the above setup. Samsung TV Plus is not available. I've tried turning it on in the Engineer menu but it is turned back off after restarting. I tried setting the Local to SD_MEXICO and NONE with the same result. I've reset the Smart Hub each time and still no luck. It looks like it needs to be set to USA to get TV Plus. That's not a big loss for me as I have never used TV Plus so I'm much happier with the PVR and Bluetooth working.