SamyGO Goes to Digital Ocean Host

This is general talk area for things that NOT RELATED WITH TV! Instead, about internal works like web site, forum, wiki, or talking, etc...

User avatar
erdem_ua
SamyGO Admin
Posts: 3102
Joined: Thu Oct 01, 2009 6:02 am
Location: Istanbul, Turkey
Contact:

SamyGO Goes to Digital Ocean Host

Post by erdem_ua » Tue Mar 10, 2015 8:41 pm

Hello all,
We have some issues with Edis.at host. There are many lost packet on their internal system. So I decide to move another host.

At this Thursday (12/03/2015), SamyGO servers probably be move to Digital Ocean cloud host's Amsterdam 2 servers which is faster, cheaper and issue free network connection.

With this move, we also made software upgrade to server. Our forum will be upgrade to phpBB v3.1.3.
Also apache server will be upgraded to 2.4. This will be give speed bump to whole site.

There will be no blackout due move. But old forum will be disabled and you can not post but just read.
Also DNS system will require some hours to sync up with new servers IP.
Regards

Edit: Well, somehow edis.at suspended our old server, due this, we are offline for a while.
Now moving old server to new one. Forum and wiki already moved.
Remaining files will be in place couple of hours...

Edit2: All files are moved to new server. Enjoy!

User avatar
fluffi444
SamyGO Project Donor
Posts: 562
Joined: Fri Apr 05, 2013 9:55 pm
Location: Germany

Re: SamyGO Goes to Digital Ocean Host

Post by fluffi444 » Fri Mar 13, 2015 12:35 pm

Thanks for that move! I followed you (?) yesterday on twitter (only web version)...
And I was really afraid what the old provider was doing !!! WTF !!!

Good that we are away from them now - That was a very bad advertising for themselves how they reacted yesterday on Twitter...

Thanks for your work on this!
TV: UE40ES7000 @ UE40ES8090 - T-ECPDEUC-2022.0 // SamyGO
CI+: Unicam EVO 4 with HD+ (HD02) @ Pacific 4.60
NET: Samba: PC

zoelechat
Official SamyGO Developer
Posts: 8372
Joined: Fri Apr 12, 2013 7:32 pm
Location: France

Re: SamyGO Goes to Digital Ocean Host

Post by zoelechat » Fri Mar 13, 2015 6:31 pm

No Twitter here, but happy that forum became browsable again, everyday was worse recently.
I guess it will take some time to get used to "new design" (actually not that different :) )

I'd just have one thought: despite the new "quick links" menu (which is fine when you're deep somewhere in forum), I find that at least "new posts" and "unread posts" are really missing on index page, especially seeing there's still empty room for them:
samygo_forum.jpg
Btw, did you voluntarily remove board translations? (not that I don't speak English but I'm a bit disoriented ;) )

Otherwise, nice work :)
You do not have the required permissions to view the files attached to this post.
I do NOT receive any PM. Please use forum.

User avatar
fluffi444
SamyGO Project Donor
Posts: 562
Joined: Fri Apr 05, 2013 9:55 pm
Location: Germany

Re: SamyGO Goes to Digital Ocean Host

Post by fluffi444 » Fri Mar 13, 2015 7:02 pm

For those who are interested (works in every browser):
https://twitter.com/edisat/status/576058356428849153

@erdem_ua: Call if you want me to remove this link. I dont want to blame old provider - I want only to show useres that we were short before and complete data loss yesterday...
TV: UE40ES7000 @ UE40ES8090 - T-ECPDEUC-2022.0 // SamyGO
CI+: Unicam EVO 4 with HD+ (HD02) @ Pacific 4.60
NET: Samba: PC

sectroyer
Official SamyGO Developer
Posts: 5765
Joined: Wed May 04, 2011 5:10 pm

Re: SamyGO Goes to Digital Ocean Host

Post by sectroyer » Fri Mar 13, 2015 9:17 pm

zoelechat wrote:No Twitter here, but happy that forum became browsable again, everyday was worse recently.
I guess it will take some time to get used to "new design" (actually not that different :) )

I'd just have one thought: despite the new "quick links" menu (which is fine when you're deep somewhere in forum), I find that at least "new posts" and "unread posts" are really missing on index page, especially seeing there's still empty room for them:
samygo_forum.jpg
Btw, did you voluntarily remove board translations? (not that I don't speak English but I'm a bit disoriented ;) )

Otherwise, nice work :)
I also have this problem :)
I do NOT support "latest fw" at ALL. If you have one you should block updates on router and wait for it to STOP being "latest":)
If you want me to help you please paste FULL log(s) to "spoiler"/"code" bbcodes or provide link(s) to pasted file(s) on http://ctrlv.it/ Otherwise "NO HELP"!!!
If you want root DISABLE internet access to your device!!!!
DO NOT EVER INSTALL FIRMWARE UPGRADE !!!!

User avatar
erdem_ua
SamyGO Admin
Posts: 3102
Joined: Thu Oct 01, 2009 6:02 am
Location: Istanbul, Turkey
Contact:

Re: SamyGO Goes to Digital Ocean Host

Post by erdem_ua » Sat Mar 14, 2015 12:40 am

@fluffi444, right thing to do is send a notice about issue. Or you can also restart server if that kill uplink. They could also suspend it but they has to be responsive to support ticket in that situation. I understand that, Edis.at became a company that only collects money and not give proper support. Our new host replies support tickets under 5 minutes :)

@zoelechat, Yes I know. I have to delete them due 3.0.12 to 3.1.3 upgrade. And yesterday I go to bed at 10:00 am. Also have some problems on copying content to new server. If I use full speed, old server shutdown the server, again. Need to restart by hand and resume the process. So I limit bandwidth but it takes longer time. Also I made some upgrade work I will start to install all language packs that I can find for 3.1 at this night. ;)

About the default style, I don't have much option for that. Don't understand from phpBB programing ( with full of macros ). But If you find a better style for phpBB3.1, I can install it also :)

User avatar
erdem_ua
SamyGO Admin
Posts: 3102
Joined: Thu Oct 01, 2009 6:02 am
Location: Istanbul, Turkey
Contact:

Re: SamyGO Goes to Digital Ocean Host

Post by erdem_ua » Sat Mar 14, 2015 1:54 am

All available phpBB 3.1.x Language Packs are installed. :D

User avatar
erdem_ua
SamyGO Admin
Posts: 3102
Joined: Thu Oct 01, 2009 6:02 am
Location: Istanbul, Turkey
Contact:

Re: SamyGO Goes to Digital Ocean Host

Post by erdem_ua » Sat Mar 14, 2015 6:08 pm

Here is evidence of EDIS.at lies about our server usage. http://t.co/i7pNoGETLo

User avatar
erdem_ua
SamyGO Admin
Posts: 3102
Joined: Thu Oct 01, 2009 6:02 am
Location: Istanbul, Turkey
Contact:

Re: SamyGO Goes to Digital Ocean Host

Post by erdem_ua » Sat Mar 14, 2015 6:55 pm

Enabled php caches for faster responsiveness and lower CPU usage.
Forum and wiki load times feels much faster right now.

zoelechat
Official SamyGO Developer
Posts: 8372
Joined: Fri Apr 12, 2013 7:32 pm
Location: France

Re: SamyGO Goes to Digital Ocean Host

Post by zoelechat » Mon Mar 16, 2015 12:59 pm

Almost everything seems fine now. I'd just like to do some report about a few things:

-In some cases, accessing site with IE reports certificate error (never happened before host change)
sec_ie_install_cert_popup.gif
-I noticed an "HTTP 500" error on a specific case: click on (new) "donors" category at the bottom of index page, sort list by "messages" once, and once again to sort reversely -> IE reports "HTTP 500" error, and Firefox remains blank.

-We (not only me) are still really hoping for "new posts" and "unread posts" links to be back on index page. Sorry to insist on that but it REALLY lacks, and having to browse "quick links" everytime is annoying (especially when you're active member :) )
You do not have the required permissions to view the files attached to this post.
I do NOT receive any PM. Please use forum.

Post Reply

Return to “General”