[SOLVED] C650 eth0<-->Apple Airport Extreme issue

Here is information about customize your C series firmware..:!:This forum is NOT FOR DUMMY USERS questions or problems but DEVELOPER.
Post Reply

riso
SamyGO Project Donor
Posts: 12
Joined: Wed Nov 23, 2011 8:43 am
Location: Slovakia

[SOLVED] C650 eth0<-->Apple Airport Extreme issue

Post by riso »

Hello,

I have a LE40C650 with SamyGO for a while now working very well using the built in LAN port.

Just recently I replaced my router with Apple's Airport Extreme for higher wifi throughput, etc and as a result I can no longer play
HD content over the wired LAN port connected to the Airport. The video plays for 0.5 second stops, plays, stops, etc...

I narrowed down the problem some incompatibility between eth0 (sdp GMAC 10/100M network driver ver 0.956) and the Airport Extreme.

Once the TV is up/reachable and I unplug/replug the TV's cable back into the Airport the problem goes away.
This however can't be a workaround as it needs to be done after every TV power cycle :)

Flapping the interface via ifconfig does not seem to help...

Un&Reloading the sdpGMAC occasionally fixed the issue but most of the times caused a kernel panic - TV reboots.

Has anyone seen this before? The kernel is: 2.6.24_SELP.4.3.x-Cortex-A8 #778 PREEMPT

Is there a better way to unload the driver or perhaps upgrade it?

Has anyone compiled ethtool? perhaps playing with that could help...

Thanks,
Riso
Last edited by riso on Tue Jan 08, 2013 10:31 pm, edited 3 times in total.

riso
SamyGO Project Donor
Posts: 12
Joined: Wed Nov 23, 2011 8:43 am
Location: Slovakia

Re: C650 eth0<-->Apple Airport Extreme issue

Post by riso »

To further add on the initial post, I tried this on a 2nd C650 and the behavior is consistent.

Interesting to find out that if I boot the TV without the cable plugged in during boot-up/kernel probe and plug it once the TV is up, the issue is also NOT seen.

I do not have another gig switch on hand at the moment, but will try to get one...

Does anyone have their TV plugged into a non manageable 10/100/1000 switch? I can't be the only one :)

riso
SamyGO Project Donor
Posts: 12
Joined: Wed Nov 23, 2011 8:43 am
Location: Slovakia

Re: C650 eth0<-->Apple Airport Extreme issue

Post by riso »

...So I managed to test the setup [NAS (WD Live) & C650] with a Cisco 10/100/1000 switch.

The HD playback on the TV worked fine in all combinations (Auto/Auto Flow Control On/Off, 1000FD/100FD Flow Control On/Off).

FYI: the non-working AP is airport 5th gen.

It seems the issue has been discussed before with different gig switches.

riso
SamyGO Project Donor
Posts: 12
Joined: Wed Nov 23, 2011 8:43 am
Location: Slovakia

Re: C650 eth0<-->Apple Airport Extreme issue

Post by riso »

Hi again,

Trying to workaround the problem with a USB LAN stick...
I got my hands on Belkin F5D5055 (ASIX AX88178 chipset) and the performance is quite bad..
The adapter functions but playing video occasionaly skips, there is a delay when doing FF/RW...

After loading the asix.ko module:

Code: Select all

eth1: register 'asix' at usb-ehci-sdp.0-1, ASIX AX88178 USB 2.0 Ethernet, 00:11:50:e7:77:6e
usbcore: registered new interface driver asix
eth1: link down
dmesg is flooded with this:

Code: Select all

Function entered at [<c00280c4>] from [<c00280f0>]
Function entered at [<c00280d8>] from [<c01de82c>]
Function entered at [<bf70899c>] from [<c0254564>]
Function entered at [<c025434c>] from [<c02649a4>]
 r7:dc820cc0 r6:dc820cc0 r5:dc83d800 r4:dca04000
Function entered at [<c02648dc>] from [<c02571bc>]
Function entered at [<c0257038>] from [<c027bc54>]
 r6:0000000e r5:dc820cc0 r4:00000000
Function entered at [<c027b9f4>] from [<c027ce20>]
 r8:00000040 r7:dc9eef00 r6:dc9eef00 r5:dc820cc0 r4:00000001
Function entered at [<c027cc48>] from [<c027a440>]
 r6:dc85ab40 r5:dc820cc0 r4:db30d410
Function entered at [<c027a088>] from [<c0298f68>]
Function entered at [<c0298ca4>] from [<c029a1b4>]
Function entered at [<c0299cd4>] from [<c02a0cd8>]
Function entered at [<c02a0c7c>] from [<c0247e8c>]
 r7:00000000 r6:dca05de0 r5:00000000 r4:00000000
Function entered at [<c0247de0>] from [<c0248190>]
 r6:dca05ed0 r5:dcca0780 r4:00000000
Function entered at [<c02480b8>] from [<c0023880>]
Division by zero in kernel.
Function entered at [<c00280c4>] from [<c00280f0>]
I am using the asix.ko from: SamyGO-All-Modules-v0.03.7-r01-for-armv7a_valencia_DEV-T-VAL6DEUC-20110912071317.zip

Anyone have any idea?

Thanks,
Riso
Last edited by riso on Wed Jan 09, 2013 12:30 pm, edited 5 times in total.

riso
SamyGO Project Donor
Posts: 12
Joined: Wed Nov 23, 2011 8:43 am
Location: Slovakia

Re: [SOLVED] C650 eth0<-->Apple Airport Extreme issue

Post by riso »

... ok last post... :)

For problem #1 with eth0 (sdp GMAC 10/100M network driver ver 0.956) just as I thought, ethttool is our friend.

With 'ethtool -r eth0' the interface is flapped at the link layer:

Code: Select all

     eth0: link down
     eth0: link up, 100Mbps, full-duplex, lpa 0xC5E1
...and the problem with Airport is fixed... until next reboot of course :)


For problem #2 with freshly recompiled asix.ko driver from a friend, the Belkin stick works like a charm.

Code: Select all

    ASIX USB Ethernet Adapter:v4.4.1 17:53:51 Jan  8 2013
    http://www.asix.com.tw
    eth%d: status ep1in, 8 bytes period 11
    eth1: register 'asix' at usb-ehci-sdp.0-1.4, Belkin Gigabit USB 2.0 Network Adapter, dca91134M
    usbcore: registered new interface driver asix
    eth1: rxqlen 0 --> 5
    eth1: ax8817x - Link status is: 0
    eth1: kevent 4 scheduled
    eth1: ax8817x - Link status is: 1

/dtv/usb/sda1 # ./ethtool-static eth1
Settings for eth1:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pg
        Wake-on: d
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes
/dtv/usb/sda1 #
I also received the ifstat binary which shows the gigabit interface buffering a lot more than the 100mbps link:

Code: Select all

/dtv/usb/sda1 #
/dtv/usb/sda1 # ~ DVB-C recording playback (over 1gbps link) ~
/dtv/usb/sda1 #
/dtv/usb/sda1 # ./ifstat-static -b -i eth1 1
       eth1       
 Kbps in  Kbps out
96292.47     88.22
96135.10     88.35
99493.38     92.12
97163.16     88.06
96139.95     88.01
96156.82     88.00
100520.3     92.27
/dtv/usb/sda1 # 
/dtv/usb/sda1 # 
/dtv/usb/sda1 #~ DVB-C recording playback (over 100mbps link) ~
/dtv/usb/sda1 # 
/dtv/usb/sda1 # ./ifstat-static -b -i eth0 1
       eth0       
 Kbps in  Kbps out
17058.00     86.67
17006.49     86.25
17004.71     86.24
17012.62     86.28
17006.00     86.25
17008.65     86.26
17005.56     86.25
/dtv/usb/sda1 #
/dtv/usb/sda1 #
/dtv/usb/sda1 #  ~ 1080p.BluRay.x264.mkv playback (over 1gbps links) ~
/dtv/usb/sda1 # 
/dtv/usb/sda1 # ./ifstat-static -b -i eth1 1
       eth1       
 Kbps in  Kbps out
78412.79     70.20
67526.75     60.11
33808.67     30.90
67386.47     60.30
33752.77     30.59
33747.62     30.23
67375.54     60.10
33762.71     30.42
67503.08     60.12
/dtv/usb/sda1 # 
/dtv/usb/sda1 #
/dtv/usb/sda1 #  ~ 1080p.BluRay.x264.mkv playback (over 100mbps links) ~
/dtv/usb/sda1 #
/dtv/usb/sda1 # ./ifstat-static -b -i eth0 1
       eth0       
 Kbps in  Kbps out
15818.29     78.78
19733.14     97.91
15794.61     79.50
11843.72     59.03
11837.65    167.73
11844.92     59.04
11851.59     59.07
18390.98     98.17
21088.66     98.03
11842.13     59.02
11836.20     58.99
23699.87    117.46
IPERF also seems to work on the TV..
here are some performance numbers :) some tcp tweaking would probably give better numbers but 150mbps is more than enough :)

Code: Select all

/dtv/usb/sda1 # 
/dtv/usb/sda1 #  ~ UDP performance ~
/dtv/usb/sda1 # 
/dtv/usb/sda1 # ./iperf-static -s -u
------------------------------------------------------------
Server listening on UDP port 5001
Receiving 1470 byte datagrams
UDP buffer size:  106 KByte (default)
------------------------------------------------------------
[  3] local 10.255.255.166 port 5001 connected with 10.255.255.12 port 55116
[ ID] Interval       Transfer     Bandwidth        Jitter   Lost/Total Datagrams
[  3]  0.0-67.3 sec  1.77 GBytes   226 Mbits/sec   0.064 ms 430674/1723205 (25%)
[  3]  0.0-67.3 sec  1 datagrams received out-of-order
/dtv/usb/sda1 # 
/dtv/usb/sda1 # 
/dtv/usb/sda1 #  ~ TCP performance ~
/dtv/usb/sda1 # 
/dtv/usb/sda1 # ./iperf-static -s
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
[  4] local 10.255.255.166 port 5001 connected with 10.255.255.12 port 60425
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-60.5 sec  1.06 GBytes   151 Mbits/sec
/dtv/usb/sda1 #
If anyone is interested in the tools (ethtool, ifstat, iperm) - PM me...

Cheers,
Riso
Please use

Code: Select all

 and other text formatting tools. Thanks! moderator[/color]

User avatar
greenhorn
SamyGO Project Donor
Posts: 700
Joined: Wed Feb 15, 2012 3:05 pm
Location: Eastern Europe

Re: [SOLVED] C650 eth0<-->Apple Airport Extreme issue

Post by greenhorn »

Nice! This should go in wiki. Asix.ko is good replacement of the stock lan card. Seems many issues with LAN conectivity can be fixed with this device&driver.
TV: UE40F7000 - T-FXPDEUC-1115.0 - SamyGO Extensions on F series
TV: UE55ES7000S - T-ECPDEUC-2003.4 - SamyGO tool Right from USB - no develop account is needed
TV: UE40C6710 - T-VALDEUC 3011 - Hacking TV over Hotel mode (C650 T-VALDEUC-3009.2)
BD-Player: BD-E6100 - B-FIRBPEWWC 1063.3 - rooted, no more Cin@vi@
NAS: CIFS: MAG250 NFS: Playon!HD

User avatar
greenhorn
SamyGO Project Donor
Posts: 700
Joined: Wed Feb 15, 2012 3:05 pm
Location: Eastern Europe

Re: [SOLVED] C650 eth0<-->Apple Airport Extreme issue

Post by greenhorn »

It can be useable if you have 2 Vlans from your ISP. The first Vlan is the internet access, the other one the multicast. So, can you please upload these tools/drivers?
TV: UE40F7000 - T-FXPDEUC-1115.0 - SamyGO Extensions on F series
TV: UE55ES7000S - T-ECPDEUC-2003.4 - SamyGO tool Right from USB - no develop account is needed
TV: UE40C6710 - T-VALDEUC 3011 - Hacking TV over Hotel mode (C650 T-VALDEUC-3009.2)
BD-Player: BD-E6100 - B-FIRBPEWWC 1063.3 - rooted, no more Cin@vi@
NAS: CIFS: MAG250 NFS: Playon!HD

Post Reply

Return to “[C] Firmware”