Using RT3070 WiFi dongles with Samsung TV

This forum for information that related with C series hardware instead of firmware/software.
Post Reply

User avatar
AlexAltea
Posts: 2
Joined: Sat Mar 02, 2013 11:02 am

Using RT3070 WiFi dongles with Samsung TV

Post by AlexAltea »

Hi guys, I am trying to make a Linksys WUSB100 v2 (RT3070) compatible with my Samsung TV (UE32C6700). I was able to patch the EEPROM values according to the information I found on this topic: viewtopic.php?f=3&t=14

Now, the dongle is recognized by the TV, and the LED has a normal behaviour (it blinks fast when scanning, otherwise it lights intermittently), but does not find any APs. If I force my computer not to use (rmmod) the rt2870sta, rt2800usb, rt2x00usb, rt2800lib, rt2x00lib modules and I insmod my modified rt2870sta driver the same behavior occurs. I have played with the source code of iwlist and I found that ioctl(skfd, req, pwrq) with the requests SIOCGIWSCAN / SIOCSIWSCAN is not doing its job. I cannot find the implementation of that function; the only information I got was its declaration in ioctl.h:

Code: Select all

extern int ioctl (int __fs, unsigned long int __request, ...) __ THROW;
Does anyone know where it is implemented? (I hope to find the cause of the issue by tracing the functions involved in the scan)

Returning to the main problem: Would it be possible to fix this issue by changing some values in the EEPROM? (In other words, is this idea stupid?).
Since I don't want to change the firmware of my TV, I guess that is the only solution. If that's right, could anyone send me an EEPROM dump of a RT2870 dongle? That can be easily done with: iwpriv ra0 e2p. Of course, feel free to hide the MAC address. Thank you very much!

PS: Yes, I really have searched on this forum and Google before asking. However, all the posts about ioctl or rt3070 were not useful to me. ;)

User avatar
AlexAltea
Posts: 2
Joined: Sat Mar 02, 2013 11:02 am

Re: Using RT3070 WiFi dongles with Samsung TV

Post by AlexAltea »

spharez wrote:I found that my samsung TV works unstable with fuppes on freenas (I think on nas4free same issues).
I fixed this issue in fuppes using patch.
How can I include my fix into to the nas4free?
O.o ... I guess you posted in the wrong thread. ;)

Post Reply

Return to “[C] Hardware”