DLink DWA140 Hw Rev D1

This forum for information that related with C series hardware instead of firmware/software.
Post Reply

Posts: 1
Joined: Sat Mar 08, 2014 1:58 pm

DLink DWA140 Hw Rev D1

Post by towme »


So, read the "C series WiKi" bought a dlink dwa140 which looked like a B2, but when arrived it turned out to be a D1. Anyway tried the things listed in the wiki to turn it samsung compatible. Which worked half way.
Managed to change the hardware id, TV recognizes it but can't connect to a network.

The driver source in the C series wiki didn't work, but downloaded one from mediatek website, compiled it and it tadaaa. (ok, had to include the little trick mentioned on the wikidev page)

The stick works under windows well, but unable to get it work under linux
The wikidev page of the stick: https://wikidevi.com/wiki/D-Link_DWA-140_rev_D1

Is there any possibility to get it working with rt2870sta module? or wrong place to ask?
Can i rename the rt5370sta to rt2870sta and replace it on my TV?

I don't care if I get only 54 Mbps and not 300.
(And I know first i have to make it work under linux, but i am half way there)


Post Reply

Return to “[C] Hardware”