TV D-Series Firmware Downgrade (SamyGO Proof of Concept)

Here is information about customize your D series firmware..:!:This forum is NOT FOR USER questions or problems but DEVELOPER.

User avatar
juusso
SamyGO Moderator
Posts: 9776
Joined: Sun Mar 07, 2010 6:20 pm

Re: TV D-Series Firmware Downgrade (SamyGO Proof of Concept)

Post by juusso » Thu Jun 15, 2017 4:55 pm

I apologize, this is not possible.
LE40B653T5W,UE40D6750
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

daviddrf
Posts: 85
Joined: Sat Jul 01, 2017 4:05 am

Re: TV D-Series Firmware Downgrade (SamyGO Proof of Concept)

Post by daviddrf » Mon Jul 03, 2017 9:46 pm

Hello to all. First of all excuse me for my bad English. I'm from Spain and I'm trying to improve my English level everyday. I haven't find any place in the forum for introduce myself so I'm taking advantage of it to do it now, it's a pleasure for me to be here with you. I wrote this message because I had a big problem today. I have an UE32D6100 Samsung television with T-GAS6DEUC-1017.1 firmware (I had a LE40C650 too but with this last television everything is fine). I've been reading a lot of this forum since one week in order to try to hack both televisions. I decided to start with the UE32D6100. I entered in service menu and disabled watchdog and enabled the RS232 option as "Logic" instead of "UART" (by default). I forgot to clone the settings to an USB and I didn't make screenshots of every screen of the service menu, but I did a photo of the "main" service menu screen:

Image

So I decided to downgrade my 1017.1 firmware (using the first message of this post) in order to hack the television with the developer account (https://wiki.samygo.tv/index.php?title= ... cpu_models) because it seemed "easier and cleaner" to me than the hospitality mode (https://wiki.samygo.tv/index.php?title= ... arm_models). I hit the menu key and then changed the DNS IP of my television to 46.101.161.175. Then went to the option for upgrading the firmware "by the official way" and started to search it. I forgot to say that the OTN option was enabled and set to "Operating" the last time I entered in the service menu. The first time I got a message from the television that told me that there aren't new firmwares found ("No se ha encontrado software para actualizarlo" in Spanish language):

Image

I tried another time and then I got a 606 error message. I tried one last time and then I got the same message than the first time ("No se ha encontrado software para actualizarlo" in Spanish language). Then I realized that the TV stopped working. If I push any key in the remote control nothing happens...So I waited 5 minutes and then I unplugged and plugged the power cord. Now the problem is the television doesn't work. It's in blank (or black screen better) with no audio and no picture. I uploaded a video to Youtube to show you it better (I don't know what is the code to post Youtube videos in embedded mode in this forum, sorry):

https://youtu.be/XJsyhNlTme8

Then I tried to do a "blind factory reset". I powered on the television and pushed the "EXIT" key for 15 seconds. Then I pushed left arrow key (I tried later with down arrow key too) and hit "ENTER" key, but nothing happened. So I tried to power off and power on the television again and try with the "INFO+MENU+MUTE+POWER" conbination to access the service menu and then hit "ENTER" three times (to go to "Option" menu, "Factory reset" and then confirm it) but nothing happenned five minutes later.
At this point I think I had two options but I don't know if any of them would work. The first option is to do an EEPROM reset but if I do this I will lost all the service menu configurations, so I would prefer to try the Ex-link cable first and if this one doesn't work then do the EEPROM reset.
The problem now is I thought my Ex-link cable would work fine but I think I made a mistake and now I will tell you why.
I had a CP2102 serial to TTL converter which I bought in eBay some years ago. With this module I was able to "revive" some routers with the serial connection and PuTTY. I connected the +5V of this module to a red wire of an USB cable attached to TV. I connected the RX pin of this module with the RX pin of the VGA connector I bought after soldered it and I did the same with the respective GND and TX pins (GND and TX pins of the VGA to GND and TX pins of the CP2102 USB to TTL module converter or adapter like this: https://wiki.samygo.tv/images/0/06/VGA-Exlink.jpg). Then I connected the VGA connector to the VGA port of the television and by the other side I connected the USB port of the converter module to my Windows laptop. In my Windows laptop I had PuTTY properly configurated with the right port, speed, etc... in COM4 (the connection for my USB module) port as a serial connection like this: https://wiki.samygo.tv/images/d/d2/ExLi ... tings1.png . The problem is nothing happens in PuTTY when I switch on the television. I already tried with an VGA and/or USB extensor and unplugging the aerial/coaxial antenna cable and the LAN ethernet cable too but I got the same result...Here are two photos of my Ex-link cable:

Image

Image

Where is the mistake? I used this CP2102 adapter because I have no MAX232 circuit neither and USB to RS232 serial cable or Nokia CA-42/DKU-5 USB cable. Is my Ex-link cable right or is a pice of garbage/rubbish?
I can't understand how is this possible. I've been reading days and days of documentation in this great forum/wiki/website and I think I learned a little bit in order to avoid this specific situation but as you can see it seems this was impossible...I also can't understand how is possible to brick this television using the "fake DNS firmware downgrade". I am very sad with this situation. Could anyone help me plase? Thanks a lot in advance and sorry for my very big and long message.

PD: another aspect I realized is that when I unplug the power cord the red LED power is blinking like you can see in the following video:

https://youtu.be/T_-rTnz8Alk

daviddrf
Posts: 85
Joined: Sat Jul 01, 2017 4:05 am

Re: TV D-Series Firmware Downgrade (SamyGO Proof of Concept)

Post by daviddrf » Tue Jul 04, 2017 11:42 am

Hello again. After more hours of "investigation" searching deep inside in this forum during the early morning (specially in the Ex-link wired cable threads like https://forum.samygo.tv/viewtopic.php?f=15&t=2817 , https://forum.samygo.tv/viewtopic.php?t=4821 , https://forum.samygo.tv/viewtopic.php?f ... 83&p=27583 , https://forum.samygo.tv/viewtopic.php?f ... 41&p=33261 or https://forum.samygo.tv/viewtopic.php?f=23&t=4341) I disconnected the red wire of an attached USB cable to TV and +5V pin of the CP2102 module (it's not necessary) and I made the trick of swaping the RX and TX pins. I tested it with the other television I have (which works properly, a 40LEC650) and it work flawessly with an USB extensor cable (my loose wires are very short). If I try with an VGA extensor cable it doesn't work. Here is the evidence:

https://youtu.be/5ML48YUQBWA

So I can confirm that the CP2102 USB RS232 UART to TTL module (like this one: https://blog.tarn-vedra.de/posts/assets ... -reset.png) works perfect (at least in my case).
Then I tried with the defective UE32D6100 and this happened when I power on and/or power off the television:

https://www.youtube.com/watch?v=rNKP3e1qwMU

The output shown in PuTTY is (everytime I power on the television):

Code: Select all

> S 0067 onboot(May 17 2011-16:18:53)
GenoaS with Parma, GenoaS only
> S 0067 onboot(May 17 2011-16:18:53)
GenoaS with Parma, GenoaS only
> S 0067 onboot(May 17 2011-16:18:53)
GenoaS with Parma, GenoaS only
> S 0067 onboot(May 17 2011-16:18:53)
GenoaS with Parma, GenoaS only
> S 0067 onboot(May 17 2011-16:18:53)
GenoaS with Parma, GenoaS only
Could anyone help me please? Is this last output referred to the bootloader or something like that? Is the EEPROM reset my last chance/opportunity to unbrick the television? Thanks in advance again.

User avatar
juusso
SamyGO Moderator
Posts: 9776
Joined: Sun Mar 07, 2010 6:20 pm

Re: TV D-Series Firmware Downgrade (SamyGO Proof of Concept)

Post by juusso » Tue Jul 04, 2017 9:24 pm

Really bad news. From log i see your tv is in bootloop. No idea what had caused this, but it is not reparable issue, mainboard replacement is an option.
Sure you can try eeprom reset, who knows, somtimes here are some miracles...
LE40B653T5W,UE40D6750
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

daviddrf
Posts: 85
Joined: Sat Jul 01, 2017 4:05 am

Re: TV D-Series Firmware Downgrade (SamyGO Proof of Concept)

Post by daviddrf » Tue Jul 04, 2017 9:47 pm

juusso wrote:
Tue Jul 04, 2017 9:24 pm
Really bad news. From log i see your tv is in bootloop. No idea what had caused this, but it is not reparable issue, mainboard replacement is an option.
Sure you can try eeprom reset, who knows, somtimes here are some miracles...
OK, for my experience I would strongly recommend to other users not to try a firmware downgrade using the following IP as DNS server: 46.101.161.175. I will try the EEPROM reset and then I will tell you what happened. Otherwise wouldn't be possible to find in the mainboard the "memory" where is located the bootloop in order to replace only it avoiding all the mainboard replacement (replacing only this "memory" instead all the mainboard)? Thanks for your help.
Last edited by daviddrf on Wed Jul 05, 2017 6:20 am, edited 1 time in total.

daviddrf
Posts: 85
Joined: Sat Jul 01, 2017 4:05 am

Re: TV D-Series Firmware Downgrade (SamyGO Proof of Concept)

Post by daviddrf » Wed Jul 05, 2017 6:18 am

Hello to all. I've made the EEPROM reset some minutes ago without success. I've been looking for the PN of my mainboard which is BN94-05514F for my UE32D6100SWXXC. I've been searching for it in Google but I had no success. Does anyone know where could I find it please?
I have another question, as I asked before: would be possible to replace only the "memory" where the problem is located instead of replacing all the mainboard? I've been reading and watching thinks like this, that's why I'm asking for it:

https://forum.samygo.tv/viewtopic.php?f=23&t=2519
https://www.youtube.com/watch?v=812DCrpZufk

Thanks in advance for all your support.

Michal
Posts: 23
Joined: Tue Jul 04, 2017 1:27 pm

Re: TV D-Series Firmware Downgrade (SamyGO Proof of Concept)

Post by Michal » Wed Jul 05, 2017 7:22 pm

Hi. Please can not downgrade my UE40D5500 with firmware T-MST5DEUC-1027 dns 46.101.161.175. Server writes, error code 601. must the router also be set? Thank you for your response.

daviddrf
Posts: 85
Joined: Sat Jul 01, 2017 4:05 am

Re: TV D-Series Firmware Downgrade (SamyGO Proof of Concept)

Post by daviddrf » Wed Jul 05, 2017 8:06 pm

Michal wrote:
Wed Jul 05, 2017 7:22 pm
Hi. Please can not downgrade my UE40D5500 with firmware T-MST5DEUC-1027 dns 46.101.161.175. Server writes, error code 601. must the router also be set? Thank you for your response.
I would strongly recommend you not to try that method to downgrade your television because it bricked mine...

Michal
Posts: 23
Joined: Tue Jul 04, 2017 1:27 pm

Re: TV D-Series Firmware Downgrade (SamyGO Proof of Concept)

Post by Michal » Wed Jul 05, 2017 8:33 pm

daviddrf wrote:
Wed Jul 05, 2017 6:18 am
Hello to all. I've made the EEPROM reset some minutes ago without success. I've been looking for the PN of my mainboard which is BN94-05514F for my UE32D6100SWXXC. I've been searching for it in Google but I had no success. Does anyone know where could I find it please?
I have another question, as I asked before: would be possible to replace only the "memory" where the problem is located instead of replacing all the mainboard? I've been reading and watching thinks like this, that's why I'm asking for it:

https://forum.samygo.tv/viewtopic.php?f=23&t=2519
https://www.youtube.com/watch?v=812DCrpZufk

Thanks in advance for all your support.
Send a photo of the mainboard

daviddrf
Posts: 85
Joined: Sat Jul 01, 2017 4:05 am

Re: TV D-Series Firmware Downgrade (SamyGO Proof of Concept)

Post by daviddrf » Wed Jul 05, 2017 8:48 pm

Michal wrote:
Wed Jul 05, 2017 8:33 pm
daviddrf wrote:
Wed Jul 05, 2017 6:18 am
Hello to all. I've made the EEPROM reset some minutes ago without success. I've been looking for the PN of my mainboard which is BN94-05514F for my UE32D6100SWXXC. I've been searching for it in Google but I had no success. Does anyone know where could I find it please?
I have another question, as I asked before: would be possible to replace only the "memory" where the problem is located instead of replacing all the mainboard? I've been reading and watching thinks like this, that's why I'm asking for it:

https://forum.samygo.tv/viewtopic.php?f=23&t=2519
https://www.youtube.com/watch?v=812DCrpZufk

Thanks in advance for all your support.
Send a photo of the mainboard
OK, here are some photos of my mainboard from different angles and positions, I can do more if you need;

Image

Image

Image

Image

Image

Image

As you can see the mainboard is pretty close than the EEPROM's reset guide (UA40D6000): https://wiki.samygo.tv/images/8/86/UA40 ... EEPROM.jpg

Post Reply

Return to “[D] Firmware”