How to get smb/samba shares to work with UE40D8000?

Here for general support for D series TVs, request and problem solve area.

boogie
Posts: 5
Joined: Wed Dec 14, 2011 11:28 pm

How to get smb/samba shares to work with UE40D8000?

Post by boogie »

Hello !!

First of all , many thanks to the developers and contributers of SamyGO !

I got an UE40D8090 and have already SamyGo installed , with the Wiki tutorial !
And now there are a few questions about getting smb-shares to work with my Laptop Win 7 Ultimate 64bit !

First problem ,this file isn?t in the init.d folder : service_name.init.dis :shock:

I read the instructions to enable samba shares.
Here was the second problem ... there isn?t an path like this : /mtd_down/widget/user/SamyGO/SamyGO/etc/init.d/04_04_samba.init !!!!
I looked for the 04_04_samba.init file and found it here : /mtd_rwcommon/widgets/user/SamyGO/SamyGO/etc/init.d/04_04_samba.init !!!! :? :? :?

Is this the right path for the .init files which i can/must configure :oops: :oops: :oops: ???
So far so good , i got on and edited the file with notpad++ like this :

(I put user=xbox and pass=pass because i got an guest-account on my laptop called "xbox", so my samba-shares in my network work flawlessly ;) !!! )

##### CHANGE MEEEEE !!!!! ######
USER="xbox"
PASSWD="pass"
PERM="rw" # can be ro or rw
##### CHANGE MEEEEE END ######

[ -e /mtd_rwarea/smb_userdata ] && source /mtd_rwarea/smb_userdata

[ -z $USER ] && exit 1
[ -z $PASSWD ] && exit 1

DEST_DIR=$MOUNT_PATH/smb
SERVER="192.168.1.4"
# SERVER="10.0.0.1" # if you want a fixed server
SHARES="Filme"
FR_NAME="Samba Server"



Is here everything O.K. ?

Then i went on doing that (like in Wiki) :

created a file like this:
smb_userdata
USER="xbox"
PASSWD="pass"

Put this file to USB and attached to TV.
Restart TV
Run SamyGO

MUST the USB with the smb_userdata-file be attached ALWAYS to the TV ??? :?

So here my questions :

1. : Have i got to create this file service_name.init.dis and transfer it via FTP
2. : Have i got to create this path/file : /mtd_down/widget/user/SamyGO/SamyGO/etc/init.d/04_04_samba.init
3. : Is everything o.k. with my 04_04_samba.init .... or did i something wrong
4. : Must the USB-Pen with the smb_userdata file always be in the USB-Port of the TV ...

Questions about questions :oops:

Appreciate EVERY HELP :mrgreen: :mrgreen: :mrgreen:

Thanks
UE40D8090 FW1018 SamyGO and VERY VERY HAPPY !

User avatar
juusso
SamyGO Moderator
Posts: 10125
Joined: Sun Mar 07, 2010 6:20 pm

Re: How to get smb/samba shares to work with UE40D8000?

Post by juusso »

boogie wrote:Hello !!
I read the instructions to enable samba shares.
Here was the second problem ... there isn?t an path like this : /mtd_down/widget/user/SamyGO/SamyGO/etc/init.d/04_04_samba.init !!!!
I looked for the 04_04_samba.init file and found it here : /mtd_rwcommon/widgets/user/SamyGO/SamyGO/etc/init.d/04_04_samba.init !!!! :? :? :?
Is this the right path for the .init files which i can/must configure :oops: :oops: :oops: ???
It`s ok, place is right. On your tv SamyGo is placed in /mtd_rwcommon/widgets/user/SamyGO/
So far so good , i got on and edited the file with notpad++ like this :
(I put user=xbox and pass=pass because i got an guest-account on my laptop called "xbox", so my samba-shares in my network work flawlessly ;) !!! )

Code: Select all

##### CHANGE MEEEEE !!!!! ######
USER="[b]xbox[/b]"
PASSWD="[b]pass[/b]"
PERM="rw" # can be ro or rw
##### CHANGE MEEEEE END ######

[ -e /mtd_rwarea/smb_userdata ] && source /mtd_rwarea/smb_userdata

[ -z $USER ] && exit 1
[ -z $PASSWD ] && exit 1

DEST_DIR=$MOUNT_PATH/smb
SERVER="[b]192.168.1.4[/b]"
# SERVER="10.0.0.1" # if you want a fixed server
SHARES="[b]Filme[/b]"
FR_NAME="Samba Server"
Is here everything O.K. ?
Stop. Either edit script ##### CHANGE MEEEEE !!!!! ###### section, or don`t touch user and passw block there and create smb_userdata.
If you edit script, then additional smb_userdata file dont needed at all. Anyway, if created, it is needed only once - it will be copied to TV`s rwarea for further use.
1. : Have i got to create this file service_name.init.dis and transfer it via FTP
2. : Have i got to create this path/file : /mtd_down/widget/user/SamyGO/SamyGO/etc/init.d/04_04_samba.init
3. : Is everything o.k. with my 04_04_samba.init .... or did i something wrong
4. : Must the USB-Pen with the smb_userdata file always be in the USB-Port of the TV ...
1. no, there was just example!!! service_name.init means 04_04_samba.init...
2. I answered already, you don`t needed to create anything there (also - impossible, filesystem is readonly ;))
3 and 4 .. see above.

p.s. Pls use text formatting tags for code, quotes and so on...
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

boogie
Posts: 5
Joined: Wed Dec 14, 2011 11:28 pm

Re: How to get smb/samba shares to work with UE40D8000?

Post by boogie »

Thanks juuso !!!

Now i have access to my smb network , i see the smb folder in SamyGO Virt. USB , and then i see the IP of my Laptop/Share (192.168.1.4) !!!

But when i enter them ....the folders are empty ????? :oops: :oops: :oops:

What can i do now ???

BTW: i?m totally new to linux ! :roll:
UE40D8090 FW1018 SamyGO and VERY VERY HAPPY !

User avatar
juusso
SamyGO Moderator
Posts: 10125
Joined: Sun Mar 07, 2010 6:20 pm

Re: How to get smb/samba shares to work with UE40D8000?

Post by juusso »

LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

boogie
Posts: 5
Joined: Wed Dec 14, 2011 11:28 pm

Re: How to get smb/samba shares to work with UE40D8000?

Post by boogie »

I checked this already , and that isn?t the problem !!!

Maybe i got to enable / disable some init.d files... ?!?!?!
Here the list of my init.d folder

Code: Select all

01_01_catch_crap.init
01_03_hotplug.init.dis
01_04_server_replacement.init
01_05_hiddev.init
02_04_replace_wifi_mod.init.dis
02_04_vusb.init
02_04_vusb.init.remi71
02_10_wakelan.init.dis
03_01_fuse.init
03_03_djmount.init.dis
03_03_nfsmount.init.dis
03_03_nfsmount.init.remi71
03_03_udpxy.init.dis.dis
04_04_fusesmb.init.dis
04_04_httpfs.init.dis
04_04_samba.init
06_05_apache.init
06_05_bb_httpd.init.dis
06_05_samba-server.init
06_06_obexpush.init.dis
70_70_arfix-sh.init.did
80_80_record_to_nwshare.init.kayaweed
80_80_record_to_nwshare.init.remi71
90_90_injectso.init.dis
90_90_loadGameMains.init.dis
99_99_start_exeDSP.ini.disabled_by_default_to_protect_the_innocent

:?: :?

Please take a look !
Thanks
UE40D8090 FW1018 SamyGO and VERY VERY HAPPY !

jarod73
Posts: 22
Joined: Mon Nov 14, 2011 10:45 pm
Location: Italy

Re: How to get smb/samba shares to work with UE40D8000?

Post by jarod73 »

In my experience if you browse to the share and you see nothing is something related file sharing or permission on your pc.
I was able to regulay browse within a share on winxp an was not on the other pc where share was done trough Vista.
I did not edited the 04_04 script anymore and created again the share in vista. Check permission on original folder too not only in share.
Now I browse both without problem.

bye J.
UE40D7000LQXZT
T-GAPDEUC 1018.0
DUID 2DCFP7.......
WinXP sp3

samer
Posts: 76
Joined: Mon Nov 14, 2011 3:04 am

Re: How to get smb/samba shares to work with UE40D8000?

Post by samer »

where i founf tutorial for dumbs?

I have samba share without password and need play avi from tv...

i write in 04_04_samba.init

SERVER="192.168.11.1"

and

SHARES="WDCWD20"

but not show anything in SamyGO Virt. USB!!!

from notebook normaly show share \\192.168.11.1 and from iDevice i browse too same share smb://192.168.11.1 vithout problem and play by BUZZ Player

Where is bug please?
----D6100, i search YouTube app for mirroring from tablet (send me pm, many thx!)
....F6500 T-MST12DEUC ver.1119

Post Reply

Return to “[D] Support”