UE32D6000 and samba vitual usb drive

Here for general support for D series TVs, request and problem solve area.
Post Reply

borath
Posts: 20
Joined: Wed Nov 02, 2011 4:01 am

UE32D6000 and samba vitual usb drive

Post by borath » Sun Mar 02, 2014 9:23 pm

Hello everyone!

Your help is needed to get the samba script working on the D6000.
The Problem is:
If i start SamyGO with samba enabled and the (04_04_samba.init adjusted), there appears a smb folder on the virtual drive, but it is and stays empty.

First my Network-Setup (all fixed IP-adresses):
192.168.1.100 is Windows 2008 SE file sharing server. Approx 10000 shared files with 10TB of data.
192.168.1.105 Samsung LE40B750 with SamyGO (works perfect)
192.168.1.110 Samsung UE32D6000 TW (samba doesn't work at all)
192.168.1.1 Router with newest firmware.

One thing before: fuseSMB works, but its extremely slow because of the hughe amount of files.

Because fuseSMB works, following common errors don't apply:
[*] Firewall/network related settings
[*] encoding setting of the scriptfiles (editor is notepad++)
[*] faults at the server

I tried
- using firmware 1011.5, 1090 (faked one) and 1014.
- I downloaded SamyGO extensions for D-Series directly from Sourceforge to my pc, extracted it and overwrote everything on the TV using ftp. (of course i adjusted the 04_04_samba.init script)

This is the debug output on starting samba-script:
SpoilerShow

Code: Select all

+ . /dtv/SGO.env
+ SYSROOT=/mtd_down/widgets/user/SamyGO/SamyGO
+ MOUNT_PATH=/dtv/usb/sda
+ export MOD_DIR=/mtd_down/widgets/user/SamyGO/SamyGO/lib/modules/2.6.30.9
+ export TMPDIR=/dtv
+ export HOME=/mtd_wiselink
+ export SMB_CONF_PATH=/mtd_down/widgets/user/SamyGO/SamyGO/etc/samba/smb.conf
+ LOGFILE=/mtd_down/widgets/user/SamyGO/SamyGO/samygo.log
+ LD_LIBRARY_PATH=/mtd_down/widgets/user/SamyGO/SamyGO/opt/privateer/lib:/mtd_down/widgets/user/SamyGO/SamyGO/opt/privateer/usr/lib:/mtd_down/widgets/user/SamyGO/SamyGO/lib:/mtd_down/widgets/user/SamyGO/SamyGO/usr/lib:/lib:/usr/lib:/mtd_swu/standalone:/mtd_cmmlib/Comp_LIB:/mtd_exe/lib:/mtd_cmmlib/YWidget_LIB:/mtd_contents:/mtd_cmmlib/InfoLink/lib/plugin/Static:/mtd_appdata/yahoo:/mtd_appdata/moip:/mtd_cmmlib/GAME_LIB:/mtd_appdata/gemstar:/mtd_cmmlib/DRM_LIB:/Java/lib:/mtd_cmmlib/InfoLink/lib:/dtv:/mtd_cmmlib/lib:/mtd_cmmlib/OIPF:/mtd_appext/Webkit:/mtd_appdata/Runtime/lib/CairoShadow:/mtd_appdata/Runtime/lib:/mtd_appdata/Runtime/XorgLibs
+ PATH=/mtd_down/widgets/user/SamyGO/SamyGO/opt/privateer/sbin:/mtd_down/widgets/user/SamyGO/SamyGO/opt/privateer/bin:/mtd_down/widgets/user/SamyGO/SamyGO/opt/privateer/usr/bin:/mtd_down/widgets/user/SamyGO/SamyGO/opt/privateer/usr/sbin:/mtd_down/widgets/user/SamyGO/SamyGO/sbin:/mtd_down/widgets/user/SamyGO/SamyGO/bin:/mtd_down/widgets/user/SamyGO/SamyGO/usr/bin:/mtd_down/widgets/user/SamyGO/SamyGO/usr/sbin:/usr/sbin:/usr/bin:/bin:/sbin:/etc/Scripts:/mtd_appdata/Runtime/bin
+ export ENV=/dtv/.ashrc
+ export FRAMEBUFFER=/dev/sam/fb0
+ export DISTROOT=/mtd_down/widgets/user/SamyGO/SamyGO/opt/privateer
+ USER=samsungtv
+ PASSWD=samsungtv
+ PERM=rw
+ [ -e /mtd_rwarea/smb_userdata ]
+ source /mtd_rwarea/smb_userdata
+ USER=samsungtv
+ PASSWD=samsungtv
+ SERVER=192.168.1.100
+ [ -z samsungtv
 ]
+ [ -z samsungtv
 ]
+ DEST_DIR=/dtv/usb/sda/smb
+ SERVER=192.168.1.100
+ SHARES=
+ FR_NAME=Samba Server
+ M_OPTS=rw,user=samsungtv
,password=samsungtv
,codepage=cp1250,iocharset=utf8
+ SERVERS=Don't set me!!
+ insmod /mtd_down/widgets/user/SamyGO/SamyGO/lib/modules/2.6.30.9/kernel/fs/cifs/cifs.ko
insmod: can't insert '/mtd_down/widgets/user/SamyGO/SamyGO/lib/modules/2.6.30.9/kernel/fs/cifs/cifs.ko': File exists
+ mkdir -p /dtv/usb/sda/smb
+ get_servers
+ [ -z 192.168.1.100 ]
+ SERVERS=192.168.1.100
+ get_shares
+ echo Search Shares
Search Shares
+ echo on: 192.168.1.100
on: 192.168.1.100
+ smbclient -s /mtd_down/widgets/user/SamyGO/SamyGO/etc/samba/smb.conf -U samsungtv
%samsungtv
 -g -L 192.168.1.100
+ grep Disk|
+ grep -v \$
+ grep -v  Service
+ sedcreating lame upcase table
creating lame lowcase table
 -r s/.*\|(.*)\|.*/\1/
+ sed -r s/ /SGOspace/g
+ S_MOUNTS=
+ [ -n  ]
So it seems that the script runs, and mounts smb folder to the virtual drive.
Either it does not add found files to the filesystem or the samba crawler doesn't find anything.

What could i try else?

Here you kindly find further technical informations:
Unbenannt.png
IMG_20140309_161051.jpg
IMG_20140309_160942.jpg
IMG_20140302_200047.jpg
You do not have the required permissions to view the files attached to this post.
Last edited by borath on Sun Mar 09, 2014 4:24 pm, edited 2 times in total.
Samsung LE40B750 T-CHL7DEUC 2004.1 - SAMBA works like charme

borath
Posts: 20
Joined: Wed Nov 02, 2011 4:01 am

Re: UE32D6000 and samba vitual usb drive

Post by borath » Mon Mar 03, 2014 8:27 am

I was so desperate that i read every single script that was enabled.
I found IP-Settings in various (by default) enabled scripts that of course dont match to my network. After fixing them/disabling unused the fusesmb-module speeded up significantally.
Instead of waiting 10-15 minutes fuseSMB it finds the shares within a few minutes.
Now it finds folders and most files, but fuseSMB seems to have problems if you share a hughe amount of files. So this solution is not satisfying.
Still not knowing what to do.

best regards,
B
Last edited by borath on Sun Mar 09, 2014 4:27 pm, edited 1 time in total.
Samsung LE40B750 T-CHL7DEUC 2004.1 - SAMBA works like charme

User avatar
juusso
SamyGO Moderator
Posts: 10125
Joined: Sun Mar 07, 2010 6:20 pm

Re: UE32D6000 and samba vitual usb drive

Post by juusso » Mon Mar 03, 2014 3:43 pm

as i wrote to you already, 03_03_juuso_nfsmount.init was just an example (together with some other scripts) of how to setup recording via nfs (to virtual USB). Seems it was bad idea and i`ll remove it from Extensions. ASAP
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

Post Reply

Return to “[D] Support”