Page 30 of 30

Re: Record TV over USB

Posted: Wed Nov 02, 2011 9:39 am
by rinaldinicri
LE40B650 (CI+) T-CHLCIPDEUC-2006.0
Same result recording on USB or NFS

It seems depending on the specific streaming that I try to record...
recording (.ts file) from the same channel normally not playable, but sometimes some recordings from the same channel can be played
I got the same result repeting the test.

Could be that depend on the channel stream?
(I'm in Italy)

I'm already using PVR+1.5 (02/10/2011) as far as I know this is the most updated version.
I cannot find a version 2.0 (even following your link)


Re: Record TV over USB

Posted: Sat Oct 27, 2012 7:29 am
by juusso
Topic was reorganized and divided to separate threads:
This is first try to make topic more user friendly and readable. Perhaps in future some of posts will be moved to separate thread too, to leave this topic clean from discussions about usage and bugs of apps, but not about recording TV over USB in general.

Re: Record TV over USB

Posted: Tue Jan 22, 2013 5:19 pm
by ingeras
trying to record on b550 ci+ model (using aston crypt cam)
firsts tests aren't working

did anyone try ?
what's the best filesystem for a usb stick to record ? (ntfs/ext3/other) ?

any other tips about : ./regrange 0x30110100 1 - or other mem range to check ?

here is log of my test

Code: Select all

Select> 66
Input Record File Name : /dtv/usb/sda1/rec01.ts
Video Pid: 0x3
input is 0x3
Audio Pid: 0x2
input is 0x2
PcrPid: 0x1
input is 0x1
__ REC FILE OPEN (/dtv/usb/sda1/rec01.ts, 34)
[iPVR  ] @[src/spIPvrStreamRec.c staPvr_StreamRecOpen 138]eFileType=17 stremType=1@
[iPVR  ] @[src/spIPvrStreamRec.c staPvr_StreamRecOpen 156]handl=0x231d190 and instanceNo=0@
[iPVR  ] @[src/spIPvrMdbRec.c staPvr_MdbRecOpen 203]eFileType=33 stremType=1@
[iPVR  ] &[src/spIPvrStreamRec.c staPvr_StreamRecRecTask 368]stateChange to Start ;hndl=0x231d190 inst=0&
[iPVR  ] &[src/spIPvrStreamRec.c staPvr_StreamRecRecTask 371]DMA_DONE ;hndl=0x231d190 inst=0 dataSize=0&
[iPVR  ] @[src/spIPvrStreamRec.c staPvr_StreamRecRecTask 375]pPvrMdbRecData->fd=0x200Size=0@
[iPVR  ] ~[src/spIPvrMdbRec.c staPvr_MdbRecRecTask 885]SPI_PVR_MDB_REC_MESSAGE_STARTbefore MakePID and BASE tbl;Instance=0 pP4
[iPVR  ] @[src/spIPvrMdbRec.c staPvr_MdbRecMakeBaseTable 462]pPvrMdbRecData->fd=0x201Size=64@
[iPVR  ] PID_TABLE: Table ID : 0x80
[iPVR  ] PID_TABLE: Video pid : 0x3
[iPVR  ] @[src/spIPvrMdbRec.c staPvr_MdbRecMakePidTable 502]pPvrMdbRecData->fd=0x201Size=64@
[iPVR  ] ~[src/spIPvrMdbRec.c staPvr_MdbRecRecTask 894]StateChangeToStart  ;Instance=0 pPvrMdbRecData=0x231cee4~

m_bOSDDisplay:1, m_bDynamicControlStatus:0, m_bSignalActivity:0, iSourceMode:201, ResInfo.IsPC:0 

~~[Sub System Error] SsWindowBase.cpp:Start():563 Window already Started....Return SS_NOT_OK


Re: Record TV over USB

Posted: Wed Jan 23, 2013 7:57 am
by ingeras
Hello i also have the same error
__ REC FILE OPEN (/dtv/usb/sda1/cap1.ts, 35) s
using DVB-C
and also the same display and strident sound
nostromo1983 wrote:As in sbva1 post:

Code: Select all

__ REC FILE OPEN (/dtv/usb/smb/, ffffffff)
means open is successful whereas mine return code (__ REC FILE OPEN (/dtv/usb/sda1/cap1.ts, 35) seems to mean it's unsuccessful
What is exactly this return code meaning, is it a return code of the "open" syscall?
I'm testing using my DVB-T and not DVB-C as you. Maybe it makes a difference and you need to input correct VPID,APID,PCRPID?
After stopping, the TV is frozen and i have 2 zero byte files cap1.ts and cap1.mdb. So it can open and create the file but it cannot capture frame of the TV.
The strange thing is when i do capture i have the same display i have when I'm on a DVB-T radio channel but it's producing a strident sound very annoying.
I don't know if there is a any PCR verbose mode i can use to troubleshoot this problem.

I can't test using network share (NFS) because 32B550 has no network card, but isn't is supposed to work with usb connected hard drive?

Re: Record TV over USB

Posted: Sun Jan 27, 2013 11:55 am
by ingeras
little update

test with vfta and ntfs

/dev/sda2 on /dtv/usb/sda2 type ntfs (ro,sync,uid=0,gid=0,fmask=0177,dmask=077,nls=utf8,errors=continue,mft_zone_multiplier=1)
/dev/sda1 on /dtv/usb/sda1 type vfat (rw,sync,fmask=0022,dmask=0022,codepage=cp437,iocharset=utf8,shortname=mixed)

can somone post how your usb hdd is mounted (mount options) ???

here is the result of ntfs
file open ok (but ntfs is mount read only ???)
Select> 66
Input Record File Name : /dtv/usb/sda2/test.ts
Video Pid: 0x0
input is 0x0
Audio Pid: 0x0
input is 0x0
PcrPid: 0x0
input is 0x0
__ REC FILE OPEN (/dtv/usb/sda2/test.ts, ffffffff)
Error set pvr Rec device(85221ff6)

still crashing after file open

Re: Record TV over USB

Posted: Sun Jan 27, 2013 12:05 pm
by juusso
don`t use ntfs disk, on tv it is always read only. Use fat32 for your tests.

Re: Record TV over USB

Posted: Sun Jan 27, 2013 1:53 pm
by ingeras
juuso wrote:don`t use ntfs disk, on tv it is always read only. Use fat32 for your tests.
I know
I used vfat (fat32) but i got error on open file
__ REC FILE OPEN (/dtv/usb/sda1/rec01.ts, 34)

what's strange is that i don't get that with ntfs (even if it fails laters as it's read only)
i will try to change dmask on mount for fat32
or try with ntfs-3g module

i try to mount a loop device from /dev/sda1 but i doesn't work
error message couldn't setup loop device :(