Page 1 of 1

Media.p shows only internal memory

Posted: Sat Oct 27, 2012 12:08 pm
by ebselarius
Hi guys,

I would be really grateful if you could help me on a little problem I have created for myself when trying to revert my firmware:

I followed the method "Fully automated way: activate Alternative Firmware from Content Library Manager" described in the wiki ... r_firmware. That did not seem to work as planned, but my TV still functions except for one thing: Now when I press the media.p button on my remote the only devices it shows me is the internal memory. I have decided that I dont understand enough of what I am doing so messing around with the firmware etc. is not my plan any longer. However, I do want to return my TV to its former abilities (dnla streamin), but I dont see the DNLA server any longer.

What did I do and how can I undo it?

Thanks so much,

Re: Media.p shows only internal memory

Posted: Sat Oct 27, 2012 12:35 pm
by juusso
ebselarius wrote:That did not seem to work as planned
what does it mean? what was planned and why don`t you think it failed? More detail please (what was planned? something went wrong? etc...)
If you got alternative firmware active, means your previous firmware is now alternative and you can always switch to it (=back to latest firmware).


you can download latest available firmware from samsung site and install it in normal way.

p.s. Strange why you haven`t used FFB.
p.p.s. Why you didn`t write your TV model, firmware version and number? From which to which have you downgraded.
p.p.p.s. Perhaps your DLNA server don`t work? Or maybe you forgot to set TV`s IP to have both in same subnet? Might problem is not at tv side at all.

Re: Media.p shows only internal memory

Posted: Sat Oct 27, 2012 1:07 pm
by ebselarius
Hi juuso,

thanks for your quick response!
My model is the LE32B653T5PXZG. I have the firmware 2008.2 (T-CHLCIPDEUC-2008.2). I originally had two issues I wanted to solve:
1) I wanted to try the Samba share implementation which I found on your project, as the DNLA server method was a pain and it doesnt auto-update the contents (server-side)
2) Because this model doesnt support DTS, and many of my vids are MKV with DTS tracks, I wanted to try your DTS "fix" for this model

So, I first set out and tried to implement the Samba share (samygo all-extensions), however, my TV's firmware seems to not allow running 3rd party software (I get the error not available). I scoured the forums and found that this is just the way it is with my firmware. I didnt try to use the DTS fix, as it will face the same firmware related problem.
Next up I thought it might be a good idea to roll-back my firmware (I upgraded the firmware myself - didnt know about samygo or the restrictions it would impose back then). At this point in time I did not know about the CI+ issues and that rolling back firmware is not supported by the samygo project for B-Series CI+ devices. The wiki afterall states "CI and CI+". So I went through the steps in the Wiki (enable wiselink; copy over the files contained in telnet-enabler.tar.gz; run the trojan).

However, nothing happened for a long while (I waited 10 minutes). I then turned off the TV and back on again. TV worked fine. Later I tried to reach my DNLA server, but I could only find the device "internal memory", which was not there before. Seeing as I have gotten access to the internal TV memory (somehow) I checked whether my firmware could now be rolled back. However, the firmware upgrade option in the menu is now greyed out.

I have meanwhile restarted my TV twice, and am only now able to see the DNLA server again (still see the internal memory as a device for some reason...). So, I supposed it fixed itself...
If there is any way that I could get the Samba share and DTS fix to work on my model it would be great, but to my understanding this is not possible with the firmware and CI+ device I have.

Greets and thanks for the help and quick reply,

Re: Media.p shows only internal memory

Posted: Sat Oct 27, 2012 4:10 pm
by juusso
Achso, this is more complicated, your TV is CI+. Well, lucky if not bricked after procedure. But seems yo`ve not downgraded (to be sure, what is actual firmware on the first service menu screen?).
To get SamyGO apps working (including samba shares and dts cip version), you have to run T-CHLCIPDEUC-2006.0. Then TV accepts third party apps an you be able to use them on your TV.
Moreover, if you need autostart of such apps, then you need patched firmware to be installed, else if you start apps manually (every time after tv power on), you can use original firmware.
Here is no other way for downgrade, just to flash all required partitions by hand or by script.

Optional, the initial working version, ffb_cip (which worked fine) is available too, as the official FFB doesn`t support ci+, these test apps are ok and do the job well.

Re: Media.p shows only internal memory

Posted: Sat Oct 27, 2012 5:35 pm
by ebselarius
Hi again,

thanks for the reply. Lucky indeed that I didnt brick my TV. :)
I am thinking of giving the whole procedure another try, but since I am a bit scared I would need a bit of help. Would you be able to guide me through what needs to be done? How safe is it to reflash my firmware back to 2006.0?
I will be off today, so I wont respond til tomorrow.
Thanks in advance for your help.


p.s. @achso: if its easier for you to reply in German, feel free :)

Re: Media.p shows only internal memory

Posted: Sun Oct 28, 2012 8:55 am
by juusso
As you probably have seen already, reflashing procedure of CI+ devices has big potential to brick. This is why i removed function from FFB. But the true reason to stop support of CI+ was - missing testers and test TV to handle all possible errors.
As i said, the first special ffbcip test versions worked w/o any problems, i`m going to add some security checks and release as standalone cip version of FFB.

In any case, procedure is dangerous, but not fatal.