How to enable file transfer via FTP (Read only permissions)

Here for general support for B series TVs, request and problem solve area.
Post Reply

User avatar
oldman
Posts: 57
Joined: Sat May 26, 2012 12:43 am
Location: Prague

How to enable file transfer via FTP (Read only permissions)

Post by oldman » Sun Feb 10, 2013 9:58 pm

I would like to use the FTP for transfer files to an external USB hard drived plugged to the TV but I have read-only permissions.
When copy via ftp starts I get this message: 553 error: Read-only file system.

Is there any way to change the file system permissions to write to USB hard drive via FTP?

I tried to change the sda1 folder permissions via telnet/Ex-link without success:

Code: Select all

# chmod -R 755 /dtv/usb/sda1
chmod: /dtv/usb/sda1: Read-only file system
my hdd drive:

Code: Select all

Device model = 5000BEV External
Device vendor = WD
Partition ID = 0
Partition Path = /dtv/usb/sda1
Partition FS = ntfs
Partition Serial = 57442D57584E5A30384
Partition Devpath = 1.1
Partition Lun = 0
Capacity = [129215212/488384000]
Storage ID = 0x0
TV Model: LE37B550A5W / LExxB55x
Model code: LE37B550A5WXXH
Firmware: T-CHL5DEUC-2008.0-v0.24-GMT2-ArFIX2-ADFIX-fwver-net-auto
40" Samsung UE40F6400

User avatar
geo650
Official SamyGO Developer
Posts: 302
Joined: Wed Oct 07, 2009 12:03 pm

Re: How to enable file transfer via FTP (Read only permissio

Post by geo650 » Sun Feb 10, 2013 10:19 pm

You cannot write to NTFS partition, via FTP or even directly. You can write to FAT[32] or ext2 partitions.

User avatar
oldman
Posts: 57
Joined: Sat May 26, 2012 12:43 am
Location: Prague

Re: How to enable file transfer via FTP (Read only permissio

Post by oldman » Sun Feb 10, 2013 10:32 pm

Oh, the problem is ntfs :cry: ... So there is no reason to try SAMBA.

Thanks a lot
40" Samsung UE40F6400

User avatar
geo650
Official SamyGO Developer
Posts: 302
Joined: Wed Oct 07, 2009 12:03 pm

Re: How to enable file transfer via FTP (Read only permissio

Post by geo650 » Wed Feb 13, 2013 8:52 pm

oldman wrote:Oh, the problem is ntfs :cry: ... So there is no reason to try SAMBA.
NTFS partition becomes writable when you use SAMBA (CIFS) for external disk (shared on LAN/WAN). I don't know if it can be writable with locally attached disk.

User avatar
oldman
Posts: 57
Joined: Sat May 26, 2012 12:43 am
Location: Prague

Re: How to enable file transfer via FTP (Read only permissio

Post by oldman » Thu Feb 14, 2013 12:21 am

Thanks for the tip. Finally, I found the solution in this forum.

I formatted my external hard drive (locally attached) from NTFS to Ext3 and add the EXT3 partition support. It works great! I also solved the ext3 support in Windows 8 x64, so I have no problems with this ext3 filesystem.

In addition, I use the next hard drive connected to the router via NFS and virtual USB. Now I have the option to use both usb hard drives in Media Player including the ability to writing via FTP :)

I got everything I needed: network support, remote control, channel info. (it is a pity that the use of the dca module overload my tv and the tv does not support a PVR. Never mind, I can live without it)

Thank you to all who have contributed in this great work on SamyGO and support.
40" Samsung UE40F6400

User avatar
juusso
SamyGO Moderator
Posts: 10125
Joined: Sun Mar 07, 2010 6:20 pm

Re: How to enable file transfer via FTP (Read only permissio

Post by juusso » Thu Feb 14, 2013 8:30 am

Also you can use ntfs-3g to get ntfs mounted as read/write. Anyway, glad to know everything works!
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

User avatar
oldman
Posts: 57
Joined: Sat May 26, 2012 12:43 am
Location: Prague

Re: How to enable file transfer via FTP (Read only permissio

Post by oldman » Thu Feb 14, 2013 8:23 pm

juuso wrote:Also you can use ntfs-3g to get ntfs mounted as read/write...
Thanks for the tip but I cannot. I tried NTFS-3g several times but it always failed to start via injectso.

Code: Select all

# /mtd_rwarea/SamyGO/bin/injectso $(pidof exeDSP) /mtd_rwarea/SamyGO/app/ntfs3g/telnet.so Game_Main /mtd_rwarea/SamyGO/app/ntfs3g/

Module injector V1.2 for ARM based CPUs.
(copyleft) SmartSmurf 2010 (smartsmurf@shared-files.de)

Info: Import dlopen set at 0x004ae424
Info: Import dlsym set at 0x004ada34
Info: Import dlclose set at 0x004ad50c
Info: current register set:
R0 =0xFFFFFFFC R1 =0x00000000 R2 =0x00000001 R3 =0x00000000
R4 =0x00000001 R5 =0x5E702180 R6 =0x0200C0D8 R7 =0x000000F0
R8 =0x00000000 R9 =0x00000000 R10=0xBE9F7A78 R11=0x00000000
R12=0x00000001 SP =0xBE9F7A68 LR =0x4005DA44 PC =0x4005B008
CPSR=0x80000010

Info: new SP for inject code 0xBE9F7668
Done.
# Remounting sda1
pgd = c36ac000
[00000000] *pgd=636c9031, *pte=00000000, *ppte=00000000
task stack info : pid(424) stack area (0xbe8fd000 ~ 0xbe912000)
* USB detected *
Segmentation fault (core dumped)
sda1 after run injectso:

Code: Select all

# cd /dtv/usb/sda1
# ls -l
-rw-------    1 root     0          118784 Jan  1 00:01 Coredum
40" Samsung UE40F6400

User avatar
oldman
Posts: 57
Joined: Sat May 26, 2012 12:43 am
Location: Prague

Re: How to enable file transfer via FTP (Read only permissio

Post by oldman » Sat Feb 16, 2013 11:32 am

One more question about FTP...

I use ftp (total commander) for transfer files from PC to TV. I do not know what the problem is but I can not start script until ftp is active.

Example: FTP transfer "test.sh" file from PC to /mtd_rwarea/SamyGO/test.sh (dest file is chmoded to 755). An error appear when excuting this script in the telnet and ftp is still connecting:

Code: Select all

# /mtd_rwarea/SamyGO/test.sh
-sh: /mtd_rwarea/SamyGO/test.sh: Text file busy
So, when I disconnect ftp and run the script again, everything is ok. Disconnecting ftp after each transfer is very frustrating. What causes this error?
40" Samsung UE40F6400

Post Reply

Return to “[B] Support”