ex-link doesn't connect prpperly

Here for general support for B series TVs, request and problem solve area.
Post Reply

Posts: 2
Joined: Wed May 01, 2013 6:57 pm

ex-link doesn't connect prpperly

Post by walter »

Hello people,

I need some help from you, because didn't find a reason that causes my problem with UE32B600 samsung tv...

At least one year ago I patched the firmware of my samsung with samygo firmware to enable telnet and network through USB-dongle or USB-ethernet adaptor, I built my ex-link cable and my own Samygo.sh script to start telnet daemon and mount NFS shared folder for play LAN videos. I did it following the wiki and it worked fine and I was happy...

Two or three weeks ago I did a modification on Samygo.sh to change some parameters like host, NFS folder or similar... ((I don't remember very well) and something went wrong because after this, the network adapter doesn't work more, and if I haven't network I have nothing at all..

now I don't have a PC with COM port so I couldn't use my exlink cable and get a terminal with TV ... the normal function on TV goes working fine... except for network that it was enabled.

Today, one friend give me a USB-COM adaptor, so now I have a complete exlink cable with USB-COM & COM-minijack, and I can connet with my tv, in theory, because in the practice I can't get a terminal connection... I follow the wiki procedure:
On a Linux PC, install 'cu' (call up) tool from the uucp package and run
cu -l /dev/ttyUSB0 -s 115200
OK. When TV starts the startup.log appears on my console showing a lot of messages and ends with...

Code: Select all

@@@@@@@@@@@@USBEventHandler => Start@@@@@@@@@@@@@@@@@@@@@
USBEventHandler Init
USB : From now, no more insmod
[DEV_BOOTON ] [static void* UsbMountService::do_UsbFault(void*)] do_UsbFault ======== START ========
[DEV_BOOTON ] [static void* UsbMountService::do_UsbFault(void*)] TDBuilder::GetTDiSystem() success...
insmod: cannot insert `/mtd_boot/modules/usb_fault.ko': File exists (-1): File exists
[UsbMountService::  usb module exist already.. so do not insmod usb ]
USB : Exit Load USB module

PTP_API_Init() successfull
CSingleCECAppBase::t_Create() : 0 (1:RTL, 0:LTR)[bool CUSBAppEventHandler::Init() - 52] 
USB Modules are already installed
1 (0): #### this : 264f1b8, pReceived : 2650604
m_bOSDDisplay:0, m_bDynamicControlStatus:0, m_bSignalActivity:1, iSourceMode:201, ResInfo.IsPC:0 

But when i follow the next step and introduce the keyword "debug" in the console, nothing happens, and I remember that is not correct... I have used the ex-link cable previously (without USB-COM adapter) and it worked like wiki says...
Enter "debug" at the invisible prompt ... to enable your serial console.
You should see something like below with each keystroke
[SERIAL INPUT MANAGE] 1-th ENABLE Magic serial input match!
[SERIAL INPUT MANAGE] serial input ENABLE!!!!!
so, Can you give me some clue about what it can be happening ??

the only thing that I have is the complete startup log in console, I read some fails with samygo.sh script (It's normal because network is not running) but I can't understand more and I don't know why the hyperterminal isn't working at this moment...

thanks for your help people; It's all I can say for now
You do not have the required permissions to view the files attached to this post.

User avatar
SamyGO Moderator
Posts: 10124
Joined: Sun Mar 07, 2010 6:20 pm

Re: ex-link doesn't connect prpperly

Post by juusso »

No idea what happen, but you have to input
before you get disconnection. Be quick and start as soon you will see :
----------- Kernel Loading End------------

Application is started..
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]


Posts: 2
Joined: Wed May 01, 2013 6:57 pm

Re: ex-link doesn't connect prpperly

Post by walter »

thanks for your answer

NO sorry it doesn't work, I can't type nothing ... I will try a native com port instead a USB/COM adapter, maybe the problem was that I can type nothing in the console....

Next day edit:

I have tested the ex-link cable without USB adapter and happens the same issue... I can input no key with the keyboard when console connection by exlink cable begins.... All my happiness went away

Post Reply

Return to “[B] Support”