[App] PVR+ 3.x

Here are software that related with Samsung B series TVs. Like hex editors, new version of BusyBox or internal software, app programs that will run in your TV hardware.:!:This forum is NOT FOR USER QUESTIONS or Problems.

Posts: 27
Joined: Sun Mar 03, 2013 2:36 am

Re: [App] PVR+ 3.x

Post by mjuti »

Thanks geo650, you are fantastic, I try this asap.

EDIT: Unfortunately it does not work for me: still no sound on tv plus no sound on pc either ( before processing it sucks only on tv, on pc it runs well with sound )

User avatar
Official SamyGO Developer
Posts: 302
Joined: Wed Oct 07, 2009 12:03 pm

Re: [App] PVR+ 3.x

Post by geo650 »

mjuti wrote:TSfix... it does not work for me: still no sound...
Please upload source TS file(s) to any web file hosting service and send me downloading link(s) via PM or here on forum. Thanks.

Posts: 27
Joined: Sun Mar 03, 2013 2:36 am

Re: [App] PVR+ 3.x

Post by mjuti »

PM sent

Posts: 36
Joined: Wed May 05, 2010 9:31 pm
Location: Bucharest, Romania

Re: PVR+ 3.x

Post by gchirtoaca »


Sorry to revive this old thread message. I recently received a CI+ CAM module from my cable operator. It's a NagraVision 2 Kudelsky CAM. It works well. Image: http://2.bp.blogspot.com/-tp3mye6W9sQ/U ... CS+RDS.jpg .
I used PVR+ 3 successfully until now, for unencrypted channels, HD or SD. With the CAM connected, I have the exact same behaviour as described below. When I press the record button, the TV program reception, encrypted or not, stops and I have to restart the TV. Is there a way to record at least the unencrypted channels, when the CAM is connected? Thanks.
volksvertreter wrote:
volksvertreter wrote:Thx for your work!

But on mine it doesn't work:

- start tv
- start pvr+
- start recording (dvb-c, no HD content)
- picture and audio freezes/stop playing, after a few seconds the screen goes black
- timecode is counting, osd is displayed
- in the middle of the screen i see "signal encrypted" / "Signal verschl?sselt" < german
- after i press stop it says "recording deleted"
- now i have to turn of the tv to get a tv-picture back!

My TV:
- firmware is patched by the script in the wiki
- Version: 2009/11/12_002006
- Modellcode: LE40B650
- telnet is enabled by boot

any ideas?

ok guys, it started fresh with a new flash and default settings of the tv.
First test:
- removed CI+ with SmartCard (Kabel Deutschland)
- tried to record a none-HD-Channel that is unencrypted
- That worsk fine
- BUT: The TV's MediaPlayer cannot play the "*.ts" FileFormat? Is that right?
- on my Mac with the VLC Player i have to switch to 3rd Audio-Track/Channel to hear sound!? Is that normal?

Second Test WITH CI+:
- tried to record a none-HD-Channel that is unencrypted
- Picture freezes,
- DatenDienst (<<thats German for DataService)
- Pressing Stop: Record deleted....

I saw the CI+ Movie on youtube.... is it possible that "Kabel-Deutschland" sent out data that has modified my CI+/SmartCard that disabled recordings?
In the past PVR1.0, geopvr .... worked just fine....

Nice gift KabelDeutschland... f*** you.

CI+ Module and SmartCard Specs:

The blue CI+ Module produced by SMIT
Picture of the card is attached...
P/N: RET.BTLDR.1.1.3
V/N: 1660N_4.0.3.1

KabelDeutschland SmartCard (german provider)
- it's a G09 card

@ The Forum/Board-Administrator: "Your post looks too spamy for a new user, please remove off-site URLs." It's not possible to do complete posts with that damn posting restrictions cause of that pseudo spam-bot! i'm also not able to attach external pictures...
Samsung LE37B653T5PXZG, T-CHLCIPDEUC 2008.2 firmware, Advanced Mode Patch

Posts: 8
Joined: Sun Oct 27, 2013 8:22 am

Re: [App] PVR+ 3.x

Post by sacredslayer6 »

Is there any way to make it work on firmware T-CHU7AEAC 2004.0 OR 2005.0? My tv model is B series CL model UA40B7000, when i tried this app i got an error on tv.

Posts: 1
Joined: Sun Feb 16, 2014 7:45 pm

Re: [App] PVR+ 3.x

Post by Benson »

Hello Geo650,

I'm trying to use your application on a UN46B8000XF. It's running a modified SamyGO firmware T-CHE7AUSC 1013..
The issue i have is when i try to load your app, i have the following error:

# cat /mtd_ram/PVRplus_debug.log
injector() started
self open
loading main module:
cannot open main module:
/mtd_tlib/GGame/PVRplus/pvrplus.so: undefined symbol: _ZN8TCWindow9MuteVideoEb

This seems to be related to the fact that the exeDSP shipped with my firmware does not contain this symbol. Is there any way to:
- update my exeDSP to include this (use the one from another firmware?), or
- modify pvrplus.so so that it doesn't ask for it?

I've scoured the forums, wiki and the interwebs for the last 3 days, (i've even read polish manuals!) with no luck. Any help will be appreciated :)

Posts: 3
Joined: Tue Mar 18, 2014 4:29 pm

Re: [App] PVR+ 3.x

Post by albatim »

Hi guys,
wonderful app.

Here is localization file in italian language. Maybe someone will appreciate it.
You do not have the required permissions to view the files attached to this post.

Posts: 70
Joined: Fri Apr 30, 2010 8:24 am

Re: [App] PVR+ 3.x

Post by baco81 »

After upgrading from PVR+ 3.0 to PVR+ 3.1, my custom scripts stopped working.

The only script I currently use is yellow.sh. For some reason, It is not being executed in version 3.1. I checked file permissions and they are OK. If I go back to version 3.0, the script is correctly executed.

I think the problem is related to the yellow button not being hooked up by PVRplus 3.1 as the following warning is displayed if I press it: "Not available".

I am only talking about the yellow button because is the only custom script that I have set up at the moment, but I think this issue affects all of the color buttons.

Geo650, could you take a look at the issue, please? Other than this, I am very happy with PVRplus ;)

Posts: 70
Joined: Fri Apr 30, 2010 8:24 am

Re: [App] PVR+ 3.x

Post by baco81 »

baco81 wrote:Geo650, could you take a look at the issue, please? Other than this, I am very happy with PVRplus ;)
Well, no need anymore.

It's working now. I don't know what was wrong before nor what did the trick, either. It wasn't a permission issue, for sure: same script and same permissions (I double-checked it). But the important thing is that the script is being executed now.

BTW, I recently bought a NAS and PVRplus records on it quite nicely over samba.

Thanks again, Geo650 for such a lovely PVR application ;)

Posts: 15
Joined: Tue Nov 05, 2013 6:54 pm

Re: [App] PVR+ 3.x

Post by BigNerd95 »

codyrocco wrote:device: UE32B7020

first of all i run SamyGO extensions, to find shares and create mountpoints; then i run PVRPlus 3.1
unfortunately, i'm obtaining an error - "Cannot execute script!" - when i'm trying to record something (PVRPLus is set to record into MOVIE001, not in Auto).
Just found solution! The executable of PVRPlus, before launching any script, controls if telnetd is running (with ps command), if not launch telentd then controls it againg and launch your script, but it FAILS
So to solve this stupid problem, i made a "faketelnetd" script containing an infinite loop and i launch it at all boot inside SamyGo.sh, so when PVRPlus controls if telnetd is present in "ps", now yes! there is a process containing "telentd", and it runs your script succesfully ;-)

Post Reply

Return to “[B] Software”